Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35

Thread: Can I remove Pulse Audio to fix glitchy sound? 11.4 KDE HDAIntel

  1. #1
    Join Date
    Jan 2011
    Location
    Riverside, Ca.
    Posts
    220

    Default Can I remove Pulse Audio to fix glitchy sound? 11.4 KDE HDAIntel

    I hear Pulse Audio is the culprit of all the sound issues. I would like to remove it, and default to straight ALSA or whatever distros like Fedora and Ubuntu use, which has never been problematic for me.

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Can I remove Pulse Audio to fix glitchy sound? 11.4 KDE HDAIntel

    In my opinion I do not advice you to do it.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    961

    Default Re: Can I remove Pulse Audio to fix glitchy sound? 11.4 KDE HDAIntel

    Quote Originally Posted by Shadowolf7 View Post
    I hear Pulse Audio is the culprit of all the sound issues. I would like to remove it, and default to straight ALSA or whatever distros like Fedora and Ubuntu use, which has never been problematic for me.
    Not sure about ubuntu but the latest Fedora uses pulseaudio by default.
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  4. #4
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Can I remove Pulse Audio to fix glitchy sound? 11.4 KDE HDAIntel

    Quote Originally Posted by ah7013 View Post
    Not sure about ubuntu but the latest Fedora uses pulseaudio by default.
    From what I read in reviews, Ubuntu uses pulseaudio as its default sound server.

  5. #5
    Join Date
    Jan 2011
    Location
    Riverside, Ca.
    Posts
    220

    Default Re: Can I remove Pulse Audio to fix glitchy sound? 11.4 KDE HDAIntel

    Hilarious. So once again its a glitch that is openSUSE specific. Like the KDE and plasma crashes with NVidia driver in 11.3. With bugs like this, I seriously have to wonder who is asleep on the job.

    Ok, so if I can't remove it how can I fix the skipping and all that? How can we start troubleshooting it?

  6. #6
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Can I remove Pulse Audio to fix glitchy sound? 11.4 KDE HDAIntel

    Quote Originally Posted by Shadowolf7 View Post
    Ok, so if I can't remove it how can I fix the skipping and all that? How can we start troubleshooting it?
    If you use the forum's search facility, you will find out how a few users (KDE) removed P/A to use ALSA exclusively. I don't believe you can simply remove P/A on Gnome, but then Gnome from 11.3 onwards has it as default sound server.

    Start troubleshooting? Use the forum's search facility and you will find some successes and failures. If you are a KDE user, sometimes installing "pavucontrol" can help. If Gnome, I think it's installed by default.

  7. #7
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: Can I remove Pulse Audio to fix glitchy sound? 11.4 KDE HDAIntel

    You can disable Pulse. In YaST's "Sound" there is button in the bottom-right corner labeled "Other" and when you click it an menu opens. Select "Pulse Audio configuration ..." and uncheck "Enable Pulse Audio Support".

    I am not quite sure what else may need to be done though.

  8. #8
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: Can I remove Pulse Audio to fix glitchy sound? 11.4 KDE HDAIntel

    Quote Originally Posted by consused View Post
    If you use the forum's search facility, you will find out how a few users (KDE) removed P/A to use ALSA exclusively.
    I had Pulse disabled until yesterday. However, Pulse is working fine now. In fact some things are better with Pulse, while others are not.

  9. #9
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Can I remove Pulse Audio to fix glitchy sound? 11.4 KDE HDAIntel

    Quote Originally Posted by Lord_Emsworth View Post
    I had Pulse disabled until yesterday. However, Pulse is working fine now. In fact some things are better with Pulse, while others are not.
    Glad to get that feedback, thanks. I'm still using P/A.

  10. #10
    Join Date
    Jan 2011
    Location
    Riverside, Ca.
    Posts
    220

    Default Re: Can I remove Pulse Audio to fix glitchy sound? 11.4 KDE HDAIntel

    Quote Originally Posted by Lord_Emsworth View Post
    You can disable Pulse. In YaST's "Sound" there is button in the bottom-right corner labeled "Other" and when you click it an menu opens. Select "Pulse Audio configuration ..." and uncheck "Enable Pulse Audio Support".

    I am not quite sure what else may need to be done though.
    This didn't seem to change a single thing. None of the behavior changed.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •