Results 1 to 10 of 10

Thread: ssh issue with 11.4

  1. #1

    Default ssh issue with 11.4

    I use Quanta to edit my remote server files using ssh. I had no problem until yesterday when I upgraded from OpenSUSE 11.3 to 11.4. Now when I try to open a remote file via sftp, I get the message "Error while talking to SSH" my first guess was that port 22 was closed by the firewall, but I still can open remote directories using Dolphin. This is an essential part of my work. Please help!

  2. #2
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: ssh issue with 11.4

    On 2011-04-10 16:36, racc11 wrote:
    >
    > I use Quanta to edit my remote server files using ssh. I had no problem
    > until yesterday when I upgraded from OpenSUSE 11.3 to 11.4. Now when I
    > try to open a remote file via sftp, I get the message "Error while
    > talking to SSH" my first guess was that port 22 was closed by the
    > firewall, but I still can open remote directories using Dolphin. This is
    > an essential part of my work. Please help!


    Try ssh on a terminal. Perhaps on verbose mode.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  3. #3

    Default Re: ssh issue with 11.4

    Gracias Carlos,
    I made a mistake while typing so I am editing this message.
    I was able to connect to the server using terminal and ssh. It seems to be a problem with Quanta.

    I can login through Dolphin using fish://

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: ssh issue with 11.4

    Are we talking both SUSE machines?
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5

    Default Re: ssh issue with 11.4

    The remote server is Debian
    It is weird. Quanta can access remote files in another server via ftp but not sftp. It seems like ssh is blocked for Quanta.
    ...
    OK I found a workaround. The sftp:// url doesn;t work but apparently fish:// does. Can somebody explain this to me?

    Thanks

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: ssh issue with 11.4

    I have had the same issue with debian. I can't figure it out.
    I just switched the server to SUSE with the exact same settings and it works.

    This was my exact problem:
    For me ssh in the terminal was fine. fish:// from konqueror was fine
    But using the connect to server from Nautilus gives a sftp error like this:
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7
    Join Date
    Aug 2009
    Location
    metro-welfare, MI США
    Posts
    115

    Default Re: ssh issue with 11.4

    I am seeing the same issue on my newer openSuSE systems running KDE.
    Most of my network shares (bookmarked in konqueror or that crappy dolphin) where created using sftp, but some where fish protocol.
    On systems 11.2 thru my newest 11.4 I don't even see the ability to create a sftp 'network connection' (konqueror > Go, Network folder> Make Network Folder (script, bm)... SSH is the choice (there is 'real' ftp and microsucks, but where dealing with Linux here)..
    When I finish creating the 'connection', it is Always a 'fish:' 'shortcut' or link...
    Why?
    Is one better than the other and why should I care.
    I remember in the past (2 years ago maybe) I had to add or start a services something like sftp in YaST2> Network Services (xint) or something???

    again, is one better (more like the 'browsing' a 'local drive) than the other?
    I can't even remember why this was an issue for me 2 years ago...: (

    Thanks in advance,
    Спасибо,
    Landis.

  8. #8
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: ssh issue with 11.4

    In kde
    I always use fish://
    And do it by just typing directly to the address bar
    Once you have connected, drag the link in the address bar to the bookmarks in konqueror or to places in dolphin
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  9. #9
    Join Date
    Aug 2009
    Location
    metro-welfare, MI США
    Posts
    115

    Default Re: ssh issue with 11.4

    **** laptops and the quire ass 'touchpad'... that should have been dropped in the early '90's
    I wrote a whole paragraph here, but f*ing pad and it's gone.
    I'm not rewriting the whole how to, but the option for sftp and fish is associated with a script I am missing on my main system called 'Network Services'.
    I'll write later how to resolve this,,
    Right now I'm pissed about these faggy touchpads.....

    Landis.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: ssh issue with 11.4

    I try not to touch mine. It's very sensitive
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •