Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Zypper says: "will not be installed: ..."

  1. #1

    Default Zypper says: "will not be installed: ..."

    I'm trying update this code:
    Code:
    sudo zypper up
    output:
    Code:
    baris@linux-suse:~> sudo zypper up
    root's password:
    Retrieving repository 'KDE:KDE3' metadata [done]
    Building repository 'KDE:KDE3' cache [done]
    Retrieving repository 'openSUSE:Factory:Contrib' metadata [done]
    Building repository 'openSUSE:Factory:Contrib' cache [done]
    Retrieving repository 'pacman' metadata [done]
    Building repository 'pacman' cache [done]
    Loading repository data...
    Reading installed packages...
    
    The following package updates will NOT be installed:
      aria2 dcatools faac faad2 gstreamer-0_10-fluendo-mp3 gstreamer-0_10-lang gstreamer-0_10-plugins-bad gstreamer-0_10-plugins-base 
      gstreamer-0_10-plugins-farsight gstreamer-0_10-plugins-good kdelibs3-default-style lame libass4 libdca0 libdnet1 libdrm libdvbpsi6 
      libexiv2-9 libfaac0 libfaac-devel libfaad2 libfarsight2_0 libfluidsynth1 libgssdp-1_0-2 libgupnp-igd-1_0-3 libkate1 libkate-tools liblash1 
      libmad0 libmp3lame0 libmpeg2-0 libopencore-amrnb0 libopencore-amrwb0 libopencv2_2 liborc-0_4-0 libpcap1 libschroedinger-1_0-0 libshout3 
      libtag-extras1 libtorrent-rasterbar6 libtwolame0 libvdpau1 libvisual libvlc5 libxine1-gnome-vfs libxine1-pulse libxvidcore4 mp4v2 mpeg2dec 
      net-tools openslp python-libtorrent-rasterbar python-simplejson qt3 twolame wget xinetd 
    
    The following package is going to be upgraded:
      pdfedit 
    
    1 package to upgrade.
    Overall download size: 2,1 MiB. No additional space will be used or freed after the operation.
    Continue? [y/n/?] (y): y
    Retrieving package pdfedit-0.4.3-1.5.i586 (1/1), 2,1 MiB (6,3 MiB unpacked)
    Retrieving: pdfedit-0.4.3-1.5.i586.rpm [done (897,9 KiB/s)]
    Installing: pdfedit-0.4.3-1.5 [done]
    why does it say?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Zypper says: "will not be installed: ..."

    You may have use the package switch to hold them to a different provider like packman

    zypper up will not break that setting, which is good.

    I assume you followed the multi-media guide and did this
    http://dl.dropbox.com/u/10573557/Swi...man_switch.png
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Zypper says: "will not be installed: ..."

    On 04/09/2011 08:06 PM, barisuse wrote:
    >
    > baris@linux-suse:~> sudo zypper up
    > root's password:
    > Retrieving repository 'KDE:KDE3' metadata [done]
    > Building repository 'KDE:KDE3' cache [done]
    > Retrieving repository 'openSUSE:Factory:Contrib' metadata [done]
    > Building repository 'openSUSE:Factory:Contrib' cache [done]


    why are you accessing kde-THREE repositories??
    and, why are you using Factory..

    if you are an experienced Linux guru, then those are ok things to do..

    are you a programmer, developer, or expert software *tester*?

    or more like a 10+ year user, like me? if you are not an expert, please
    show us the output of entering the following into a terminal

    Code:
    zypper lr -d
    and copy/paste the output back to this thread using the instructions
    here: http://goo.gl/i3wnr

    and, please tell us what openSUSE version are you using, and what
    version of which desktop environment?

    --
    CAVEAT: http://is.gd/bpoMD [NNTP via openSUSE 11.3 + KDE4.5.5 +
    Thunderbird3.1.8] Can you believe it? This guy Ralph wins $181 million
    in the lottery last Wednesday, and then finds the love of his life just
    2 days later. Talk about LUCK!

  4. #4

    Default Re: Zypper says: "will not be installed: ..."

    @caf4926, i did it but, did not solve..
    @DenverD, I dont know why it was so... Im a programmer. Im using openSUSE 11.4 KDE desktop

    zypper -lr d
    Code:
    #  | Alias                    | Name                     | Enabled | Refresh | Priority | Type   | URI                                                                                 | Service
    ---+--------------------------+--------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------+--------
     1 | KDE:KDE3                 | KDE:KDE3                 | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/KDE3/openSUSE_11.4/                  |        
     2 | google-chrome            | google-chrome            | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/i386                                   |        
     3 | network:utilities-11.4   | network:utilities-11.4   | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/repositories/network:/utilities/openSUSE_11.4/         |        
     4 | openSUSE-11.4-Source     | openSUSE-11.4-Source     | Yes     | No      |   99     | yast2  | http://download.opensuse.org/source/distribution/11.3/repo/oss/                     |        
     5 | openSUSE:Factory:Contrib | openSUSE:Factory:Contrib | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Factory:/Contrib/openSUSE_11.4/ |        
     6 | packman-11.4             | Packman                  | Yes     | No      |   99     | rpm-md | http://packman.jacobs-university.de/suse/openSUSE_11.4                              |        
     7 | repo-11.4-non-oss        | openSUSE-11.4 Non-OSS    | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss                         |        
     8 | repo-11.4-oss            | openSUSE-11.4 OSS        | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/                            |        
     9 | repo-11.4-update         | openSUSE-11.4 Updates    | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/update/11.4                                            |        
    10 | vlc-11.4                 | VLC-11.4                 | Yes     | No      |   99     | rpm-md | http://download.videolan.org/pub/vlc/SuSE/11.4                                      |

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Zypper says: "will not be installed: ..."

    On 04/10/2011 10:36 AM, barisuse wrote:
    >
    > @DenverD, I dont know why it was so..


    it is so because you need to remove (or disable and cease refreshing)
    these, at least:


    > # | Alias | Name | Enabled | Refresh | Priority | Type | URI | Service
    > ---+--------------------------+--------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------+--------
    > 1 | KDE:KDE3 | KDE:KDE3 | Yes | Yes | 99 | rpm-md | http://download.opensuse.org/reposit...openSUSE_11.4/ |
    > 6 | packman-11.4 | Packman | Yes | No | 99 | rpm-md | http://packman.jacobs-university.de/suse/openSUSE_11.4 |
    > 10 | vlc-11.4 | VLC-11.4 | Yes | No | 99 | rpm-md | http://download.videolan.org/pub/vlc/SuSE/11.4 |
    >


    personally (and many here use this as standard practice) i normally only
    have four enabled: oss, non-oss, update and packman

    but, maybe as a programmer you wanna live dangerously.

    --
    CAVEAT: http://is.gd/bpoMD
    [NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]
    Maybe the developers are not here because they are so busy fixing these>
    http://tinyurl.com/392jnb

  6. #6

    Default Re: Zypper says: "will not be installed: ..."

    I deleted packman, vlc-11.4 and KDE:KDE3 but my problem is same...

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Zypper says: "will not be installed: ..."

    Please post your repos now

    Code:
    zypper lr -d
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: Zypper says: "will not be installed: ..."

    Code:
    # | Alias                    | Name                     | Enabled | Refresh | Priority | Type   | URI                                                                                 | Service                                                                                               
    --+--------------------------+--------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------+--------                                                                                               
    1 | google-chrome            | google-chrome            | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/i386                                   |                                                                                                       
    2 | network:utilities-11.4   | network:utilities-11.4   | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/repositories/network:/utilities/openSUSE_11.4/         |                                                                                                       
    3 | openSUSE-11.4-Source     | openSUSE-11.4-Source     | Yes     | No      |   99     | yast2  | http://download.opensuse.org/source/distribution/11.3/repo/oss/                     |                                                                                                       
    4 | openSUSE:Factory:Contrib | openSUSE:Factory:Contrib | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Factory:/Contrib/openSUSE_11.4/ |                                                                                                       
    5 | repo-11.4-non-oss        | openSUSE-11.4 Non-OSS    | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss                         |        
    6 | repo-11.4-oss            | openSUSE-11.4 OSS        | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/                            |        
    7 | repo-11.4-update         | openSUSE-11.4 Updates    | Yes     | No      |   99     | rpm-md | http://download.opensuse.org/update/11.4

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Zypper says: "will not be installed: ..."

    On 2011-04-09 20:06, barisuse wrote:
    > why does it say?


    That there are possible updates that will not be installed because they
    don't meet the rules you have set.

    You can fire up YaST package management, seek one of those packages not
    upgraded, and in the versions tab see what is available and from what repo.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Zypper says: "will not be installed: ..."

    Change as shown in Bold

    Quote Originally Posted by barisuse View Post
    Code:
    # | Alias                    | Name                     | Enabled | Refresh | Priority | Type   | URI                                                                                 | Service                                                                                               
    --+--------------------------+--------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------+--------                                                                                               
    1 | google-chrome            | google-chrome            | Yes     | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/i386                                   |                                                                                                       
    2 | network:utilities-11.4   | network:utilities-11.4   | Yes     | Yes      |   99     | rpm-md | http://download.opensuse.org/repositories/network:/utilities/openSUSE_11.4/         |                                                                                                       
    3 | openSUSE-11.4-Source     | openSUSE-11.4-Source     | Yes     | No      |   99     | yast2  | http://download.opensuse.org/source/distribution/11.3/repo/oss/                     |                                                                                                       
    4 | openSUSE:Factory:Contrib | openSUSE:Factory:Contrib | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Factory:/Contrib/openSUSE_11.4/ |                                                                                                       
    5 | repo-11.4-non-oss        | openSUSE-11.4 Non-OSS    | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss                         |        
    6 | repo-11.4-oss            | openSUSE-11.4 OSS        | Yes     | No      |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/                            |        
    7 | repo-11.4-update         | openSUSE-11.4 Updates    | Yes     | Yes      |   99     | rpm-md | http://download.opensuse.org/update/11.4
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •