Results 1 to 7 of 7

Thread: CDs & DVDs not mounting, displaying &/or ejecting w/ 11.4 & KDE 4.6

  1. #1
    Join Date
    Aug 2008
    Location
    Little Exuma, Bahamas
    Posts
    731

    Default CDs & DVDs not mounting, displaying &/or ejecting w/ 11.4 & KDE 4.6

    I've been very unhappy with the difficulty using removeable devices like CD ROM drives, etc. in 11.4 with KDE 4.6.0, and I'd struggled mightly to try and figure out how to get them to "behave". It took a great deal of trial and error. I've followed many suggestions to edit all sorts of system files, changed lots of setting that made no difference, and lots of other complicated "fixes" that fixed nothing and often created other issues.

    Today I finally come up with simple (KISS) resolutions and workarounds for most of the issues.

    To show the CD/DVD drive in Device Notifier:
    Right click on Device Notifier and select "Show HIdden Devices"

    To have the CD/DVD drive and/or USB drives etc. display in the Places Panel in Dolphin:
    Right Click on a blank space in the Places Panel and select "Show All Entries"

    It's often impossible to eject an optical disk using the button on the drive. I've been unable to find any program that's locking the drive or anything like that, but I can eject the drive with either of these workarounds:
    1. Right click on the drive listing in Dolpin>Places Panel
    2. Click on the little up arrow at the right of the drive listing in Device Notifier.

    Note: When I first started this saga the CD drive didn't automount and didn't even show up in /media. Another post suggested to edit /usr/share/polkit-1/actions/org.freedesktop.udisks.policy to resolve that issue by replacing a couple of
    <allow_active>auth_admin_keep</allow_active>
    entries with
    <allow_active>yes</allow_active>
    . Doing so did seem to solve the issue, however I'm sorry to say I didn't keep good notes on which sections I changed, and I forgot to make a backup first. If you need to try this fix I'd suggest you make a backup copy of the file first then as su run
    Code:
    # dbus-launch kwrite /usr/share/polkit-1/actions/org.freedesktop.udisks.policy
    and check out the sections. Each one has a <message> line describing its function. It'll make sense when you see it. I'm hoping someone will try this and then post the differences between his backup and the new version, so nobody else will have to try the 'trial and error' approach.
    MS user 1988-2008, Linux user 1998-present, openSUSE user since 2004
    (The first computer I used had a punch card reader)

  2. #2
    Join Date
    Sep 2009
    Location
    Columbus, Ohio, USA
    Posts
    178

    Default Re: CDs & DVDs not mounting, displaying &/or ejecting w/ 11.4 & KDE 4.6

    Could you translate that into Gnome, for me?

    forums.opensuse.org/english/get-technical-help-here/hardware/457710-dvd-not-seen.html
    AMD Athlon II X2 220, 2.8 GHz, 6 GB, PNY GeForce 210; 1 TB: Windows 7HP, Ubuntu 13.10, DBLab/Linux Mint 16 Remix, Suse 12.1 KDE.

  3. #3
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,237

    Default Re: CDs & DVDs not mounting, displaying &/or ejecting w/ 11.4 & KDE 4.6

    Quote Originally Posted by caprus View Post
    It's often impossible to eject an optical disk using the button on the drive.
    In System-settings>start/stop>Service Manager there is a checkbox under "services loaded at startup" for atomatically unmount units when the eject button is pressed. Is it set?

  4. #4
    Join Date
    Aug 2008
    Location
    Little Exuma, Bahamas
    Posts
    731

    Default Re: CDs & DVDs not mounting, displaying &/or ejecting w/ 11.4 & KDE 4.6

    @Randymanme
    Sorry I've no experience with gnome on OpenSUSE.

    @brunomci
    I'm not sure where to find that setting now that so many things have been relabeled and relocated (unnecessary and counterproductive "change for the sake of change" IMHO)
    I think you're referring to Yast>System>System Services (Runlevel). I've looked there and elsewhere but can find no such setting.
    Can you help me out here?
    MS user 1988-2008, Linux user 1998-present, openSUSE user since 2004
    (The first computer I used had a punch card reader)

  5. #5
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    3,237

    Default Re: CDs & DVDs not mounting, displaying &/or ejecting w/ 11.4 & KDE 4.6

    No, not yast. I'm referring to System Settings, previously known as KDE control center... It might be named somewhat differently depending on your os localization (language).

  6. #6
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: CDs & DVDs not mounting, displaying &/or ejecting w/ 11.4 & KDE 4.6

    This is not how it should be, and I don't have this issue on any of my KDE systems. So, I don't suspect some setting, rather a missing/corrupted package. Can you post output of 'dmesg' right after the phenomenon takes place?
    And, can we see the output of 'zypper lr -d' ?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  7. #7
    Join Date
    Aug 2008
    Location
    Little Exuma, Bahamas
    Posts
    731

    Default Re: CDs & DVDs not mounting, displaying &/or ejecting w/ 11.4 & KDE 4.6

    Quote Originally Posted by Knurpht View Post
    This is not how it should be, and I don't have this issue on any of my KDE systems. So, I don't suspect some setting, rather a missing/corrupted package.
    I do note that a number of posts on this and other fora describe similar problems with 11.4 and 4.6, 'though I've not seen anyone else post that they'd tried the simple settings I noted above.
    Can you post output of 'dmesg' right after the phenomenon takes place?
    I think you're referring to the eject issue.
    When I insert a DVD the following entry is added to dmesg:
    Code:
    [38854.733289] UDF-fs: Partition marked readonly; forcing readonly mount
    [38854.735094] UDF-fs INFO UDF: Mounting volume 'SHERLOCK_HOLMES_COLLECTION', timestamp 2005/09/02 13:55 (1f10)
    When I attempt to eject using the button on the drive no additional entry is added.
    When I use the eject command from CLI the drive opens, but no additional entry is added.

    Quote Originally Posted by Knurpht View Post
    And, can we see the output of 'zypper lr -d' ?
    Code:
    ~> zypper lr -d
    #  | Alias                             | Name                                    | Enabled | Refresh | Priority | Type   | URI                                                                                 | Service
    ---+-----------------------------------+-----------------------------------------+---------+---------+----------+--------+-------------------------------------------------------------------------------------+--------
     1 | Factory:Contrib                   | Factory:Contrib                         | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Factory:/Contrib/standard/      |        
     2 | KDE_4.6_for_11.4                  | KDE 4.6 for 11.4                        | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Release:/46/openSUSE_11.4            |        
     3 | Multimedia                        | Multimedia                              | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/multimedia:/libs/openSUSE_11.4/           |        
     4 | Packman                           | Packman                                 | Yes     | Yes     |   90     | rpm-md | http://packman.inode.at/suse/openSUSE_11.4                                          |        
     5 | download.nvidia.com-opensuse      | NVIDIA Repository                       | Yes     | Yes     |   99     | rpm-md | ftp://download.nvidia.com/opensuse/11.4/                                            |        
     6 | download.opensuse.org-Apps        | openSUSE BuildService - GNOME:Apps      | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/GNOME:/Apps/openSUSE_11.4/                |        
     7 | download.opensuse.org-Extra       | openSUSE BuildService - KDE:Extra       | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/Extra/openSUSE_11.4/                 |        
     8 | download.opensuse.org-UpdatedApps | openSUSE BuildService - KDE:UpdatedApps | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/KDE:/UpdatedApps/openSUSE_11.4/           |        
     9 | download.opensuse.org-mozilla     | openSUSE BuildService - Mozilla         | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_11.4/                    |        
    10 | google-chrome                     | google-chrome                           | No      | No      |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                                 |        
    11 | multimedia/audio                  | multimedia/audio                        | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/multimedia:/audio:/KMP/openSUSE_Factory/  |        
    12 | openSUSE:Factory:Contrib          | openSUSE:Factory:Contrib                | No      | No      |   99     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/Factory:/Contrib/openSUSE_11.4/ |        
    13 | opensuse-guide.org-repo           | libdvdcss repository                    | No      | No      |   99     | rpm-md | http://opensuse-guide.org/repo/11.3/                                                |        
    14 | repo-debug                        | openSUSE-11.4-Debug                     | No      | No      |   99     | NONE   | http://download.opensuse.org/debug/distribution/11.4/repo/oss/                      |        
    15 | repo-debug-update                 | openSUSE-11.4-Update-Debug              | No      | No      |   99     | NONE   | http://download.opensuse.org/debug/update/11.4/                                     |        
    16 | repo-non-oss                      | openSUSE-11.4-Non-Oss                   | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/                        |        
    17 | repo-oss                          | openSUSE-11.4-Oss                       | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/                            |        
    18 | repo-source                       | openSUSE-11.4-Source                    | No      | No      |   99     | NONE   | http://download.opensuse.org/source/distribution/11.4/repo/oss/                     |
    Note: all the disabled repos have been unused since the system was loaded and configured.
    MS user 1988-2008, Linux user 1998-present, openSUSE user since 2004
    (The first computer I used had a punch card reader)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •