Results 1 to 3 of 3

Thread: OpenSUSE 11.4 no sound problem

  1. #1
    Join Date
    Aug 2010
    Location
    Dalian
    Posts
    8

    Default OpenSUSE 11.4 no sound problem

    Hello all

    I installed OpenSUSE 11.4 with GNOME. but system audio not working at all. I've try Yast -> Sound->other->play test sound. no sound at all. when I was try to add another card to test it always show me error:
    The kernel module snd-intel8x0 for sound support
    could not be loaded. This can be caused by incorrect
    module parameters, including invalid IO or IRQ parameters.
    My laptop is Lenovo R400

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: OpenSUSE 11.4 no sound problem

    Quote Originally Posted by JUNZHOU_WANG View Post
    I installed OpenSUSE 11.4 with GNOME. but system audio not working at all. I've try Yast -> Sound->other->play test sound. no sound at all. when I was try to add another card to test it always show me error:
    This is a laptop ? Do NOT try to add another card. Thats a mistake. Go with the default card that YaST selects.

    The error you quote can be eliminated by removing the /etc/modprobe.d/50-sound.conf file (do NOT put backups in the /etc/modprobe.d directory) and then go back to YaST > Hardware > sound and configure there USING the sound card YaST detects.

    Quote Originally Posted by JUNZHOU_WANG View Post
    My laptop is Lenovo R400
    Sound should work on this laptop. According to Think wiki this laptop has an Intel HD Audio with a CX20561 Intel HD Audio with a CX20561 hardware audio codec, which works in Linux.

    I recommend you install the application 'pavucontrol' and then run 'pavucontrol' and use it to select your audio device

  3. #3
    Join Date
    Aug 2010
    Location
    Dalian
    Posts
    8

    Default Re: OpenSUSE 11.4 no sound problem

    Thanks, Its working now

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •