Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: KDE keep asking Secrets when I try to connect to WPA2

  1. #1

    Default KDE keep asking Secrets when I try to connect to WPA2

    Hi

    I recently installed KDE and just found that it cannot connect to my school wireless which uses WPA2.
    It keep asking Secretes for .... , even after I input everything correctly. It works fine with not secured wireless.

    In Gnome there was no problem with connecting to this wireless service.

    the following is dmesg results:
    Code:
    [  944.013115] cfg80211: Calling CRDA to update world regulatory domain
    [  944.017425] cfg80211: World regulatory domain updated:
    [  944.017427] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [  944.017430] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [  944.017432] cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [  944.017435] cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
    [  944.017437] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [  944.017439] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 1052.259753] wlan0: authenticate with 00:23:05:0c:f7:81 (try 1)
    [ 1052.260994] wlan0: authenticated
    [ 1052.261067] wlan0: associate with 00:23:05:0c:f7:81 (try 1)
    [ 1052.264027] wlan0: RX AssocResp from 00:23:05:0c:f7:81 (capab=0x431 status=0 aid=31)
    [ 1052.264031] wlan0: associated
    [ 1052.265652] cfg80211: Calling CRDA for country: US
    [ 1052.269651] cfg80211: Regulatory domain changed to country: US
    [ 1052.269655] cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
    [ 1052.269658] cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
    [ 1052.269660] cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
    [ 1052.269662] cfg80211:     (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 1052.269665] cfg80211:     (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 1052.269667] cfg80211:     (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
    [ 1052.269669] cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
    [ 1077.006790] wlan0: deauthenticating from 00:23:05:0c:f7:81 by local choice (reason=3)
    I don't know why that deauthenticating thing is happening.

    The following is the message from /var/log/NetworkManager

    Code:
    Apr  8 14:03:12 linux-e9w7 NetworkManager[1686]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
    Apr  8 14:03:12 linux-e9w7 NetworkManager[1686]: <info> Config: set interface ap_scan to 1
    Apr  8 14:03:12 linux-e9w7 NetworkManager[1686]: <info> (wlan0): supplicant connection state:  disconnected -> scanning
    Apr  8 14:03:13 linux-e9w7 NetworkManager[1686]: <info> (wlan0): supplicant connection state:  scanning -> associating
    Apr  8 14:03:13 linux-e9w7 NetworkManager[1686]: <info> (wlan0): supplicant connection state:  associating -> associated
    Apr  8 14:03:37 linux-e9w7 NetworkManager[1686]: <warn> Activation (wlan0/wireless): association took too long.
    Apr  8 14:03:37 linux-e9w7 NetworkManager[1686]: <info> (wlan0): device state change: 5 -> 6 (reason 0)
    Apr  8 14:03:37 linux-e9w7 NetworkManager[1686]: <warn> Activation (wlan0/wireless): asking for new secrets
    Apr  8 14:03:37 linux-e9w7 NetworkManager[1686]: <info> (wlan0): supplicant connection state:  associated -> disconnected
    Apr  8 14:03:53 linux-e9w7 NetworkManager[1686]: <warn> (wlan0): link timed out.
    Dell Precision T7500 | Nvidia | 12GB Ram | openSUSE 12.1 x86-64 | Gnome 3.2

  2. #2
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,970

    Default Re: KDE keep asking Secrets when I try to connect to WPA2

    Most likely You have kwallet misconfigured. You need to turn kwallet on and allow NetworkManager to have access to it and store the passwords in kwallet.

    Best regards,
    Greg
    Best regards,
    Greg

  3. #3

    Default Re: KDE keep asking Secrets when I try to connect to WPA2

    Quote Originally Posted by glistwan View Post
    Most likely You have kwallet misconfigured. You need to turn kwallet on and allow NetworkManager to have access to it and store the passwords in kwallet.
    Thanks for the reply. But I don't think that is the problem because I did always allow access for NetworkManager when the popup showed up. I even deleted everything related to NetworkManager in kwalletmanager and did it again as well.

    -Joon
    Dell Precision T7500 | Nvidia | 12GB Ram | openSUSE 12.1 x86-64 | Gnome 3.2

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,674
    Blog Entries
    3

    Default Re: KDE keep asking Secrets when I try to connect to WPA2

    I am partly guessing, and partly going by my experience with WiFi here.

    I am guessing that you created a shared WiFi connection when using gnome (you checked the option to make the connection available to all users). And the KDE network management applet doesn't grok that.

    Look in directory "/etc/NetworkManager/system-connections". There is probably a file with the name "Auto eth0" or something similar. And that should not be a problem. If there are additional files, then try moving those to somewhere else (maybe temporarily to the "/root" directory). Then reboot your computer and see if KDE can then connect.

    Looking at your "dmesg" output, I see signs that the network associated, and then disconnected. I saw similar symptoms on my system when I had experimented with using the gnome applet for WiFi, defining a shared connection, then switching back to the KDE applet.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  5. #5

    Default Re: KDE keep asking Secrets when I try to connect to WPA2

    Quote Originally Posted by nrickert View Post
    I am partly guessing, and partly going by my experience with WiFi here.

    I am guessing that you created a shared WiFi connection when using gnome (you checked the option to make the connection available to all users). And the KDE network management applet doesn't grok that.

    Look in directory "/etc/NetworkManager/system-connections". There is probably a file with the name "Auto eth0" or something similar. And that should not be a problem. If there are additional files, then try moving those to somewhere else (maybe temporarily to the "/root" directory). Then reboot your computer and see if KDE can then connect.

    Looking at your "dmesg" output, I see signs that the network associated, and then disconnected. I saw similar symptoms on my system when I had experimented with using the gnome applet for WiFi, defining a shared connection, then switching back to the KDE applet.
    Actually I did the share thing in Gnome. I looked at the directory but there is only Auto eth0 file though. Should I try to log in Gnome and get rid of the network connection setting?
    Dell Precision T7500 | Nvidia | 12GB Ram | openSUSE 12.1 x86-64 | Gnome 3.2

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,674
    Blog Entries
    3

    Default Re: KDE keep asking Secrets when I try to connect to WPA2

    It doesn't hurt to login to gnome and check. However, if it is not in that directory, then the shared connection is probably gone.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  7. #7

    Default Re: KDE keep asking Secrets when I try to connect to WPA2

    I just did. Actually it was not set as shared. But I just deleted the setting in Gnome to see if it makes any difference. I logged back in to KDE and deleted the configured wireless and try to connect again.
    To my surprise, now it connects to the wireless lan correctly. I have no idea what happened but I'm happy now.

    Thanks for the help.

    -Joon
    Dell Precision T7500 | Nvidia | 12GB Ram | openSUSE 12.1 x86-64 | Gnome 3.2

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,674
    Blog Entries
    3

    Default Re: KDE keep asking Secrets when I try to connect to WPA2

    I'm glad it is working.

    I guess that NetworkManager is still a work in progress. This isn't intended as criticism of its programmers, but as encouragement. I don't doubt that the software is trying to do something that is difficult to accomplish.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  9. #9
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,970

    Default Re: KDE keep asking Secrets when I try to connect to WPA2

    Always learn something new on this forums. Thanks for the read guys. Personally never encountered this problem because I don't use gnome at all but still it's good to know about this and I agree that there is a bug in either the gnome applet or the KDE NetworkManager applets.

    Best regards,
    Greg
    Best regards,
    Greg

  10. #10

    Default Re: KDE keep asking Secrets when I try to connect to WPA2

    Oops .. actually after rebooting this thing came back again.
    I got a bad feeling that I might have to do complete reinstallation of openSUSE with KDE ..

    I just got bunch of updates from KDE:Release:46 repo, and it includes networkmanager, so let me see if the update fixes this problem.

    -Joon
    Dell Precision T7500 | Nvidia | 12GB Ram | openSUSE 12.1 x86-64 | Gnome 3.2

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •