Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Microphone problem Alsa / Pulse audio

  1. #1

    Default Microphone problem Alsa / Pulse audio

    Hello.

    I have some microphone problems. I can't record anything. (I'm using openSUSE 11.3)

    My sound card was detected almost correctly (at least the chip-set was i think). I have an Asrock motherboard (k7upgrade880, with a Southbridge: VIA 8237 | Audio: CMedia CMI9761 6 channel AC'97.

    I ran these commands so far with these results - while i was following the audio troubleshooting guide (SDB:Audio troubleshooting - openSUSE

    cat /proc/asound/version
    Advanced Linux Sound Architecture Driver Version 1.0.22.1.

    cat /proc/asound/modules
    0 snd_via82xx

    cat /proc/asound/cards
    0 [V8237 ]: VIA8237 - VIA 8237
    VIA 8237 with CMI9761A+ at 0xd000, irq 22


    But i have NO audio playback problems - movies, games, music all play well.
    And the Microphone guid has a broken link

    I tried to change my 50-sound.conf file (i read it on a forum, I'm new to linux troubleshooting) from this:
    options snd slots=snd-via82xx
    to this:
    options snd slots=snd-via82xx position_fix=1
    But that did not work either. I did not get any sound with the last line.

    Any suggestions, what kind of information you guys need to help whit my problem? Or some guides that i can follow?

    Thanks.

  2. #2
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Microphone problem Alsa / Pulse audio

    When you are using Pulse Audio, start pavucontrol (control volume of Pulse Audio in the Multimedia category of the menu) and check in the input tab if the right microphone is selected. You'll see automatically if it works in this application.

    Also, check with alsamixer that all the volume related to the mic are at a right level.

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Microphone problem Alsa / Pulse audio

    Quote Originally Posted by yrott View Post
    I tried to change my 50-sound.conf file (i read it on a forum, I'm new to linux troubleshooting) from this:
    options snd slots=snd-via82xx
    to this:
    options snd slots=snd-via82xx position_fix=1
    But that did not work either. I did not get any sound with the last line.
    I'm sorry to read your mic does not work. My first recommendation is not to play with things like 'position_fix=1" unless you really know what you are doing.

    ... Installing 'pavucontrol' and then running 'pavucontrol' is IMHO a good start IF you are using Pulse with Gnome. If using KDE in 11.3 its not such a good idea, ... it has an 'input device' tab and a 'recording' tab. While trying to record sound, you can try to tune with that.

    When testing your mic, use a simple terminal command such as:
    Code:
    arecord -vv -f cd test.wav
    and then try to tune with pavucontrol (with Gnome). You can test if the recording working by simply playing back "test.wav".

    If that does not work, then please provide the information that is requested to be provided in our multimedia stickie: Welcome to multimedia sub-area

    To save you trying to figure out the part to post, I'll quote the salient sections from the stickie for you:
    please post ...providing in your post the following information:
    • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
      SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script
      Code:
      /usr/sbin/alsa-info.sh
      and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
      .
      Note if for some reason that gives you no website/url/address then run it with the no-upload option:
      Code:
      /usr/sbin/alsa-info.sh --no-upload
      and post the file /etc/alsa-info.txt it creates to Pastebin.com and press SUBMIT on that site and again post here the URL/website-address it provides.

    .
    ... some clarification on running the script "alsa-info.sh" ... when you run:
    Code:
    /usr/sbin/alsa-info.sh
    you should get something like this (if it asks for an update, select NO):


    followed by this (select the SHARE/UPLOAD option):


    followed by this (its quickest if you simply select 'NO' to seeing the output - you will see it on the web page) :


    followed by this (where in RED is the URL).


    Just post the URL you get (similar to the RED URL in my example, but yours will be different).

    Again, if you can not get that, then run this with the no upload option:
    Code:
    /usr/sbin/alsa-info.sh --no-upload
    which will create the file /tmp/alsa-info.txt. Copy that file and paste it on Pastebin.com and press submit. That will give you a URL address. Please post that URL here.


    Also provide the following:
    • in a terminal, or xterm, or konsole, type: rpm -qa '*alsa*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -qa '*pulse*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
    • in a terminal, or xterm, or konsole, type: uname -a #and post output here
    • ....
    • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

  4. #4

    Default Re: Re : Microphone problem Alsa / Pulse audio

    I checked both pavucontrol and alsamixer. In pavucontrol i checked all posibilities, and still no luck. In alsamixer i cant change the microphone volume at all.

  5. #5

    Default Re: Microphone problem Alsa / Pulse audio

    The script result:
    http://www.alsa-project.org/db/?f=f2...6f14934795833d

    And the command results:

    rpm -qa '*alsa*'
    alsa-firmware-1.0.23-1.2.noarch
    alsamixergui-0.9.0rc1-746.1.i586
    alsa-plugins-1.0.23-1.9.i586
    alsa-utils-1.0.23-1.8.i586
    pyalsa-1.0.22-1.8.i586
    alsa-plugins-pulse-1.0.23-1.9.i586
    alsa-oss-1.0.17-29.2.i586
    alsa-1.0.23-2.12.i586
    bluez-alsa-4.64-2.10.i586

    rpm -qa '*pulse*'
    pulseaudio-esound-compat-0.9.21-10.3.1.i586
    pulseaudio-0.9.21-10.3.1.i586
    pulseaudio-module-zeroconf-0.9.21-10.3.1.i586
    pulseaudio-module-gconf-0.9.21-10.3.1.i586
    pulseaudio-module-lirc-0.9.21-10.3.1.i586
    alsa-plugins-pulse-1.0.23-1.9.i586
    libpulse0-0.9.21-10.3.1.i586
    libpulse-mainloop-glib0-0.9.21-10.3.1.i586
    pulseaudio-module-bluetooth-0.9.21-10.3.1.i586
    libpulse-browse0-0.9.21-10.3.1.i586
    pulseaudio-module-x11-0.9.21-10.3.1.i586
    pulseaudio-utils-0.9.21-10.3.1.i586

    rpm -q libasound2
    libasound2-1.0.23-2.12.i586

    uname -a
    Linux linux-l58b 2.6.34.7-0.7-default #1 SMP 2010-12-13 11:13:53 +0100 i686 athlon i386 GNU/Linux

    cat /etc/modprobe.d/50-sound.conf

    options snd slots=snd-via82xx
    # Ssy1.Ygdz0JkHI56:K7VT6 motherboard
    alias snd-card-0 snd-via82xx

    Hope this helps shed some light on my problem.

    Oh, by the way, I'm using gnome desktop 11.3 distro.

  6. #6
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Microphone problem Alsa / Pulse audio

    Quote Originally Posted by yrott View Post
    Thanks for the information. The diagnostic script tells me you are running a 32-bit openSUSE-11.3 with the 2.6.34.7-0.7-default kernel, also with alsa version 1.0.22.1 (driver) and alsa version 1.0.23 (utilities) on a K7Upgrade-880 with a C-Media Electronics CMI9761A hardware audio codec. I checked the ALSA-Configuration.txt file to see if had any guidance for that hardware audio codec and did not find any.

    I checked your mixer settings to see if it is properly setup for recording, and it does appear it may be possible to tune better ...

    Code:
    !!Amixer output
    !!-------------
    
    !!-------Mixer controls for card 0 [V8237]
    Card hw:0 'V8237'/'VIA 8237 with CMI9761A  at 0xd000, irq 22'
      Mixer name	: 'C-Media Electronics CMI9761A '
    Simple mixer control 'Line',0
      Front Left: Playback 0 [0%] [-34.50dB] [off] Capture [off]
      Front Right: Playback 0 [0%] [-34.50dB] [off] Capture [off]
    Simple mixer control 'Mic',0
      Front Left: Playback 31 [100%] [12.00dB] [off] Capture [on]
      Front Right: Playback 31 [100%] [12.00dB] [off] Capture [on]
    Simple mixer control 'Mic Boost ( 20dB)',0
      Mono: Playback [on]
    Simple mixer control 'Mic Select',0
      Items: 'Mic1' 'Mic2'
      Item0: 'Mic1'
    Simple mixer control 'IEC958',0
      Mono: Playback [on] Capture [off]
    Simple mixer control 'Aux',0
      Front Left: Playback 0 [0%] [-34.50dB] [off] Capture [off]
      Front Right: Playback 0 [0%] [-34.50dB] [off] Capture [off]
    Simple mixer control 'Mono Output Select',0
      Items: 'Mix' 'Mic'
      Item0: 'Mix'
    Simple mixer control 'Capture',0
      Front Left: Capture 0 [0%] [0.00dB] [on]
      Front Right: Capture 0 [0%] [0.00dB] [on]
    Simple mixer control 'Mix',0
      Front Left: Capture [off]
      Front Right: Capture [off]
    Simple mixer control 'Mix Mono',0
      Front Left: Capture [off]
      Front Right: Capture [off]
    Simple mixer control 'Input Source Select',0
      Items: 'Input1' 'Input2'
      Item0: 'Input1'
    Simple mixer control 'Input Source Select',1
      Items: 'Input1' 'Input2'
      Item0: 'Input1'
    I don't know which capture controls need to be unmuted, but I note that the Mon Mic is NOT selected, but rather a mixer input (for recording) is selected. And that mixer input has capture OFF. I don't know how relevant that is.

    I did read somewhere (via surfing for the CMI9761A) that this device is very sensitive to inappropriate capture settings being set: No microphone input with alsa 1.0.20 with an CMI9761A+ chip on-board

    I note the IEC958 capture is OFF, I assume that is a digital capture. Does your motherboard use a digital or analog capture?

    Further, when testing for mic record functionality, I recommend you use a simple terminal command:
    Code:
    arecord -vv -f cd test.wav
    talk in to the mic, check the pavucontrol settings (and alsamixer) and then after some recording, press <ctrl><c> to stop recording, and play back the test.wav file with a media player.

    The mixer suggests a Mic1 and a Mic2, and the script provides:
    Code:
    ARECORD
    
    **** List of CAPTURE Hardware Devices ****
    card 0: V8237 [VIA 8237], device 0: VIA 8237 [VIA 8237]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: V8237 [VIA 8237], device 1: VIA 8237 [VIA 8237]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    which suggests 2 input devices. I assume you have then a front jack and a rear jack on your PC for the mic ? I also assume this is not a USB mic.

    Updating alsa

    If after turning with the mic and unmuting the various capture controls you still do not succeed, you could try an alsa update, but I'm not so convinced that will work as I have read no indication of an alsa update in this area.

    To update one could follow the guidance here: SDB:Alsa-update - openSUSE and update alsa-firmware, alsa-plugins, alsa-utils, pyalsa, alsa-plugins-pulse, alsa-oss, alsa, libasound2. There are also many pulse updates there, but I have never recommended updating them (as I have NEVER read of a case where such a pulse update helped).

    After updating those, check the version number. If the version number did not change, then you do not understand how YaST software management works, and you need to try again to update.

    Also install alsa-driver-kmp-default for the 2.6.34.7-0.7 kernel you have installed.

  7. #7

    Default Re: Microphone problem Alsa / Pulse audio

    Thanks for the replies.
    Do i need to edit the alsa.conf file, and if so where can i locate it, i searched for it in the /usr/sbin and /etc folders but did not find it. Maybe you could guide me, where to find the file, that i need to edit?

    P.S
    I tried running alsaconf as root but it did not detect my sound card. I than got a bit scared - i lost all sound - but after restarting the sound server it worked again.

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Microphone problem Alsa / Pulse audio

    Quote Originally Posted by yrott View Post
    Do i need to edit the alsa.conf file, and if so where can i locate it, i searched for it in the /usr/sbin and /etc folders but did not find it. Maybe you could guide me, where to find the file, that i need to edit?
    No you should NOT edit the alsa.conf file. Other distributions may do that but NOT openSUSE.

    Quote Originally Posted by yrott View Post
    I tried running alsaconf as root but it did not detect my sound card. I than got a bit scared - i lost all sound - but after restarting the sound server it worked again.
    alsaconf was depreciated a long time ago. It does NOT work with any recent openSUSE version.

    Why are you looking at editing a file?

    If I had thought there was a file to edit, I would have recommended such.

    Did the update to alsa fail ?

  9. #9

    Default Re: Microphone problem Alsa / Pulse audio

    Quote Originally Posted by oldcpu View Post
    I checked your mixer settings to see if it is properly setup for recording, and it does appear it may be possible to tune better ...

    Code:
    !!Amixer output
    !!-------------
    
    !!-------Mixer controls for card 0 [V8237]
    Card hw:0 'V8237'/'VIA 8237 with CMI9761A  at 0xd000, irq 22'
      Mixer name	: 'C-Media Electronics CMI9761A '
    Simple mixer control 'Line',0
      Front Left: Playback 0 [0%] [-34.50dB] [off] Capture [off]
      Front Right: Playback 0 [0%] [-34.50dB] [off] Capture [off]
    Simple mixer control 'Mic',0
      Front Left: Playback 31 [100%] [12.00dB] [off] Capture [on]
      Front Right: Playback 31 [100%] [12.00dB] [off] Capture [on]
    Simple mixer control 'Mic Boost ( 20dB)',0
      Mono: Playback [on]
    Simple mixer control 'Mic Select',0
      Items: 'Mic1' 'Mic2'
      Item0: 'Mic1'
    Simple mixer control 'IEC958',0
      Mono: Playback [on] Capture [off]
    Simple mixer control 'Aux',0
      Front Left: Playback 0 [0%] [-34.50dB] [off] Capture [off]
      Front Right: Playback 0 [0%] [-34.50dB] [off] Capture [off]
    Simple mixer control 'Mono Output Select',0
      Items: 'Mix' 'Mic'
      Item0: 'Mix'
    Simple mixer control 'Capture',0
      Front Left: Capture 0 [0%] [0.00dB] [on]
      Front Right: Capture 0 [0%] [0.00dB] [on]
    Simple mixer control 'Mix',0
      Front Left: Capture [off]
      Front Right: Capture [off]
    Simple mixer control 'Mix Mono',0
      Front Left: Capture [off]
      Front Right: Capture [off]
    Simple mixer control 'Input Source Select',0
      Items: 'Input1' 'Input2'
      Item0: 'Input1'
    Simple mixer control 'Input Source Select',1
      Items: 'Input1' 'Input2'
      Item0: 'Input1'
    I don't know which capture controls need to be unmuted, but I note that the Mon Mic is NOT selected, but rather a mixer input (for recording) is selected. And that mixer input has capture OFF. I don't know how relevant that is.
    Can you specify how can i change the settings that you marked with red? Can i do that at all?

    Quote Originally Posted by oldcpu View Post
    The mixer suggests a Mic1 and a Mic2, and the script provides:
    Code:
    ARECORD
    
    **** List of CAPTURE Hardware Devices ****
    card 0: V8237 [VIA 8237], device 0: VIA 8237 [VIA 8237]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: V8237 [VIA 8237], device 1: VIA 8237 [VIA 8237]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    which suggests 2 input devices. I assume you have then a front jack and a rear jack on your PC for the mic ? I also assume this is not a USB mic.
    I don't know about a front microphone jack, but maybe there is a cable plugged in on the motherboard that i'm not aware of.

    Quote Originally Posted by oldcpu View Post
    Also install alsa-driver-kmp-default for the 2.6.34.7-0.7 kernel you have installed.
    I installed the kernel module, but that did not help.

    I verified the installation in the Yast Software Manager and the version indicators font color is red. I suppose that is bad, but i'm not shore.

    As you mentioned it would not help to update the alsa, so i did not do that.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Microphone problem Alsa / Pulse audio

    Quote Originally Posted by yrott View Post
    Can you specify how can i change the settings that you marked with red? Can i do that at all?
    Yes of course. Those are mixer settings. Change them in your mixer. THAT depends on your desktop. In gnome you can use alsamixer, amixer and pavucontrol. amixer is tricky to use because it needs precise syntax and I don't know the syntax. That is ONE reason why I avoid the gnome desktop and prefer KDE.

    Quote Originally Posted by yrott View Post
    I installed the kernel module, but that did not help.
    Don't stop 1/2 way. If you are going to update the kernel module then you should update the remaining alsa apps and libasound2. The guide is QUITE CLEAR on that. If you are going to innovate and go 'your own way' make sure you know EXACTLY what you are doing and EXACTLY how the alsa driver works. Why deviate?

    Quote Originally Posted by yrott View Post
    I verified the installation in the Yast Software Manager and the version indicators font color is red. I suppose that is bad, but i'm not shore.
    I don't know what you mean. How about posting the output of:
    Code:
    rpm -qa '*alsa*'
    rpm -q libasound2
    Quote Originally Posted by yrott View Post
    As you mentioned it would not help to update the alsa, so i did not do that.
    Now I'm confused. You just told me you did update with the alsa-kernel module. So did you or did you not?

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •