Results 1 to 5 of 5

Thread: journal commit IO error on 11.4

  1. #1

    Default journal commit IO error on 11.4

    Hi, hope this is the correct forum to post this question,
    I have a dual boot laptop (T61) with a 250G hard disk where opensuse 11.4 is my main os and debian on another partition, I have 4 partitions:
    /dev/sda1 5GB swap
    /dev/sda2 55GB opensuse 11.4 64bit (upgraded recently from 11.3)
    /dev/sda3 29GB debian 6 64bit
    /dev/sda4 142GB /opt in both os's

    this is my setup for the past two years or so.
    opensuse 11.4 worked fine until today,
    I usually suspend opensuse by closing the laptop lid and I must say that sometimes opensuse can't wake up from suspend and I have to power off and reboot, today was the same and i powered it off and rebooted and then the problem started.
    it started fine but then in a few minutes firefox suddenly crashed and trying to do anything in terminal ended with a message like:
    message from syslogd..
    kernel:[ 8824.996238] journal commit I/O error
    after this message any mouse click causes gnome to crash and I'm left with an unusable terminal window.
    this is consistent, I tried rebooting many times and its the same every time, it starts ok but then in a few minutes something happens, for example trying 'zypper dup' causes the above message in terminal and the system is unusable anymore.



    now, I can boot to debian with no problem and it works fine, /dev/sda2 where opensuse is installed is mounted and I can read the opensuse messages log , the only thing I can think that can be relevant to my problem is a lot of errors like:
    Apr 5 18:12:43 my-laptop kernel: [34060.397919] ata1.00: error: { UNC }
    Apr 5 23:24:25 my-laptop smartd[2108]: Device: /dev/sda [SAT], ATA error count increased from 66 to 102

    but those messages are from Apr 5, and today is Apt 8 and I used it until last night with no problem,

    latest messages that may be related are:

    Apr 8 13:11:59 my-laptop mcelog: failed to prefill DIMM database from DMI data
    Apr 8 13:12:00 my-laptop smartd[1909]: Device: /dev/sda [SAT], found in smartd database.
    Apr 8 13:12:00 my-laptop modem-manager: Loaded plugin AnyData
    Apr 8 13:12:00 my-laptop smartd[1909]: Device: /dev/sda [SAT], state read from /var/lib/smartmontools/smartd.FUJITSU_MHZ2250BH_G2-K60KT912HKJJ.ata.state
    Apr 8 13:12:00 my-laptop smartd[1909]: Monitoring 1 ATA and 0 SCSI devices
    Apr 8 13:12:01 my-laptop smartd[1909]: Device: /dev/sda [SAT], state written to /var/lib/smartmontools/smartd.FUJITSU_MHZ2250BH_G2-K60KT912HKJJ.ata.state


    I googled and most threads I read are talking about hard disk failure , but the fact that I can boot to debian and work with no problem and even read the partition where opensuse is installed makes me think that the disk is fine. although in opensuse i have more startup programs like liferea,spideroak,mysql and more, i started on debian programs that will use the disk a lot and there is no problem.

    I must say that I dropped my laptop on the ground a few days ago, but it worked fine after that, it still is as I said I'm using it right now with debian.

    I have no idea where to start and would appreciate any help.
    Thanks

  2. #2
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : journal commit IO error on 11.4

    It really looks like a hard disk failure to me.... or your disk is about to die....

    Did you run Debian for a long time after those problems arise in openSUSE ? Maybe Debian will start to misbehave eventually.

    I'd save all critical data if I were you.

    After that, you should check the partitions of openSUSE to see if there is errors on them. By the way, check the integrity of all the HDD.

  3. #3
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Re : journal commit IO error on 11.4

    As I can see your disk has a boot problem from your opensuse. Do you isolate debian's grub?
    I suggest you to save your files in storage system.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,926
    Blog Entries
    14

    Default Re: Απ: Re : journal commit IO error on 11.4

    I'm with @DaaX: serious suspicions of a degrading disk.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: Απ: Re : journal commit IO error on 11.4

    OK, thanks, I will backup my data as you guys suggest,
    I'm using debian for the past three hours, no problems yet and nothing suspicious in the logs.
    about grub, I never install grub to the MBR, I install grub to the same partition where I install the os and I boot with GAG.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •