Results 1 to 8 of 8

Thread: apache2 restart warning message

  1. #1
    Join Date
    Oct 2009
    Location
    Dhaka,Bangladesh
    Posts
    251

    Question apache2 restart warning message

    Code:
    /etc/init.d/apache2 restart
    Message:
    Code:
    Could not reliably determine the server's fully qualified domain name, using ::1 for ServerName
    How can i get rid of that message?
    openSUSE 11.3 + LXDE
    uname -r = 2.6.34.7-0.4-default

  2. #2
    Join Date
    Mar 2009
    Location
    sri mayapur, west bengal, india
    Posts
    958

    Default Re: apache2 restart warning message

    On Fri, 08 Apr 2011 14:06:02 +0530, colao
    <colao@no-mx.forums.opensuse.org> wrote:

    >
    > Code:
    > --------------------
    > /etc/init.d/apache2 restart
    > --------------------
    >
    > Message:
    >
    > Code:
    > --------------------
    > Could not reliably determine the server's fully qualified domain name,
    > using ::1 for ServerName
    > --------------------
    >
    > How can i get rid of that message?
    >


    edit /etc/apache2/httpd.conf, assigning your machine's hostname to the
    "ServerName" variable.


    --
    phani.

  3. #3
    Join Date
    Oct 2009
    Location
    Dhaka,Bangladesh
    Posts
    251

    Default Re: apache2 restart warning message

    I could not find any ServerName in http.conf.
    openSUSE 11.3 + LXDE
    uname -r = 2.6.34.7-0.4-default

  4. #4
    Join Date
    Jul 2010
    Location
    Adelaide, Australia
    Posts
    963

    Default Re: apache2 restart warning message

    I think you will have to create it in httpd.conf
    Desktop: Gigabyte GA-Z270-HD3 - Core i7 7700K - openSUSE Leap 42.2 KDE
    Laptop: HP EliteBook 8770W - Core i7 3940XM - openSUSE Leap 42.2 KDE

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,861
    Blog Entries
    14

    Default Re: apache2 restart warning message

    This can be done from Yast, HTTP-server. You probably did not enter any hostnames/IP addresses. I always enter 127.0.0.1 for a start, that way I can at least check if things work locally.

    Edit: The ServerName is entered in default-server.conf, not in httpd.conf
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: apache2 restart warning message

    Quote Originally Posted by ah7013 View Post
    I think you will have to create it in httpd.conf
    As I can see here
    Code:
    Could not reliably determine the server's fully qualified domain name, using ::1 for ServerName
    Maybe the problem based on URL of DNS server. Maybe he must check his internet/connection settings in Yast.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,861
    Blog Entries
    14

    Default Re: Απ: Re: apache2 restart warning message

    Quote Originally Posted by stamostolias View Post
    As I can see here
    Code:
    Could not reliably determine the server's fully qualified domain name, using ::1 for ServerName
    Maybe the problem based on URL of DNS server. Maybe he must check his internet/connection settings in Yast.
    No, that's not the case. It's not the internet connection, it's the apache webserver that's throwing this error on a local accessed webserver. Should work even without a networkconnection.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: Re: apache2 restart warning message

    Quote Originally Posted by Knurpht View Post
    No, that's not the case. It's not the internet connection, it's the apache webserver that's throwing this error on a local accessed webserver. Should work even without a networkconnection.
    So no fault in connection only server's problem.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •