Results 1 to 9 of 9

Thread: Headphone jack and Internal Mic not working

  1. #1

    Question Headphone jack and Internal Mic not working

    Hi,

    Just curious if someone could help me with my issue, I've noticed that my internal mic doesn't work, and when I plug in headphones it stops the use of the speakers but I hear nothing through the headphones. I'm running openSUSE 11.3 and have had almost no major problems until this. I've searched around and asked a couple friends and have made absolutely no progress.

    Help?

    Thanks,
    Myst

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Headphone jack and Internal Mic not working

    Quote Originally Posted by Myst_218 View Post
    Just curious if someone could help me with my issue, I've noticed that my internal mic doesn't work, and when I plug in headphones it stops the use of the speakers but I hear nothing through the headphones. I'm running openSUSE 11.3 and have had almost no major problems until this. I've searched around and asked a couple friends and have made absolutely no progress.
    This should 'just work', and the fact that it does not 'just work' suggests it could be a misconfiguration of the alsa audio driver, although it is possible it is also a mixer configuration problem (but that is FAR less likely).

    I would like to help, but typically to do so , in order to my avoid wild speculation, I like to have a lot of information. Could you provide the information that is recommended to be provided in our multimedia stickie ? The stickie is here: Welcome to multimedia sub-area

    ... and to help you so that you do not have to struggle through that stickie to figure out what I mean, I will quote the salient portions for you:

    For all openSUSE users, if that that does not help you get your basic sound working, please post in this "multimedia" sub-forum, providing in your post the following information:
    • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
      SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script
      Code:
      /usr/sbin/alsa-info.sh
      and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
      .
      Note if for some reason that gives you no website/url/address then run it with the no-upload option:
      Code:
      /usr/sbin/alsa-info.sh --no-upload
      and post the file /etc/alsa-info.txt it creates to Pastebin.com and press SUBMIT on that site and again post here the URL/website-address it provides.

    .
    ... some clarification on running the script "alsa-info.sh" ... when you run:
    Code:
    /usr/sbin/alsa-info.sh
    you should get something like this (if it asks for an update, select NO):


    followed by this (select the SHARE/UPLOAD option):


    followed by this (its quickest if you simply select 'NO' to seeing the output - you will see it on the web page) :


    followed by this (where in RED is the URL).


    Just post the URL you get (similar to the RED URL in my example, but yours will be different).

    Again, if you can not get that, then run this with the no upload option:
    Code:
    /usr/sbin/alsa-info.sh --no-upload
    which will create the file /tmp/alsa-info.txt. Copy that file and paste it on Pastebin.com and press submit. That will give you a URL address. Please post that URL here.


    Also provide the following:
    • in a terminal, or xterm, or konsole, type: rpm -qa '*alsa*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -qa '*pulse*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
    • in a terminal, or xterm, or konsole, type: uname -a #and post output here
    • ....
    • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here



  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Headphone jack and Internal Mic not working

    Before I forget, WELCOME to openSUSE and WELCOME to openSUSE forums !!

  4. #4

    Default Re: Headphone jack and Internal Mic not working

    In the order you told me to do them, here's the information you requested.
    /usr/sbin/alsa-info.sh result:
    http://www.alsa-project.org/db/?f=e1...21f216b4396b83

    rpm -qa '*alsa*' result:
    Code:
    alsa-utils-1.0.23-1.8.x86_64
    alsa-oss-1.0.17-29.2.x86_64
    alsa-plugins-32bit-1.0.23-1.9.x86_64
    alsa-plugins-1.0.23-1.9.x86_64
    alsa-plugins-jack-1.0.23-1.9.x86_64
    gmerlin-alsa-1.0.0-1.pm.7.19.x86_64
    alsa-oss-32bit-1.0.17-29.2.x86_64
    alsa-1.0.23-2.12.x86_64
    alsa-devel-1.0.23-2.12.x86_64
    alsa-plugins-pulse-32bit-1.0.23-1.9.x86_64
    alsa-plugins-jack-32bit-1.0.23-1.9.x86_64
    alsa-plugins-pulse-1.0.23-1.9.x86_64
    gmerlin-alsamixer-1.0.0-1.pm.7.19.x86_64
    rpm -qa '*pulse*' result:
    Code:
    pulseaudio-0.9.21-10.3.1.x86_64
    libpulse0-0.9.21-10.3.1.x86_64
    pulseaudio-utils-0.9.21-10.3.1.x86_64
    pulseaudio-module-zeroconf-0.9.21-10.3.1.x86_64
    libpulse-mainloop-glib0-0.9.21-10.3.1.x86_64
    libpulse0-32bit-0.9.21-10.3.1.x86_64
    pulseaudio-module-bluetooth-0.9.21-10.3.1.x86_64
    alsa-plugins-pulse-32bit-1.0.23-1.9.x86_64
    pulseaudio-esound-compat-0.9.21-10.3.1.x86_64
    pulseaudio-module-x11-0.9.21-10.3.1.x86_64
    vlc-aout-pulse-1.1.8-1.pm.2.4.x86_64
    pulseaudio-module-lirc-0.9.21-10.3.1.x86_64
    pulseaudio-module-gconf-0.9.21-10.3.1.x86_64
    alsa-plugins-pulse-1.0.23-1.9.x86_64
    libpulse-browse0-0.9.21-10.3.1.x86_64
    rpm -q libasound2 result:
    Code:
    libasound2-1.0.23-2.12.x86_64
    uname -a result:
    Code:
    Linux linux-v0t7.site 2.6.34.7-0.7-default #1 SMP 2010-12-13 11:13:53 +0100 x86_64 x86_64 x86_64 GNU/Linux
    cat /etc/modprobe.d/50-sound.conf result:
    Code:
    # u1Nb.w3SAN3oGsLA:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel

    I'm new to linux in general really so bare with me here. And thanks for the help!

  5. #5
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Headphone jack and Internal Mic not working

    Quote Originally Posted by Myst_218 View Post
    In the order you told me to do them, here's the information you requested.
    /usr/sbin/alsa-info.sh result:
    http://www.alsa-project.org/db/?f=e1...21f216b4396b83
    Thanks, the alsa versions look ok.

    Quote Originally Posted by Myst_218 View Post
    cat /etc/modprobe.d/50-sound.conf result:
    Code:
    # u1Nb.w3SAN3oGsLA:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    THAT looks strange. Are you 100% certain you did not cut off a line when posting that ?

    Anyway, looking at the output of your diagnostic script I note a 64-bit openSUSE-11.3 with the 2.6.34.7-0.7-default kernel running an ASUSTeK G60VX computer with an ALC663 hardware audio codec. There are many different 'asus' modes that can be forced upon the alsa audio driver, in case it did not configure properly at boot (such that the headphone and internal mic does not work) but first, can you take a look at these mixer settings that are set on your PC per the diagnostic script output?

    Code:
    !!Amixer output
    !!-------------
    !!-------Mixer controls for card 0 [Intel]
    Mixer name    : 'Realtek ALC663'
      Simple mixer control 'Headphone',0
      Capabilities: pswitch penum
      Playback channels: Front Left - Front Right
      Mono:
      Front Left: Playback [on]
      Front Right: Playback [off]
    Simple mixer control 'Mic',0
      Playback channels: Front Left - Front Right
      Front Left: Playback 31 [100%] [12.00dB] [on]
      Front Right: Playback 31 [100%] [12.00dB] [on]
    Simple mixer control 'Capture',0
      Capture channels: Front Left - Front Right
      Front Left: Capture 31 [100%] [30.00dB] [on]
      Front Right: Capture 31 [100%] [30.00dB] [on]
    Simple mixer control 'i-Mic',0
      Playback channels: Front Left - Front Right
      Front Left: Playback 0 [0%] [-34.50dB] [on]
      Front Right: Playback 0 [0%] [-34.50dB] [on]
    I note one channel of your headphone is muted, and I note your "i-Mic" (internal mic ?? ) playback is muted.

    If fixing that does not help, there is a list of ALC663 modes we can force upon alsa (one at a time) but before we do that I need to be provided assurance that you provided me the complete content of the /etc/modprobe.d/50-sound.conf file with the command:
    Code:
    cat /etc/modprobe.d/50-sound.conf
    The list (for 1.0.23 of alsa) is:
    Code:
    ALC662/663/272
    ==============
      3stack-dig    3-stack (2-channel) with SPDIF
      3stack-6ch     3-stack (6-channel)
      3stack-6ch-dig 3-stack (6-channel) with SPDIF
      6stack-dig     6-stack with SPDIF
      lenovo-101e     Lenovo laptop
      eeepc-p701    ASUS Eeepc P701
      eeepc-ep20    ASUS Eeepc EP20
      ecs        ECS/Foxconn mobo
      m51va        ASUS M51VA
      g71v        ASUS G71V
      h13        ASUS H13
      g50v        ASUS G50V
      asus-mode1    ASUS
      asus-mode2    ASUS
      asus-mode3    ASUS
      asus-mode4    ASUS
      asus-mode5    ASUS
      asus-mode6    ASUS
      dell        Dell with ALC272
      dell-zm1    Dell ZM1 with ALC272
      samsung-nc10    Samsung NC10 mini notebook
      auto        auto-config reading BIOS (default)
    ... and in addition to forcing an alsa configuration (which I will explain later how to do) we can also update your alsa version from the older version 1.0.23 to a newer version 1.0.24. But first, lets ensure your mixer is correct AND I need confirmation the content provided for 50-sound.conf was correct !

  6. #6

    Default Re: Headphone jack and Internal Mic not working

    You were right, apparently a line did get cut off before. Here's the correct* result:

    Code:
    options snd slots=snd-hda-intel
    # u1Nb.w3SAN3oGsLA:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    Also, those are the current mixer settings. Though before, the headphone wasn't half muted, regardless though I cannot unmute it (atleast not with alsamixer). Also, the i-Mic option is there but when I boost the volume for some reason it's constant (I am hearing myself through the speakers when I type or do anything, constantly).

    I really appreciate all this help!

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Headphone jack and Internal Mic not working

    Quote Originally Posted by Myst_218 View Post
    Also, those are the current mixer settings. Though before, the headphone wasn't half muted, regardless though I cannot unmute it (atleast not with alsamixer). Also, the i-Mic option is there but when I boost the volume for some reason it's constant (I am hearing myself through the speakers when I type or do anything, constantly).
    I don't know how important it is to control the i-Mic setting, but your inability to set it does cause me some concern it 'might' be related to the problem. I think i-Mic might be internal mic and so it should NOT be at 0%. Try it high 80% or so for each test. I suspect 'amixer' would enable you to control all mixer settings, but one needs a very specific syntax with 'amixer' and I can't help there with the syntax. If you type :
    Code:
    man amixer
    you will learn more about amixer.

    Quote Originally Posted by Myst_218 View Post
    You were right, apparently a line did get cut off before. Here's the correct* result:

    Code:
    options snd slots=snd-hda-intel
    # u1Nb.w3SAN3oGsLA:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    Ok, with that 50-sound.conf file, we can proceed under a possibly falacious, and possibly correct, assumption that alsa sound driver was not configured correctly upon boot, and check to see if we can better tune it.

    Some what supporting that hypothesis is the dmesg output noted in the diagnostic script where it notes:
    Code:
    [  491.814958] input: HDA Digital PCBeep as /devices/pci0000:00/0000:00:1b.0/input/input10
    [  493.571474] hda-intel: IRQ timing workaround is activated for card #0. Suggest a bigger bdl_pos_adj.
    Unfortunately I'm not smart enough to suggest a better "bdl_pos_adj" (I've read the documentation on that, but I don't have the experience in applying it), ... but I think by applying different model options one will in effect achieve the same in selected cases.

    Look at the "ALC662/663/272" table I provided in a previous post in this thread. That's important.

    So lets say you wish to try the option "g50v" on your PC (note the descriptions are not precise, and a given model option can be applicable to MORE than just the indicated hardware), then you would edit the /etc/modprobe.d/50-sound.conf file to read (adding a new line at the start of the file):
    Code:
    options snd-hda-intel model=g50v
    options snd slots=snd-hda-intel
    # u1Nb.w3SAN3oGsLA:82801I (ICH9 Family) HD Audio Controller
    alias snd-card-0 snd-hda-intel
    and save that, then restart your sound as a regular user with:
    Code:
    su -c 'rcalsasound restart
    enter root password when prompted, ... then restart your mixer (type 'alsamixer' if gnome) ... and then test your internal mic. A test I recommend is running in a terminal:
    Code:
    arecord -vv -f cd test.wav
    Note one can even tune that command more to point to specific input devices (but that should not be necessary).

    Applying g50v may make things worse. No worries, if it does not help then replace g50v with a different option in the 50-sound.conf file (such as g71v) and save the change, and restart alsa, restart your mixer, and test.

    Do that for each item in the list.

    Note you MUST check your mixer settings for each test (as they may not be saved from test to test). You could also check out pavucontrol for each test.

    If you have no success there, you could update alsa, but when I check the alsa website for the ALC663 I can not see any indication that the ALC663 updates address a mic problem.

  8. #8

    Default Re: Headphone jack and Internal Mic not working

    I tried a couple that didn't work at all, but when I tried putting
    Code:
    model=asus-mode1
    as the option, it worked fine. Both the headphones and the mic are working now... The alsamixer also has less options, but I'm satisfied!!

    Thanks for all the help, I learned a lot about this stuff..

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,108
    Blog Entries
    40

    Default Re: Headphone jack and Internal Mic not working

    Quote Originally Posted by Myst_218 View Post
    I tried a couple that didn't work at all, but when I tried putting
    Code:
    model=asus-mode1
    as the option, it worked fine. Both the headphones and the mic are working now... The alsamixer also has less options, but I'm satisfied!!

    Thanks for all the help, I learned a lot about this stuff..
    Excellent !! Thanks for sharing your solution.

    You could try the remainder some time, to see if you can 'get your cake and eat it too', with a note to yourself to go back to asus-mode1 if all else fails.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •