Results 1 to 4 of 4

Thread: SVN Package Issue

  1. #1

    Default SVN Package Issue

    Hello Everbody,

    We are using SLES 11.1 with SVN 1.6.16 from this Repository :

    https://build.opensuse.org/package/b...ository=SLE_11


    While installing it with zypper , eg install subversion-server it throws an error without much description of the deeper problem:

    My Question: Is this alright to just not forbid the installation of the apache package, will subversion work properly/stable with this setup(using Solution 1)? Is there a problem now or when i upgrade and if so is there a good solution?

    zypper install subversion-server
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...

    Problem: subversion-server-1.6.16-27.1.x86_64 requires apache2, but this requirement cannot be provided
    uninstallable providers: apache2-2.2.10-2.24.5.x86_64[local_server:SLES11-1]
    Solution 1: do not forbid installation of apache2-2.2.10-2.24.5.x86_64[local_nu_server:SLES11-SP1-Pool]
    Solution 2: do not ask to install a solvable providing subversion-server
    Solution 3: break subversion-server by ignoring some of its dependencies


    Choose from above solutions by number or cancel [1/2/3/c] (c): 1
    Resolving dependencies...
    Resolving package dependencies...

    The following NEW packages are going to be installed:
    apache2 apache2-prefork apache2-utils subversion-server

    The following package is not supported by its vendor:
    subversion-server

    4 new packages to install.
    Overall download size: 1.2 MiB. After the operation, additional 3.3 MiB will be used.
    Continue? [y/n/?] (y): y
    Retrieving package apache2-utils-2.2.10-2.24.5.x86_64 (1/4), 110.0 KiB (192.0 KiB unpacked)
    Retrieving: apache2-utils-2.2.10-2.24.5.x86_64.rpm [done]
    Installing: apache2-utils-2.2.10-2.24.5 [done]
    Retrieving package apache2-prefork-2.2.10-2.24.5.x86_64 (2/4), 265.0 KiB (653.0 KiB unpacked)
    Retrieving: apache2-prefork-2.2.10-2.24.5.x86_64.rpm [done]
    Installing: apache2-prefork-2.2.10-2.24.5 [done]
    Retrieving package apache2-2.2.10-2.24.5.x86_64 (3/4), 745.0 KiB (2.3 MiB unpacked)
    Retrieving: apache2-2.2.10-2.24.5.x86_64.rpm [done]
    Installing: apache2-2.2.10-2.24.5 [done]
    Additional rpm output:
    Starting SuSEconfig, the SuSE Configuration Tool...
    Running module permissions only
    Reading /etc/sysconfig and updating the system...
    Executing /sbin/conf.d/SuSEconfig.permissions...
    Finished.
    Updating etc/sysconfig/apache2...
    insserv: warning: script 'S01tsm' missing LSB tags and overrides
    insserv: warning: script 'tsm' missing LSB tags and overrides

    looking for old 2.0 modules to be renamed...
    Done.


    Retrieving package subversion-server-1.6.16-27.1.x86_64 (4/4), 114.0 KiB (166.0 KiB unpacked)
    Retrieving: subversion-server-1.6.16-27.1.x86_64.rpm [done]
    Installing: subversion-server-1.6.16-27.1 [done]

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,100
    Blog Entries
    15

    Default Re: SVN Package Issue

    On Fri, 2011-04-08 at 05:06 +0000, Alcatros32 wrote:
    > Hello Everbody,
    >
    > We are using SLES 11.1 with SVN 1.6.16 from this Repository :
    >
    > http://tinyurl.com/44gur6b
    >
    >
    > While installing it with zypper , eg install subversion-server it
    > throws an error without much description of the deeper problem:
    >
    > My Question: Is this alright to just not forbid the installation of the
    > apache package, will subversion work properly/stable with this
    > setup(using Solution 1)? Is there a problem now or when i upgrade and if
    > so is there a good solution?

    Hi
    Suggest you ask the maintainers to add the SLE_11_SP1 repository if you
    need that version?

    Plus this is the incorrect forum to be asking, you need to be over at
    http://forums.novell.com

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.29-0.3-default
    up 1 day 13:12, 2 users, load average: 1.13, 1.20, 1.23
    GPU GeForce 8600 GTS Silent - Driver Version: 260.19.26


  3. #3

    Default Re: SVN Package Issue

    Hi,

    I actually have the SLE_11_SP1 Repository, Apache2 shows there as "Installed" after i do execute this command. In addition i cannot ask there because its an unsupported Package as the installation shows.


    S | Name | Summary | Type
    --+--------------------------+-------------------------------------------------------+--------
    i | apache2 | The Apache Web Server Version 2.0 | package
    | apache2-doc | Additional Package Documentation. | package
    | apache2-example-pages | Example Pages for the Apache 2 Web Server | package
    | apache2-mod_apparmor | AppArmor module for apache2 | package
    | apache2-mod_macro | Define and Use Macros within the Apache Configuration | package
    | apache2-mod_mono | Run ASP.NET Pages on Unix with Apache and Mono | package
    | apache2-mod_perl | Embedded Perl for Apache | package
    | apache2-mod_php5 | PHP5 Module for Apache 2.0 | package
    | apache2-mod_python | A Python Module for the Apache 2 Web Server | package
    i | apache2-prefork | Apache 2 "prefork" MPM (Multi-Processing Module) | package
    i | apache2-utils | Apache 2 utilities | package
    | apache2-worker | Apache 2 worker MPM (Multi-Processing Module) | package
    | slessp1-apache2-mod_php5 | Security update for PHP5 | patch

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,100
    Blog Entries
    15

    Default Re: SVN Package Issue

    On Fri, 2011-04-08 at 06:36 +0000, Alcatros32 wrote:
    > Hi,
    >
    > I actually have the SLE_11_SP1 Repository, Apache2 shows there as
    > "Installed" after i do execute this command. In addition i cannot ask
    > there because its an unsupported Package as the installation shows.

    Hi
    Sure you can ask in the Novell Forums... using the repos may exclude
    getting an SR processed or a bug etc, but not asking questions.

    Again these forums are for openSUSE, not SLE.

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.29-0.3-default
    up 1 day 21:59, 2 users, load average: 1.15, 1.29, 1.31
    GPU GeForce 8600 GTS Silent - Driver Version: 260.19.26


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •