Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: open Suse 11.3 no sound

  1. #1

    Default open Suse 11.3 no sound

    Hi,

    When i run lspci, i can see audio card intel 82801I (ICH9).
    I use a anvantech board(i think audio chip is on board), and a audio module( has alc888 and 7 jack).

    From YAST/Sound, system recognizes an Optiplex 755. But there is no sound. Could you please help me to solve the issue? Thanks...

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: open Suse 11.3 no sound

    Hello go first to yast-->Hardware-->sound. Then select in other--> test sound. If you have sound select this sound card as main. Then go to system settings and check sound again. See first in system settings if you have Gstreamer as Support System.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3

    Default Re: Απ: open Suse 11.3 no sound

    Quote Originally Posted by stamostolias View Post
    Hello go first to yast-->Hardware-->sound. Then select in other--> test sound. If you have sound select this sound card as main. Then go to system settings and check sound again. See first in system settings if you have Gstreamer as Support System.
    In YAST/Sound there is only one sound card (Optiplex 755). Other->play test sound, there is no sound again. what do u mean by "Then go to system settings and check sound again. See first in system settings if you have Gstreamer as Support System"

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Απ: open Suse 11.3 no sound

    I would like to try help, but I'm not smart enough to use the information you provided and come up with a recommendation. Unfortuantely I need a LOT more information to understand as to what should be a good approach.

    Please, can you provide the information that is recommended to be provided (when sound does not work) as described in our multimedia stickie : Welcome to multimedia sub-area ?


    I'll quote this for you to make it easier for you:


    .... please post ... providing in your post the following information:
    • provide the URLs (of a summary webpage) that are created by running the diagnostic script noted here:
      SDB:AudioTroubleshooting - openSUSE - Script to run to obtain detailed information. On openSUSE-11.1 and newer that will ask you to run the script
      Code:
      /usr/sbin/alsa-info.sh
      and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
      .
      Note if for some reason that gives you no website/url/address then run it with the no-upload option:
      Code:
      /usr/sbin/alsa-info.sh --no-upload
      and post the file /etc/alsa-info.txt it creates to Pastebin.com and press SUBMIT on that site and again post here the URL/website-address it provides.
    .

    ... some clarification on running the script "alsa-info.sh" ... when you run:
    Code:
    /usr/sbin/alsa-info.sh
    you should get something like this (if it asks for an update, select NO):


    followed by this (select the SHARE/UPLOAD option):


    followed by this (its quickest if you simply select 'NO' to seeing the output - you will see it on the web page) :


    followed by this (where in RED is the URL).


    Just post the URL you get (similar to the RED URL in my example, but yours will be different).

    Again, if you can not get that, then run this with the no upload option:
    Code:
    /usr/sbin/alsa-info.sh --no-upload
    which will create the file /tmp/alsa-info.txt. Copy that file and paste it on Pastebin.com and press submit. That will give you a URL address. Please post that URL here.






    Also provide the following:
    • in a terminal, or xterm, or konsole, type: rpm -qa '*alsa*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -qa '*pulse*' #and post output here
    • in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here
    • in a terminal, or xterm, or konsole, type: uname -a #and post output here
    • ...
    • for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here

  5. #5

    Default Re: Απ: open Suse 11.3 no sound

    Also ı want to add the output txt file of "alsa-info.sh"

    http://www.alsa-project.org/db/?f=a9...4a285589ccfd7e

  6. #6

    Default Re: Απ: open Suse 11.3 no sound

    [B][B]
    Quote Originally Posted by oldcpu View Post
    I would like to try help, but I'm not smart enough to use the information you provided and come up with a recommendation. Unfortuantely I need a LOT more information to understand as to what should be a good approach.

    Please, can you provide the information that is recommended to be provided (when sound does not work) as described in our multimedia stickie : Welcome to multimedia sub-area ?


    I'll quote this for you to make it easier for you:


    in a terminal, or xterm, or konsole, type: rpm -qa '*alsa*' #and post output here

    alsa-utils-1.0.23-1.8.i586
    alsa-1.0.23-2.12.i586
    alsa-oss-1.0.17-29.2.i586
    alsa-plugins-1.0.23-1.9.i586
    alsa-plugins-jack-1.0.23-1.9.i586
    alsa-plugins-pulse-1.0.23-1.9.i586

    in a terminal, or xterm, or konsole, type: rpm -qa '*pulse*' #and post output here

    libpulse0-0.9.21-9.2.i586
    pulseaudio-module-lirc-0.9.21-9.2.i586
    pulseaudio-module-x11-0.9.21-9.2.i586
    libpulse-mainloop-glib0-0.9.21-9.2.i586
    pulseaudio-utils-0.9.21-9.2.i586
    pulseaudio-module-bluetooth-0.9.21-9.2.i586
    vlc-aout-pulse-1.1.5-4.5.i586
    libpulse-browse0-0.9.21-9.2.i586
    pulseaudio-0.9.21-9.2.i586
    pulseaudio-module-zeroconf-0.9.21-9.2.i586
    pulseaudio-esound-compat-0.9.21-9.2.i586
    alsa-plugins-pulse-1.0.23-1.9.i586
    pulseaudio-module-gconf-0.9.21-9.2.i586


    in a terminal, or xterm, or konsole, type: rpm -q libasound2 #and post output here

    libasound2-1.0.23-2.12.i586

    in a terminal, or xterm, or konsole, type: uname -a #and post output here

    Linux linux-rg6t 2.6.34-12-desktop #1 SMP PREEMPT 2010-06-29 02:39:08 +0200 i686 i686 i386 GNU/Linux

    ...
    for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here


    options snd slots=snd-hda-intel
    # u1Nb.NLpnEGU_GL4:Optiplex 755
    alias snd-card-0 snd-hda-intel

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Απ: open Suse 11.3 no sound

    Quote Originally Posted by electroo View Post
    ...
    for openSUSE-11.2 or newer, in a terminal, or xterm, or konsole, type: cat /etc/modprobe.d/50-sound.conf #and post output here


    options snd slots=snd-hda-intel
    # u1Nb.NLpnEGU_GL4ptiplex 755
    alias snd-card-0 snd-hda-intel
    Thanks. Based on the number of pulse applications on your openSUSE-11.3 it appears you have the Gnome desktop installed. I find in openSUSE-11.4 (which has many pulse applications installed) it is useful to install the package 'pavucontrol' and run 'pavucontrol' and try to use that to configure one's sound. That 'might help'. But it might not.

    From the alsa-info.sh diagnostic script, I note a 32-bit openSUSE-11.3 with the 2.6.34-12-desktop kernel and the 1.0.22.1 alsa (Driver version), and 1.0.23 alsa (Library version) and the 1.0.23 alsa (Utilities version) on a ALC888 hardware audio codec.

    Your mixer settings sound should be working. Please, what are you using as a "sound test" ?

    If your sound test is correct, it is possible that the ALC888 hardware audio codec is misconfigured by the alsa driver upon boot. I note some strange messages in the dmesg at the bottom of the alsa-info.sh script output that you provided. Hence you could try to tune the alsa driver configuration for your ALC888.

    I'm not at my desktop PC, and I don't have the HD-Audio-Models.txt file handy for version 1.0.22 of alsa (which is on your PC, likely located at /usr/src/linux-your-kernel-version/Documentation/sound/alsa. But I do have 1.0.24 of alsa handy and the entry for the ALC888 presumeably has not changed too much between versions. On 1.0.24 of alsa that is:
    Code:
    ALC882/883/885/888/889
    ======================
      3stack-dig             3-jack with SPDIF I/O
      6stack-dig             6-jack digital with SPDIF I/O
      arima                   Arima W820Di1
      targa                   Targa T8, MSI-1049 T8
      asus-a7j               ASUS A7J
      asus-a7m             ASUS A7M
      macpro                 MacPro support
      mb5                     Macbook 5,1
      macmini3              Macmini 3,1
      mba21                  Macbook Air 2,1
      mbp3                    Macbook Pro rev3
      imac24                  iMac 24'' with jack detection
      imac91                  iMac 9,1
      w2jc                      ASUS W2JC
      3stack-2ch-dig        3-jack with SPDIF I/O (ALC883)
      alc883-6stack-dig    6-jack digital with SPDIF I/O (ALC883)
      3stack-6ch             3-jack 6-channel
      3stack-6ch-dig        3-jack 6-channel with SPDIF I/O
      6stack-dig-demo     6-jack digital for Intel demo board
      acer                       Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
      acer-aspire             Acer Aspire 9810
      acer-aspire-4930g    Acer Aspire 4930G
      acer-aspire-6530g    Acer Aspire 6530G
      acer-aspire-7730g    Acer Aspire 7730G
      acer-aspire-8930g    Acer Aspire 8930G
      medion                   Medion Laptops
      medion-md2            Medion MD2
      targa-dig                Targa/MSI
      targa-2ch-dig           Targa/MSI with 2-channel
      targa-8ch-dig           Targa/MSI with 8-channel (MSI GX620)
      laptop-eapd             3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
      lenovo-101e             Lenovo 101E
      lenovo-nb0763          Lenovo NB0763
      lenovo-ms7195-dig    Lenovo MS7195
      lenovo-sky                Lenovo Sky
      haier-w66                  Haier W66
      3stack-hp                  HP machines with 3stack (Lucknow, Samba boards)
      6stack-dell                Dell machines with 6stack (Inspiron 530)
      mitac                        Mitac 8252D
      clevo-m540r               Clevo M540R (6ch + digital)
      clevo-m720                Clevo M720 laptop series
      fujitsu-pi2515             Fujitsu AMILO Pi2515
      fujitsu-xa3530             Fujitsu AMILO XA3530
      3stack-6ch-intel           Intel DG33* boards
      intel-alc889a               Intel IbexPeak with ALC889A
      intel-x58                     Intel DX58 with ALC889
      asus-p5q                     ASUS P5Q-EM boards
      mb31                          MacBook 3,1
      sony-vaio-tt                 Sony VAIO TT
      auto                            auto-config reading BIOS (default)
    Hence what you could do is try specifying each of those model options ONE AT A TIME, restarting alsa after each attempt, and see if that restores your sound.

    Lets say you start from the top of the above list, and try 3stack-dig. To do that, you change the /etc/modprobe.d/50-sound conf file so that it looks like:

    Code:
    options snd-hda-intel model=3stack-dig
    options snd slots=snd-hda-intel
    # u1Nb.NLpnEGU_GL4:Optiplex 755
    alias snd-card-0 snd-hda-intel
    (note the line I added to the start of the file). Save the change.

    Then restart alsa with:
    Code:
    su -c 'rcalsasound restart'
    and enter root password when prompted for a password. And restart your mixer (alsamixer in gnome, by typing as a regular user in a terminal, 'alsamixer' #no quotes). and test.

    If 3stack-dig does not work, then replace it in the /etc/modprobe.d/50-sound.conf file with the next entry in the list (6stack-dig) and again restart alsa, restart mixer, and test.

    Some of those will prevent one's sound from functioning. But hopefully one will get sound working.
    Last edited by oldcpu; 07-Apr-2011 at 05:10. Reason: fixed syntax error

  8. #8

    Default Re: Απ: open Suse 11.3 no sound

    Quote Originally Posted by oldcpu View Post
    Thanks. Based on the number of pulse applications on your openSUSE-11.3 it appears you have the Gnome desktop installed. I find in openSUSE-11.4 (which has many pulse applications installed) it is useful to install the package 'pavucontrol' and run 'pavucontrol' and try to use that to configure one's sound. That 'might help'. But it might not.....
    I'm testing the sound from YAST/Sound Other-->play test sound.
    Also I play wav files with the players.

    I will change the conf file and try the ALC888 model options.

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: Απ: open Suse 11.3 no sound

    Quote Originally Posted by electroo View Post
    I'm testing the sound from YAST/Sound Other-->play test sound.
    Also I play wav files with the players.



    Reference testing for sound, what I typically recommend is to try each of the following in a terminal, first as a regular user and then with root permissions (and also with and without headphones):
    • first:
      Code:
       speaker-test -Dplug:front -c2 -l5 -twav
    • second, try again:
      Code:
      speaker-test -c2 -l5 -twav
    • third:
      Code:
      speaker-test -c2 -D hw:0,0 -t wav -l3
    • fourth, this next command has a volume meter at the bottom of its output with a changing number of #'s and %'s to show volume levels so run this command and tell me if the number of #'s and %'s are changing:
      Code:
      aplay -vv /usr/share/sounds/alsa/Front_*
    • fifth: and also:
      Code:
      aplay -vv /usr/share/sounds/alsa/test.wav
    Despite those tests, my view is your assessment is correct that sound is not functioning.

    Quote Originally Posted by electroo View Post
    I will change the conf file and try the ALC888 model options.
    I think thats the best approach for now. IF that does not work, I can help you update alsa by pointing you to a guide that explains an easy way to update alsa on openSUSE.

  10. #10

    Default Re: Απ: open Suse 11.3 no sound

    Quote Originally Posted by oldcpu View Post
    Reference testing for sound, what I typically recommend is to try each of the following in a terminal, first as a regular user and then with root permissions (and also with and without headphones):
    • first:
      Code:
       speaker-test -Dplug:front -c2 -l5 -twav
    • second, try again:
      Code:
      speaker-test -c2 -l5 -twav
    • third:
      Code:
      speaker-test -c2 -D hw:0,0 -t wav -l3
    • fourth, this next command has a volume meter at the bottom of its output with a changing number of #'s and %'s to show volume levels so run this command and tell me if the number of #'s and %'s are changing:
      Code:
      aplay -vv /usr/share/sounds/alsa/Front_*
    • fifth: and also:
      Code:
      aplay -vv /usr/share/sounds/alsa/test.wav
    Despite those tests, my view is your assessment is correct that sound is not functioning.



    I think thats the best approach for now. IF that does not work, I can help you update alsa by pointing you to a guide that explains an easy way to update alsa on openSUSE.

    I tried different models but that does not work. I use openSUSE 11.3. Now i think i need to upgrade alsa. Could u please help...

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •