Results 1 to 4 of 4

Thread: GRUB Loader will not run if Windows is set as the active partition

  1. #1

    Default GRUB Loader will not run if Windows is set as the active partition

    Hi all,

    A few days ago my Laptop wouldn't hibernate in Windows 7, I managed to fix this problem by going into Windows' Disk Management tool and setting the C:/ Partition as the active partition, this fixed my hibernation issue, however I have just noticed that now when I boot my laptop my GRUB menu no longer appears, instead it just loads Windows straight away as if it was the only OS on my laptop.

    I've confirmed it's something to do with my recent Disk Management change as I booted up GParted, removed the boot flag from Windows and when a rebooted my GRUB menu reappeared.

    Not sure on how I can both have Windows as the active partition while being able to keep GRUB working also.

    My Partition Setup is as follows:

    /dev/sda1 C:/ Windows 7 (NTFS) (Boot Flag Set)
    /dev/sda2 D:/ DATA (Documents and stuff) (NTFS)
    Unallocated 1 MB
    /dev/sda3 Extended 146.49 GB (LBA Flag Set)
    /dev/sda5 Linux Swap 2.01 GB
    /dev/sda6 ext4 20.00 GB
    /dev/sda7 ext4 124.46 GB
    Unallocated 10.00 MB

    I'm running openSUSE 11.4

    Thanks for your help

    James

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,674
    Blog Entries
    3

    Default Re: GRUB Loader will not run if Windows is set as the active partition

    That's not a bug. It's a feature.

    I am guessing that grub is installed to boot from /dev/sda3.

    It seems that hibernation won't work from Windows 7, unless it is the boot system. The easiest way of having both is to setup the Windows boot manager to start grub (as a menu choice). Google for "BCDEDIT linux" (without the quotes) to find pages that show how to set that up.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3

    Default Re: GRUB Loader will not run if Windows is set as the active partition

    Thanks for your reply.

    I've come up with a compromise. I put the Windows 7 Boot loader back on as the default loader and then used EasyBCD to create a GRUB (Legacy) entry and made sure the option "Grub isn't installed to the MBR/bootsector" option was checked. After doing that I am able to boot into openSUSE's GRUB loader through the created boot option via the Windows Boot Loader.

    Thanks for pointing me in the right direction.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,674
    Blog Entries
    3

    Default Re: GRUB Loader will not run if Windows is set as the active partition

    I am glad that you now have it working.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •