Results 1 to 6 of 6

Thread: Crossover Pro 9 does not work - error message

  1. #1

    Default Crossover Pro 9 does not work - error message

    Hi,

    I installed Crossover Office Pro (full release) which I used on previous version of opensuse, but now it is installed on opensuse 11.4 64 bits.

    The installation is fine, but the problems begin when I try to launch the application to install windows software.

    I get this output:

    alienware:/opt/cxoffice/bin # ./cxinstaller
    Traceback (most recent call last):
    File "./cxinstaller", line 85, in <module>
    import gtk
    ImportError: No module named gtk


    It has something to do with python I guess but I tried about every possible solution I could find on the internet but nothing works. Any idea's how to fix this error? I tried all option, but no luck so far.

  2. #2
    Join Date
    Jun 2008
    Location
    Norman, OK
    Posts
    209

    Default Re: Crossover Pro 9 does not work - error message

    Did you install crossover as 'root' or as an individual user (Wondering if your issue is permissions related)? Is Crossover configured for just a single user or everyone on the system? Which desktop environment are you using?

    What happens if you try to Install Windows Software from the "crossover" section of either the GNOME or KDE menu? (for example in GNOME: Applications --> Crossover --> Install Windows Software)?

    Sorry -- lots of questions there. I've used Crossover Professional 9, and am currently using 10 on OpenSuse 11.4 64-bit under GNOME, single-user install, no issues.
    Main Machine: Dell Precision M6600 running openSUSE Leap 16
    Server: Dell PowerEdge SC1430 running SLES 15

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,677
    Blog Entries
    15

    Default Re: Crossover Pro 9 does not work - error message

    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4

    Default Re: Crossover Pro 9 does not work - error message

    I ran the installation as root and as user, no solution, same problem.
    Installed the package as user under Gnome instead of KDE and got the same error.

    I give up. It doesn't work and will never work.

  5. #5
    Join Date
    Jun 2008
    Location
    Norman, OK
    Posts
    209

    Default Re: Crossover Pro 9 does not work - error message

    well, I've got it working, and I've been using Crossover since it was first released, so it does work ... but I understand that sometimes things can be frustrating to troubleshoot.

    Why not try this (since you have the pro version).

    1. uninstall the current version
    2. go get the latest one (10 -- if you have paid support then you are entitled to it).
    3. download the latest installer -- NOT the rpm version
    4. run the installer script

    See if that works better. That's what I've done for multiple versions of Crossover Office / openSUSE / SLED and it's worked every time for me -- so it does work.
    Main Machine: Dell Precision M6600 running openSUSE Leap 16
    Server: Dell PowerEdge SC1430 running SLES 15

  6. #6

    Default Re: Crossover Pro 9 does not work - error message

    I'm not entitled for a free upgrade anymore.
    But I downloaded the trial version 10.
    When I start the Windows install tool I now get a similar error as when I start the tool from the command line.

    It now says that I'm missing some GTK Python libraries * yeah, right, nothing new...*
    It even says how to install them for debian and suse. And for suse it asks me to run the following:

    yast -i python-gtk

    So I did and it installed the requested package and it's addons.

    But when I start crossover it still throws out the same error and continues to ask me to install the same python package again and again while it is installed.

    So as you can see, I tried about everthing that is imaginable and nothing works.
    I spent a lot of time researching this and the more I test and install the more my system behaves unstable. So I'm not going to spent more time.

    If the **** won't install then I don't need it any more.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •