Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Disable kpackagekit / kupdate applet ?

  1. #1
    Join Date
    Sep 2009
    Location
    Liverpool
    Posts
    143

    Default Disable kpackagekit / kupdate applet ?

    Hi, I recently installed Suse 11.4 (running KDE) and my first experiences with the new updater are not great. It seems to stall, require a lot of intervention, fail, and generally not behave nicely. I would much prefer to use zypper manually as I used to but can't find anywhere to disable this applet or process in KDE. Is there any way of disabling this so that the process and systray icon never start?

    Thanks all

  2. #2

    Default Re: Disable kpackagekit / kupdate applet ?

    yeah, I'm looking how to disable kpackagekit too...
    it checks for updates few times a day, and icon appears in the tray which makes all other icons to shift. I don't like this animation. I would like to update my system manually through the Yast

  3. #3

    Default Re: Disable kpackagekit / kupdate applet ?

    just remove the rpm's

    the applet in settings should have an option to not automatically start as should kpackage
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  4. #4
    Join Date
    Sep 2009
    Location
    Liverpool
    Posts
    143

    Default Re: Disable kpackagekit / kupdate applet ?

    Quote Originally Posted by google01103 View Post

    the applet in settings should have an option to not automatically start as should kpackage
    You'd think so wouldn't you? But they don't seem to have.

    I was trying to avoid uninstalling the packages in case of dependency issues.

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,890
    Blog Entries
    3

    Default Re: Disable kpackagekit / kupdate applet ?

    I have not tested it. However, there is a setting for this.

    Personal settings --> Startup and Shutdown --> Service Manager

    then uncheck "KPackageKit Service" in the list of "Startup Services".
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6

    Default Re: Disable kpackagekit / kupdate applet ?

    I found a way to disable it:

    1. hit kicker menu and type into search field "kpackagekit", run it
    2. in kpackagekit window go to settings
    3. set Check for updates to "never"


  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,051
    Blog Entries
    14

    Default Re: Disable kpackagekit / kupdate applet ?

    Open a terminal window and do:
    Code:
    su -c 'rpm -e kpackagekit'
    (enter rootpassword)
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8
    Join Date
    Feb 2010
    Location
    Los Angeles, CA, USA
    Posts
    148

    Default Re: Disable kpackagekit / kupdate applet ?

    i completely removed it from Yast package manager or from command line:

    Code:
    sudo zypper rm kpackagekit
    enter root password and you're done.

    Note: sometimes it won't uninstall because it might be running, just log out and log in again.
    WE ARE LINUX... RESISTANCE IS FUTILE !!
    openSUSE 13.1, KDE
    2 daughters, 1 Dog, lots of passion for Linux

  9. #9
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Re: Disable kpackagekit / kupdate applet ?

    I found a way to disable it:

    1. hit kicker menu and type into search field "kpackagekit", run it
    2. in kpackagekit window go to settings
    3. set Check for updates to "never"
    The tip by tosiara works. I did it with mine some time ago and it stopped messing!
    But other tips suggesting uninstalling are also good.

    greetings
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

  10. #10
    Join Date
    Sep 2009
    Location
    Liverpool
    Posts
    143

    Default Re: Disable kpackagekit / kupdate applet ?

    Thanks all - I went with the suggestion from tosiara as all I wanted was to switch off the behaviour, not uninstall. Seems fine now. :-)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •