Results 1 to 4 of 4

Thread: Certificate problem with yast2

  1. #1

    Default Certificate problem with yast2

    Hello List

    Out of stupidity I removed using yast the package "ssl-cert". At this point yast2 started throwing the error:
    Code:
    Download failed: 
    Download (curl) error for 'https://nu.novell.com/repo/repoindex.xml?cookies=0&credentials=NCCcredentials':
    Error code: Unrecognized error
    Error message: SSL certificate problem, verify that the CA cert is OK. Details: 
    error:14090086:SSL routines:SSL3_GET_SERVER_CERTIFICATE:certificate verify failed
    And of course a redownload and install of ssl-cert is not possible,I get the same error
    So I tried downloading and installing the openssl package by hand, but still I got nowhere
    Does anyone knows how to reinstall this ssl-cert package again??

    Thanks and best regards,
    Moataz

  2. #2

    Default Re: Certificate problem with yast2

    what's the error you get when you install ssl-cert?

  3. #3
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,970

    Default Re: Certificate problem with yast2

    I think You could try to manually download the package from the official repos. Don't know which version You're using :
    Package repositories - openSUSE

    You need to download this package and all the dependencies if required and if they have been installed as well. Once You do that You can use the "rpm" command to install them.

    Best regards,
    Greg
    Best regards,
    Greg

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Certificate problem with yast2

    Sounds like you have problems connecting to a remote repository so you have a "chicken or the egg" problem.

    Recommend you re-install the ssl-cert package from a local source, ie. a DVD install source, not a network install.

    Otherwise, although I don't have the info at my fingertips, you should be able to find the OSS repository GPG key, then manually import and configure, but isn't that harder?

    HTH,
    Tony

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •