Results 1 to 8 of 8

Thread: Reiehenfolge in runlevel ändern (11.4)

  1. #1
    Join Date
    Apr 2011
    Location
    Oldenburg, Germany
    Posts
    1

    Default Reiehenfolge in runlevel ändern (11.4)

    Hallo!

    Ich stöbere in den Archiven nach einer Lösung für obiges Anliegen:
    Als Admin an unserer Schule habe ich Laptops (Suse 11.4) als NFS- und NIS-Clients an unseren Server gekettet. Die Anbindung klappt mit Kabel gebundenem Netzwerk, nicht aber übers Wlan, da network-remotefs erst nach nfs und ypbind gestartet wird.
    Wie ändere ich das so ab, dass nfs und ypbind erst nach Einrichtung der wlan-Verbindung gestartet werden?

    Gruß
    Axel

  2. #2
    Join Date
    Mar 2008
    Location
    Bochum, Germany
    Posts
    3,587

    Default Re: Reiehenfolge in runlevel ändern (11.4)

    Axel,

    ich bin nicht ganz sicher, wie das gehen kann.
    Zum theoretischen Ablauf:
    Schau Dir die Skripte in /etc/init.d mal an. Alle haben einen Header, der von insserv, also beim Einrichten des Dienstes für den automatischen Start ausgelesen wird. Darin stehen auch die abhängigen Dienste:

    ### BEGIN INIT INFO
    # Provides: network-remotefs
    # Required-Start: $network $remote_fs
    # Should-Start:
    # Required-Stop: $network $remote_fs
    # Should-Stop:
    # Default-Start: 3 5
    # Default-Stop:
    # Short-Description: Configure the remote-fs depending network interfaces
    # Description: Configure the remote-fs depending network interfaces as
    # Wireless and set up routing or start the NetworkManager
    ### END INIT INFO

    Das Dingen sieht also beim Start mit Kabel, dass das Netzwerk da ist und startet. Falls WLAN dann schon an ist, sollte es auch klappen. Wenn Du allerdings WLAN später startest und vorher keine Netzverbindung hattest, ist network-remotefs beim Boot nicht gestartet worden, und jetzt läuft das Skript ja nicht mehr von allein. Was ich machen würde: Ich würde dem Network Manager oder womit Du das machst irgendwie beibringen, beim Start des WLAN nochmal "rcnetwork-remotefs restart" auszuführen.

    Hilft das weiter?

    Gruß
    Uwe

  3. #3

    Default Re: Reiehenfolge in runlevel �ndern (11.4)

    mich würde dies auch brennend interessieren.
    Im Internet wird man nicht fündig, es scheint kein Konsolenpianist NFS zu brauchen.
    Beim booten versucht der NFS Client eine Verbindung zum Server aufzubauen bevor das WLAN gestartet wird, und das geht in die Hose. Nach ewig langem Gerödel bricht er die Suche ab.
    Wie kriege ich es hin, daß er beim Booten zuerst eine WLAN Verbindung aufbaut und dann den NFS Clienten aktiviert bzw. es würde mir ja schon reichen wenn er erst beim Benutzer-Login den NFS Clienten aktiviert.
    Kann mir da jemand helfen?

  4. #4
    Join Date
    Oct 2008
    Location
    near Munich
    Posts
    507

    Default AW: Re: Reiehenfolge in runlevel �ndern (11.4)

    Ich hab nfs auch schon lange nicht mehr verwendet, aber ich glaube die Option "soft" in /etc/fstab müsste dazu führen, dass er schneller abbricht.

    Verwendest du NetworkManager oder ifup??
    - openSuse 12.1 3.1.0-1.2-desktop x86_64 KDE: 4.7.4 (4.7.4) "release 11"

    Murphy's Law is recursive. Washing your car to make it rain doesn't work.

  5. #5

    Default Re: Reiehenfolge in runlevel �ndern (11.4)

    ich starte mit ifup.
    Mein Zeil wäre gerne: booten -> WLAN ein -> NFS-Client ein in der Reihenfolge.
    WLAN ist nicht intern sondern mit UBS Stick.
    Danke für Deine Antwort.

    Gruß
    Wodni

  6. #6

    Default Re: Reiehenfolge in runlevel �ndern (11.4)

    so ich habs jetzt mal auf einen anderen Laptop probiert, wo, zufälligerweise, mal WLAN intern geht. Genau dasselbe Problem. Beim booten blinkt die WLAN Lampe und just in dem Augenblick wo man sie braucht, sprich beim starten und mounten vom NFS Clienten, schaltet sich WLAN aus. Ist ja echt "praktisch". Stand der Programmierer unter Drogen, oder was soll dieser Quatsch?

  7. #7

    Default Re: Reiehenfolge in runlevel �ndern (11.4)

    hab endlich die Lösung des Problems gefunden.
    Linux runter, Win7 drauf und dann gehts. Null Probleme mit WLAN und eingebundene Netzlaufwerke. Geht und findet sich immer.
    Ist zwar traurig so eine Richtung einschlagen zu müssen, aber es scheint ja wohl nicht anders zu gehen.
    Keine Lösung gefunden in den Weiten des Indernetz. Ich fasse es nicht, daß ich scheinbar der Einzige bin, der WLAN und NFS Client benutzt, oder wie kann ich die Stille deuten?
    Egal. Es läuft, alle sind zufrieden und können arbeiten.

    Danke für eure Antworten und Mühe.

    Gruß
    Wodni

  8. #8

    Default Re: Reiehenfolge in runlevel �ndern (11.4)

    Die Lösung war bei mir recht einfach:

    Problem: NFS-Service wird vor Netzwerk gestartet -> ERROR

    Lösung:
    1) Yast -> System -> Runlevel_> NFS deaktivieren (bei mir musste ich das Kreuzchen bei 3 und 5 entfernen)
    2) Als Root in der /etc/init.d/after.local folgende Zeile einfügen:
    service nfs start

    Fertig!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •