Results 1 to 3 of 3

Thread: error compiling Amaork from git "No rule to make target `/usr/lib64/libavformat.so"

  1. #1

    Default error compiling Amaork from git "No rule to make target `/usr/lib64/libavformat.so"

    compiling Amarok from git on openSuse 64bit 11.3 (of course it used to work fine)

    using the Packman repo's and they recently switched from ffmpeg to libav (ffmpeg fork) which isn't supposed to cause any issues

    rm'ed amarok dir, re dl'ed and re-compiled but error remains

    anyone else compile it recently?

    Code:
    71%] Building CXX object src/CMakeFiles/amaroklib.dir/ Mpris2AmarokAppAdaptor.o                     
    [ 71%] make[2]: *** No rule to make target `/usr/lib64/libavformat.so', needed by `lib/libamaroklib.so.1.0.0'.  Stop.
    make[2]: *** Waiting for unfinished jobs....
    [ 71%] Building CXX object src/CMakeFiles/amaroklib.dir/Mpris2AmarokPlayerAdaptor.o
    Building CXX object src/CMakeFiles/amaroklib.dir/amarokconfig.o                                      
    make[1]: *** [src/CMakeFiles/amaroklib.dir/all] Error 2                                              
    
    make: *** [all] Error 2
    update - yes I just noticed wrong forum, sorry
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  2. #2

    Default Re: error compiling Amaork from git "No rule to make target `/usr/lib64/libavformat.so"

    seems a symbolic link leads nowhere

    Code:
    ls -l /usr/lib64/libavformat.so
    lrwxrwxrwx 1 root root 23 Mar 26 06:04 /usr/lib64/libavformat.so -> libavformat.so.52.102.0
    circus:/home/smiley/MyTemp/amarok # ls -l /usr/lib64/libavformat.so.52.102.0
    ls: cannot access /usr/lib64/libavformat.so.52.102.0: No such file or directory
    actually seems lots of libav links leading nowhere
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  3. #3

    Default Re: error compiling Amaork from git "No rule to make target `/usr/lib64/libavformat.so"

    seems a symbolic link leads nowhere

    Code:
    ls -l /usr/lib64/libavformat.so
    lrwxrwxrwx 1 root root 23 Mar 26 06:04 /usr/lib64/libavformat.so -> libavformat.so.52.102.0
    circus:/home/smiley/MyTemp/amarok # ls -l /usr/lib64/libavformat.so.52.102.0
    ls: cannot access /usr/lib64/libavformat.so.52.102.0: No such file or directory
    actually seems lots of libav links leading nowhere

    reported it to packager
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •