Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Open SuSE 11.4 nVidia Kwin and Compiz

  1. #1
    Join Date
    Jan 2009
    Location
    Always on the road !
    Posts
    129

    Default Open SuSE 11.4 nVidia Kwin and Compiz

    I have installed OpenSuse 11.4 86x64 on a comp with nVidia GeForce 6150 . The process of installation didn't pass smooth - the new nouveau drivers seem conflicted with some other drivers and destroyed YAST2 GUI in the process of installation. I forbid installation of nouveau drivers and managed to installed fresh 11.4 this way.

    In KDE4 desktop effects worked smoothly before installing nvidia proprietary drivers. It seems KWIN works better with xrender that OpenGL, unfortunatelly xrender does not support all the effects.

    I had always used compiz as composite manager in KDE environment, as it works perfectly with nVidia and OpenGL, and I tried to switch to compiz (compiz comes with the installation dvd ) , but KDE4 does not accept it and returned back to KWIN. There is no more fusion-icon and emerald , so I can not try to switch the compiz manager with fusion-icon.

    Once I managed to switch to compiz but without windows decoration and I am not sure that was clear turning on.

    I checked if the problem is with the compiz , I loged in Gnome and turned on compiz desktop effects, everything got working perfect and smooth. On next logon in Gnome the session did not turn automatically compiz on , I had to do it manually.

    So compiz works perfect with nVidia drivers, KWIN annoyingly slows some actions as grid and expose for example.

    I would like to know if there is another way to start and run compiz as composite manager in KDE4 (I tried with choosing compiz as default window manager that does not work for me) and how to make Gnome to start desktop effects on automatically with the login on.

    Thanks in advance.

  2. #2

    Default Re: Open SuSE 11.4 nVidia Kwin and Compiz

    there's already a thread oor 2 on this

    recap:
    Compiz appears not working under KDE 4.6.x
    emerald no longer supported by Compiz and iirc won't compile in 11.4
    Fusion-icon not compiling in 11.4 (may because it requires Emerald?)

    Compiz is started with "compiz --replace" on the command line
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  3. #3
    Join Date
    Jan 2009
    Location
    Always on the road !
    Posts
    129

    Default Re: Open SuSE 11.4 nVidia Kwin and Compiz

    Thanks for the answer.

  4. #4

    Default Re: Open SuSE 11.4 nVidia Kwin and Compiz

    With 11.3 compiz is working perfectly with KDE 4.6.1. But with 11.4 it's terrible slow, I think it's an issue with the 0.9.x-Release of compiz. I will try the 0.8.6-packages of 11.3 in 11.4.
    If it's working, I will post...

  5. #5
    Join Date
    Nov 2010
    Location
    Kazakhstan, Aktau
    Posts
    84

    Default Re: Open SuSE 11.4 nVidia Kwin and Compiz

    Quote Originally Posted by google01103 View Post
    there's already a thread oor 2 on this

    recap:
    Compiz appears not working under KDE 4.6.x
    emerald no longer supported by Compiz and iirc won't compile in 11.4
    Fusion-icon not compiling in 11.4 (may because it requires Emerald?)

    Compiz is started with "compiz --replace" on the command line
    You say
    Compiz appears not working under KDE 4.6.x
    .
    Below you say
    Compiz is started with "compiz --replace" on the command line
    So does it work or not? For me it works but there is no Window Decoration.

  6. #6
    Join Date
    Nov 2010
    Location
    Kazakhstan, Aktau
    Posts
    84

    Default Re: Open SuSE 11.4 nVidia Kwin and Compiz

    Quote Originally Posted by Herbster0815 View Post
    If it's working, I will post...
    Post the results please even if it won't work.

  7. #7

    Default Re: Open SuSE 11.4 nVidia Kwin and Compiz

    I can confirm that under kde 4.6.1 (neither the shipped 4.6.0) compiz starts but there're no windows decorations.
    Tried to launch kde4-window-decorator --replace but nothing happens, no errors and no window decoration.
    I don't think it's a graphic card issue, i had the same result with Ati, Nvidia and Intel cards.

  8. #8
    Join Date
    Nov 2010
    Location
    Kazakhstan, Aktau
    Posts
    84

    Default Re: Open SuSE 11.4 nVidia Kwin and Compiz

    Quote Originally Posted by occhigrigi View Post
    I can confirm that under kde 4.6.1 (neither the shipped 4.6.0) compiz starts but there're no windows decorations.
    Tried to launch kde4-window-decorator --replace but nothing happens, no errors and no window decoration.
    I don't think it's a graphic card issue, i had the same result with Ati, Nvidia and Intel cards.
    Yes! I have the same issue! May be we should go to the SUSE developers? :-)

  9. #9

    Default Re: Open SuSE 11.4 nVidia Kwin and Compiz

    I see great improvements in Compiz 0.9.4 in stability and I have to say is daaaaaamn fast compared to version 0.8.x

    this is what I did for those who want to try but caution that it's a bit unstable in my opinion and when it fails to regain control i has to select the KDE window manager (KWin) from kde preferences

    1. this is the repo I'm using URL: Index of /repositories/X11:/Compiz/openSUSE_11.4 (from yast change the system packages compiz to this repository)

    Packages


    2. I removed my previous attempts configuration
    ./.config/compiz-1
    ./.config/compiz-1/compizconfig

    3. from CCSM and activate the basic plugins and KDE decorator

    Config 1
    Config 2
    Config 3
    Config 4
    Config 5

    4. Starting Compiz

    Config 1
    Config 2


    Note:
    I see a strange behavior when you click on the title bar to resize the windows to occupy the opposite corner, as usual before the action was that process underway to move the window (Alt + F8 or Alt + button 2 are useful if the window grows too )



    Opensuse 11.4 x 64 Bits
    Nvidia driver 270.30

  10. #10
    Join Date
    Nov 2010
    Location
    Kazakhstan, Aktau
    Posts
    84

    Default Re: Open SuSE 11.4 nVidia Kwin and Compiz

    Quote Originally Posted by bitcero View Post
    I see great improvements in Compiz 0.9.4 in stability and I have to say is daaaaaamn fast compared to version 0.8.x

    Opensuse 11.4 x 64 Bits
    Nvidia driver 270.30
    Hi, guy! Did you really make this? You have a working Compiz? I will try your how-to tomorrow. Hope I will have a success. It's so important for me!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •