Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: have you seen 'Set Basic Path'?

  1. #1

    Default have you seen 'Set Basic Path'?

    hi, i'm newbie on linux.

    i have no idea if my question is belong to this category.

    I tried to use scp like..

    scp -p 1234 111.222.333.444:/home/anonymous/asdf.asd /home/cognita/

    this command asked me password and after typing password it showed

    Set Basic Path

    and didn't copy..

    do you have any idea how i should solve this problem?

    sorry about my poor english..

  2. #2

    Default Re: have you seen 'Set Basic Path'?

    oh, i'm using opensuse 11.3

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,804

    Default Re: have you seen 'Set Basic Path'?

    When you post computer input/output, plkease do so between CODE tags (Posting in Code Tags - A Guide).

    And in this case it would have been usefull to show the complete part of thh session. Just saying "it didn't copy" is without even showing what (error) messages were displayed is not very informative. It does not prove e.g. that /home/anonymous/asdf.asd exists. Let the computer speak!

    An example:
    Code:
    mgi@boven:~> scp beneden:hoera hoera
    Password:
    scp: hoera: No such file or directory
    mgi@boven:~>
    Henk van Velden

  4. #4

    Default Re: have you seen 'Set Basic Path'?

    oh i see.

    code:

    sj@right:~>scp -P 22 111.222.333.444:/home/bjm/waterphantom/test.root ./
    sj@111.222.333.444's password:
    Set Basic Path
    sj@right:~>

    that's all. 'Set Basic Path' was all error message.
    could you help me understand this message?

  5. #5
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,804

    Default Re: have you seen 'Set Basic Path'?

    Maybe you have a different SSH config then I have. As you have seen, mine asks simply Password, while your asks 111.222.333.444's password
    My questions, are you loging in as usr sj at the other system? And do you use sj's password then?

    And I repeat: please put computer output between CODE tags. There is no need to put code: before it because that is of no help. Read the link I provided in the first liine of poist #3 above.
    Henk van Velden

  6. #6

    Default Re: have you seen 'Set Basic Path'?

    the thing i cannot understand is.. it worked before.
    i don't remember exactly when it started not working.
    but i didn't change anything... --a

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: have you seen 'Set Basic Path'?

    seyjoon wrote:

    >
    > oh i see.
    >
    > code:
    >
    > sj@right:~>scp -P 22 111.222.333.444:/home/bjm/waterphantom/test.root
    > ./
    > sj@111.222.333.444's password:
    > Set Basic Path
    > sj@right:~>
    >
    > that's all. 'Set Basic Path' was all error message.
    > could you help me understand this message?
    >
    >

    No idea what that means but can you add the option -v to your command to get
    hopefully the more verbose debug messages from scp like this
    Code:
    scp -v -P 22 111.222.333.444:/home/bjm/waterphantom/test.root ./
    or the short form
    scp -vP 22 111.222.333.444:/home/bjm/waterphantom/test.root ./
    of course with a valid ip address

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.1 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | Gnome 2.32 | nVidia
    ION | 3GB Ram

  8. #8

    Default Re: have you seen 'Set Basic Path'?

    i solved the problem.
    i commented out one line in .bashrc and scp worked~!

    #source /home/software/script/g482.sh

    I don't understand what is relavant exactly, but it works.
    Thank you for your kind posts, Henk and Martin.

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,680
    Blog Entries
    3

    Default Re: have you seen 'Set Basic Path'?

    Quote Originally Posted by seyjoon View Post
    the thing i cannot understand is.. it worked before.
    i don't remember exactly when it started not working.
    but i didn't change anything... --a
    What's the output from:
    Code:
    ssh 111.222.333.444 'echo $PATH'
    The quotes are important. Change the IP to whatever you were really using. And you might need a "-p port" option (to match the "-P port" that you were apparently using with scp).

    There might be a messed up ".bashrc" or other shell initialization file on the destination system.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,804

    Default Re: have you seen 'Set Basic Path'?

    Quote Originally Posted by seyjoon View Post
    i solved the problem.
    i commented out one line in .bashrc and scp worked~!

    #source /home/software/script/g482.sh

    I don't understand what is relavant exactly, but it works.
    Thank you for your kind posts, Henk and Martin.
    That depends on what is in /home/software/script/g482.sh. This should contains bash commands (else the source would be nonsense).
    Henk van Velden

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •