Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Digikam, I can only access camera as root user; openSuse 11.4 KDE

  1. #1
    Join Date
    Apr 2011
    Location
    New Zealand
    Posts
    9

    Default Digikam, I can only access camera as root user; openSuse 11.4 KDE

    This showed up when I tried with Digikam, but I think the problem is system wide. With digikam I get "Failed to connect to the camera," warnings if I add the camera manually and try to connect to it. I get nothing at all if I try to connect to "auto detected camera".

    I can access my Fuji Finepix S2000HD camera with DigiKam if I start Digikam as root user.

    I tried accessing camera through Dolphin as ordinary user and the camera folder showed up, but clicking it produced "Unknown error code 150 Bad parameters Please send a full bug report..." I also get the same error code if I try to access the camera with Gwenview.

    I did a couple of hours of searching for the answer on the Internet, and found "solutions" with other linux distros that ranged from changing an entry in /etc/fstab, to building a set of rules for udev to use when someone attaches a camera. I do suspect that this is a "permissions" problem, but don't know where to set things up in openSuse.

    Any help you can give would be very much appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Digikam, I can only access camera as root user; openSuse 11.4 KDE

    Does this camera have a actual HD?

    If you open a terminal and become su -
    and do

    Code:
    fdisk -l
    does the camera show?
    Show us the result:
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Apr 2011
    Location
    New Zealand
    Posts
    9

    Default Re: Digikam, I can only access camera as root user; openSuse 11.4 KDE

    Hi caf4926,
    Thanks for your quick reply. The camera has no actual HD, I think that the "HD" in it's name refers to the HD video that it can take. I did an fdisk -l as requested (results below) and also an lsusb. You will see the camera listed (last item) with the lsusb

    fdisk -l

    Disk /dev/sda: 320.1 GB, 320072933376 bytes
    255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
    Units = sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disk identifier: 0x8f800000

    Device Boot Start End Blocks Id System
    /dev/sda1 * 63 21703814 10851876 83 Linux
    /dev/sda2 21703815 25912844 2104515 82 Linux swap / Solaris
    /dev/sda3 25912845 46893167 10490161+ 83 Linux
    /dev/sda4 46893735 625137344 289121805 83 Linux

    lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 003: ID 058f:6362 Alcor Micro Corp. Flash Card Reader/Writer
    Bus 002 Device 002: ID 045e:0040 Microsoft Corp. Wheel Mouse Optical
    Bus 001 Device 013: ID 04cb:01e8 Fuji Photo Film Co., Ltd

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: Digikam, I can only access camera as root user; openSuse 11.4 KDE

    I'll have to come back to this
    I have to run
    Others can help in the mean time
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,670
    Blog Entries
    1

    Default Re: Digikam, I can only access camera as root user; openSuse 11.4 KDE

    Hi Ceramics

    I've had something similar happen on occasion with my digital camera (KDE4.6.1, openSUSE 11.3) when I think I selected Dolphin via the notifier and was prompted with a password. I usually click 'Ignore' which then allows me to view photos via Dolphin as user. Anyway, try rebooting with a clean KDE session, reconnect the camera, and see if that fixes things for you. I would also check System Settings>>Device Actions (same as device notifier settings) and check that 'Open with File Manager for 'Camera" exists and contains 'kioclient exec camera:/'

    Try entering 'camera:/' in Dolphin's location bar. Any error reported?

    This may be a particular KDE update that resulted in this behaviour. I'm sure this has happened with 11.3 updates as well. Maybe check the Novell or KDE bug reports.

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,670
    Blog Entries
    1

    Default Re: Digikam, I can only access camera as root user; openSuse 11.4 KDE

    Another quick experiment: With your camera plugged in, execute the following (as user)

    Code:
    gphoto2 --auto-detect
    Is your camera detected ok? Mine for reference (reported as generic PTP camera)

    Code:
    USB PTP Class Camera           usb:            
    USB PTP Class Camera           usb:002,003
    If detected ok, now type the following

    Code:
    cd ~/
    mkdir test
    cd test
    gphoto2 --get-all-files
    Does that work ok?

    As user, what groups are you a member of?

    Code:
    groups

  7. #7
    Join Date
    Apr 2011
    Location
    New Zealand
    Posts
    9

    Default Re: Digikam, I can only access camera as root user; openSuse 11.4 KDE

    Thankyou deano_ferrari for your suggestions.

    I tried all the ones in your first reply, and camera:/ in Dolphin's location bar gives the following error "Unknown error code 150 Bad parameters Please send a full bug report at http://bug.kde.org"

    I checked System Settings>>Device Actions, and 'Open with File Manager for 'Camera" exists and contains 'kioclient exec camera:/'

    I did the reboot and reconnected the camera with the same results.

    Your second "experiments" look promising. Here follow the results:

    > groups
    users video vboxusers

    > gphoto2 --auto-detect
    libusb couldn't open USB device /dev/bus/usb/001/003: Permission denied.
    libusb requires write access to USB device nodes.
    Model Port
    ----------------------------------------------------------
    The same command as root gave the following:
    # gphoto2 --auto-detect
    Model Port
    ----------------------------------------------------------
    Fuji FinePix S2000HD usb:001,007

    My guess is that I need permissions for gphoto2 to do its detective work?

    I just checked that I can access my usb memory stick as my ordinary non root self, and that does work OK.

    Out of interest,... I have been running Windows and Ubuntu via the marvellous VirtualBox, and both can happily download photos from my camera, which is at least a little amusing seeing as their host system can't!

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,670
    Blog Entries
    1

    Default Re: Digikam, I can only access camera as root user; openSuse 11.4 KDE

    I have /etc/udev/rules.d/90-libgphoto2.rules, and this has entries assigning camera devices 'lp' group ownership. So, try adding the relevant user to this group via

    YaST >> Security and Users >> User and Group Management

    Out of interest,... I have been running Windows and Ubuntu via the marvellous VirtualBox, and both can happily download photos from my camera, which is at least a little amusing seeing as their host system can't!
    Yes, but they'll be accessing the usb interface with root permissions via the host.
    Last edited by deano_ferrari; 04-Apr-2011 at 02:21.

  9. #9
    Join Date
    Apr 2011
    Location
    New Zealand
    Posts
    9

    Default Re: Digikam, I can only access camera as root user; openSuse 11.4 KDE

    Ah, I think you may have found the problem... I have looked in /etc/udev/rules.d/ and I have no entry at all for "90-libgphoto2.rules" .

    I had a search and came across this from "old nabble"Old Nabble - gphoto-user - Re: generating missing udev rules to sense all supported cameras OR why do I have to be root to use gphoto2

    "Under Ubuntu Hardy Heron I was missing the udev rules to needed
    to use my Nikon D50. This forced me to be root to use gphoto2 with
    the Nikon D50. The permanent fix for this problem is to generate
    and install the required udev rules via the following command sequence:

    1)>./print-camera-list udev-rules version 0.98 mode 0666 > ./90-libgphoto2.rules
    2)>sudo cp ./90-libgphoto2.rules /etc/udev/rules.d/.
    3)>sudo /etc/init.d/udev restart

    The program print-camera-list is part of the libgphoto2 source."

    I am tempted to try that, but don't know if the version or mode that he uses for udev-rules would be correct for our system as he was writing a year ago about a Ubuntu issue.
    I wondered if you would mind printing your 90-libgphoto2.rules so that I could see what we should be aiming for?

    Anyway, many thanks for progress thus far.

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,670
    Blog Entries
    1

    Default Re: Digikam, I can only access camera as root user; openSuse 11.4 KDE

    Something like this should work (as root):
    Code:
    /usr/lib/libgphoto2/print-camera-list udev-rules mode 0660 version 0.98 group lp > /etc/udev/rules.d/90-libgphoto2.rules
    Some distros use other group names eg 'camera'.

    My 90-libgphoto2.rules entries look like (first and last few lines shown):

    Code:
    # udev rules file for libgphoto2 devices (for udev 0.98 version)
    # Created from this library:
    #   libgphoto2      2.4.9          gcc, ltdl, EXIF
    #   libgphoto2_port 0.8.0          gcc, ltdl, USB, serial lockdev locking
    #
    # this file is autogenerated, local changes will be LOST on upgrades
    ACTION!="add", GOTO="libgphoto2_rules_end"
    SUBSYSTEM!="usb|usb_device", GOTO="libgphoto2_usb_end"
    
    ATTRS{idVendor}=="0553", ATTRS{idProduct}=="0202", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="06bd", ATTRS{idProduct}=="0403", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="06bd", ATTRS{idProduct}=="0404", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="04fc", ATTRS{idProduct}=="504b", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="0553", ATTRS{idProduct}=="0202", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="04fc", ATTRS{idProduct}=="504a", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="0553", ATTRS{idProduct}=="0202", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="08ca", ATTRS{idProduct}=="0111", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="04fc", ATTRS{idProduct}=="504a", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="04fc", ATTRS{idProduct}=="504b", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="0402", ATTRS{idProduct}=="5668", ENV{ID_MEDIA_PLAYER}="1", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="0979", ATTRS{idProduct}=="0224", MODE="0660", GROUP="lp"
    #
    #
    #
    #
    ATTRS{idVendor}=="0d64", ATTRS{idProduct}=="1001", MODE="0660", GROUP="lp"
    PROGRAM="check-ptp-camera 06/01/01", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="2770", ATTRS{idProduct}=="9120", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="2770", ATTRS{idProduct}=="9120", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="093a", ATTRS{idProduct}=="010e", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="093a", ATTRS{idProduct}=="010f", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="0c45", ATTRS{idProduct}=="800a", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="2770", ATTRS{idProduct}=="905c", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="0c45", ATTRS{idProduct}=="8001", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="041e", ATTRS{idProduct}=="6000", ENV{ID_MEDIA_PLAYER}="1", MODE="0660", GROUP="lp"
    ATTRS{idVendor}=="2770", ATTRS{idProduct}=="905c", MODE="0660", GROUP="lp"
    
    LABEL="libgphoto2_usb_end"
    
    KERNEL=="sg[0-9]*", ATTRS{idVendor}=="1908", ATTRS{idProduct}=="1315", MODE="0660", GROUP="lp"
    KERNEL=="sg[0-9]*", ATTRS{idVendor}=="1908", ATTRS{idProduct}=="1320", MODE="0660", GROUP="lp"
    KERNEL=="sg[0-9]*", ATTRS{idVendor}=="1908", ATTRS{idProduct}=="0102", MODE="0660", GROUP="lp"
    KERNEL=="sd[a-z]*", ATTRS{idVendor}=="1403", ATTRS{idProduct}=="0001", MODE="0660", GROUP="lp"
    
    LABEL="libgphoto2_rules_end"
    Last edited by deano_ferrari; 04-Apr-2011 at 03:04.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •