Results 1 to 3 of 3

Thread: Cannot run apche2 with php5

  1. #1

    Smile Cannot run apche2 with php5

    I can't run apache2 with php5. I follow instructions from here: SDB:Linux Apache MySQL PHP - openSUSE but seems stuck at Confirming apache2 works. It did not.

    I noticed that everytime I restart this 'error' will come out :
    [Mon Apr 04 10:40:30 2011] [warn] module rewrite_module is already loaded, skipping
    [Mon Apr 04 10:40:30 2011] [warn] module rewrite_module is already loaded, skipping
    httpd2-prefork: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    Syntax OK
    Shutting down httpd2 (waiting for all children to terminate) done
    Starting httpd2 (prefork) [Mon Apr 04 10:40:32 2011] [warn] module rewrite_module is already loaded, skipping
    [Mon Apr 04 10:40:32 2011] [warn] module rewrite_module is already loaded, skipping
    httpd2-prefork: Could not reliably determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    can anybody help?

  2. #2
    Tom Millican NNTP User

    Default Re: Cannot run apche2 with php5

    Not having the domain name set shouldn't affect it. I see the same
    notice on my development server, but it still works fine.
    What do you see when you go to the localhost (127.0.0.1) link? Is it
    just like mistyping an address in the browser's address bar and
    watching the browser try to find it? Accidentally mistyping it of
    course.
    Have you tried browsing to your public_html folder? If your username is
    akmalfikri, the address would be "http://127.0.0.1/~akmalfikri"
    (I'm assuming this address won't get filtered out of my post and you
    can see it.)



    akmalfikri wrote:

    >
    > I can't run apache2 with php5. I follow instructions from here:
    > 'SDB:Linux Apache MySQL PHP - openSUSE'
    > (http://en.opensuse.org/SDB:Linux_Apache_MySQL_PHP) but seems stuck

    at
    > Confirming apache2 works. It did not.
    >
    > I noticed that everytime I restart this 'error' will come out :
    >> [Mon Apr 04 10:40:30 2011] [warn] module rewrite_module is already
    >> loaded, skipping
    >> [Mon Apr 04 10:40:30 2011] [warn] module rewrite_module is already
    >> loaded, skipping
    >> httpd2-prefork: Could not reliably determine the server's fully
    >> qualified domain name, using 127.0.0.1 for ServerName
    >> Syntax OK
    >> Shutting down httpd2 (waiting for all children to terminate)
    >> done
    >> Starting httpd2 (prefork) [Mon Apr 04 10:40:32 2011] [warn] module
    >> rewrite_module is already loaded, skipping
    >> [Mon Apr 04 10:40:32 2011] [warn] module rewrite_module is already
    >> loaded, skipping
    >> httpd2-prefork: Could not reliably determine the server's fully
    >> qualified domain name, using 127.0.0.1 for ServerName
    >>

    > can anybody help?
    >
    >



  3. #3
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,587
    Blog Entries
    14

    Default Re: Cannot run apche2 with php5

    Browsing 'public_html' is no use. openSUSE uses /srv/www/htdocs as a document root folder.

    Installing a LAMP server is no more than selecting the LAMP pattern in Software Management for install.
    After that you need to configure HTTP-server in Yast - Networkservices, and set mysql to run at boottime.
    Next you need to configure mysql, creating a master user and password. To administer databases you can use phpMyAdmin or phpwebmin
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •