Results 1 to 9 of 9

Thread: Testing Webcam in Skype freezes Skype up

  1. #1
    Tom Millican NNTP User

    Default Testing Webcam in Skype freezes Skype up

    I can't use the webcam with skype. I followed the instructions on the SDB
    Skype page of opensuse.org. I can make calls and recieve calls, but there
    is no video option. Sound isn't going either way during the calls. In
    Skype's options menu, there is a place to test the video. When I click on
    the "Test" button, Skype freezes and eventually the terminate application
    window comes up.
    The webcam is a Logitech that works fine in Cheese, and I've used it with
    previous versions of Opensuse and Skype. The only skype available that
    I've found is the 2.1 beta version, so that's what I'm using. I'm using
    Opensuse 11.4 with KDE4.
    Thanks,
    -tom

  2. #2
    Join Date
    Feb 2010
    Location
    Los Angeles, CA, USA
    Posts
    148

    Default Re: Testing Webcam in Skype freezes Skype up

    I'm using the same version of skype and a Logitech camera (C250) without any problems. One thing i did notice was that the camera wouldn't work with the gstreamer codecs installed by openSuse. I changed all of them to the Packman versions and skype works with my camera without any problems.
    WE ARE LINUX... RESISTANCE IS FUTILE !!
    openSUSE 13.1, KDE
    2 daughters, 1 Dog, lots of passion for Linux

  3. #3
    Tom Millican NNTP User

    Default Re: Testing Webcam in Skype freezes Skype up

    That did it. Thanks a lot!
    I never would have figured that one out on my own.


    Argoson wrote:

    >
    > I'm using the same version of skype and a Logitech camera (C250)

    without
    > any problems. One thing i did notice was that the camera wouldn't work
    > with the gstreamer codecs installed by openSuse. I changed all of them
    > to the Packman versions and skype works with my camera without any
    > problems.
    >
    >



  4. #4
    Join Date
    Feb 2010
    Location
    Los Angeles, CA, USA
    Posts
    148

    Default Re: Testing Webcam in Skype freezes Skype up

    Quote Originally Posted by Tom Millican View Post
    That did it. Thanks a lot!
    I never would have figured that one out on my own.
    well... now you know.
    WE ARE LINUX... RESISTANCE IS FUTILE !!
    openSUSE 13.1, KDE
    2 daughters, 1 Dog, lots of passion for Linux

  5. #5
    Tom Millican NNTP User

    Default Re: Testing Webcam in Skype freezes Skype up

    ....but now I don't have sound in anything. It was there before. The Wifi
    was there before too, but why would that be broken now?
    Perhaps this laptop is too old to find good drivers for. This may be
    reason enough to get another PC. :-)

    Argoson wrote:

    >
    > Tom Millican;2318049 Wrote:
    >> That did it. Thanks a lot!
    >> I never would have figured that one out on my own.
    >>

    >
    > well... now you know.
    >
    >



  6. #6
    Join Date
    Feb 2010
    Location
    Los Angeles, CA, USA
    Posts
    148

    Default Re: Testing Webcam in Skype freezes Skype up

    When you say no sound - is it only when you play a video or music or in the entire system ? check the volume. sometimes kMix will default to mute when i restart the computer.

    I don't see any reason why WiFi will stop working after changing the codecs..

    I have an old laptop as well -HP dv2000 with a 1.86 ghz single core , 512mb ram and broadcom wifi card. still works great with openSuse 11.4 and LXDE desktop.
    WE ARE LINUX... RESISTANCE IS FUTILE !!
    openSUSE 13.1, KDE
    2 daughters, 1 Dog, lots of passion for Linux

  7. #7
    Join Date
    Apr 2010
    Location
    i am location
    Posts
    1,421

    Default Re: Testing Webcam in Skype freezes Skype up

    Quote Originally Posted by Tom Millican View Post
    I can't use the webcam with skype. I followed the instructions on the SDB
    Skype page of opensuse.org. I can make calls and recieve calls, but there
    is no video option. Sound isn't going either way during the calls. In
    Skype's options menu, there is a place to test the video. When I click on
    the "Test" button, Skype freezes and eventually the terminate application
    window comes up.
    The webcam is a Logitech that works fine in Cheese, and I've used it with
    previous versions of Opensuse and Skype. The only skype available that
    I've found is the 2.1 beta version, so that's what I'm using. I'm using
    Opensuse 11.4 with KDE4.
    Thanks,
    -tom
    Don't know if you have a 64bit system, if yes, check my answer on this thread
    Skype

    This repo works for sure and you need to add these lines to it also.
    If you still have the problems, give it a shot.

  8. #8
    Tom Millican NNTP User

    Default Re: Testing Webcam in Skype freezes Skype up

    There was no sound at all, not even the test sound from the sound
    configuration in Yast. I followed Joerg's instructions, and there is
    now sound with the test sound option in Yast, but nothing else. The
    wifi seems to be a coincidence. It doesn't work when booting in Windows
    anymore either, so I think the hardware is dead.
    Thanks for the help. I'll try some other distros and try to find
    something that works with both sound and video. I've spent 1.5 weeks on
    this already with no luck. ...a new pc still sounds like the best
    option.


    Argoson wrote:

    >
    > When you say no sound - is it only when you play a video or music or

    in
    > the entire system ? check the volume. sometimes kMix will default to
    > mute when i restart the computer.
    >
    > I don't see any reason why WiFi will stop working after changing the
    > codecs..
    >
    > I have an old laptop as well -HP dv2000 with a 1.86 ghz single core ,
    > 512mb ram and broadcom wifi card. still works great with openSuse

    11.4
    > and LXDE desktop.
    >
    >



  9. #9

    Default Re: Testing Webcam in Skype freezes Skype up

    I had some issues with Skype as well. One thing you should do is go into kopete and test to see if the cam shows video, if skype still doesnt work turn off kopete as it seems like it might be stealing focus for the cam. Messing with that usually fixes my problems, but you might have to restart skype. The default audio didnt work right away for me but go into the options and click on sound devices and try changing the microphone and testing to see if any of them works. Ohh and dont forget to go into kmix mixer and make sure the mic volume and PCM is up. My volume was all the way down even though that makes no sense.
    Follow me on my blog where I write about Linux, Open Source, and Technology.
    http://bsmith1012.blogspot.com/

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •