Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Bad sound quality

  1. #1
    Join Date
    Nov 2009
    Location
    Iran
    Posts
    32

    Default Bad sound quality

    Hi,

    The quality of sound I am getting is very poor with lots of noises.
    I'm using openSUSE 11.4 on a DELL Inspiron 6400, and the sound is "82801G (ICH7 Family) High Definition Audio Controller".
    I have tried removing pulseaudio but it did not change anything.
    I had no problem with the sound on 11.2 and the quality of sound is normal on Windows.

    I would appreciate any help and would happily provide more information if needed.

    Thanks.

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Bad sound quality

    Firstly Which music files do you use and you have this problem?
    Secondly go to system settings and see if gstreamer is energized.
    And thirdly I want to see your repos
    Code:
    su
    Code:
    # zypper lr -d
    Post the output here.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3
    Join Date
    Nov 2009
    Location
    Iran
    Posts
    32

    Default Re: Απ: Bad sound quality

    Thanks for the reply.

    Quote Originally Posted by stamostolias View Post
    Firstly Which music files do you use and you have this problem?
    Well normally I'm listening to mp3 files using Amarok, but even when I'm listening to music on the internet (e.g flash based applications like youtube or grooveshark) I'm having the same issue.

    I noticed something last night that thought maybe my problem is not sound related but I only notice it when there are some music playing, but couldn't edit my post and didn't want to look I'm bumping the thread.

    I'm using 6 desktop (on KDE) the problem occurs when I switch to a desktop which has an active window on focus. If no window is open in a desktop or if windows are minimized everything is back to normal. But an active window causes the music play with noise and sometime a little slower and I think the system gets respectively slower as well.

    Back to 11.2 everything was normal for me, but about a moth before 11.4 I upgraded from 11.2 to 11.3 and right after upgrading I had problem with my radeon ati, the system crushing right after logging in to the system most of the time. After I noticed how the problem occurs I thought it might be a graphic issue or maybe some other hardware issue and I only notice it when I'm having some music playing. I also should mention that the problem does not occur all the time.

    Quote Originally Posted by stamostolias View Post
    Secondly go to system settings and see if gstreamer is energized.
    I have gstreamer installed if that is what you mean by energized?
    Code:
    linux-svsd:~ # rpm -qa | grep gstreamer
    gstreamer-0_10-fluendo-mp3-12-2.1.i586
    libgstreamer-0_10-0-0.10.32-4.1.i586
    gstreamer-0_10-plugins-base-0.10.32-4.1.i586
    phonon-backend-gstreamer-0_10-4.4.4-3.1.i586
    PackageKit-gstreamer-plugin-0.6.12-1.4.1.i586
    gstreamer-0_10-0.10.32-4.1.i586
    gstreamer-0_10-plugins-good-0.10.27-4.5.1.i586
    gstreamer-0_10-plugin-hal-0.10.27-4.5.1.i586
    gstreamer-0_10-plugin-gnomevfs-0.10.32-4.1.i586
    Quote Originally Posted by stamostolias View Post
    And thirdly I want to see your repos
    Code:
    # zypper lr -d
    Post the output here.
    Here the list of my repos:
    Code:
    linux-svsd:~ # zypper lr -d
    # | Alias                            | Name         | Enabled | Refresh | Priority | Type   | URI                                                                         | Service
    --+----------------------------------+--------------+---------+---------+----------+--------+-----------------------------------------------------------------------------+--------
    1 | Updates-for-openSUSE-11.4-11.4-0 | update       | Yes     | Yes     |   99     | rpm-md | http://download.opensuse.org/update/11.4/                                   |        
    2 | ftp.uni-erlangen.de-suse         | packman      | Yes     | Yes     |   98     | rpm-md | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/openSUSE_11.4/          |        
    3 | openSUSE:11.4:Contrib            | contrib      | Yes     | Yes     |   95     | rpm-md | http://download.opensuse.org/repositories/openSUSE:/11.4:/Contrib/standard/ |        
    4 | repo-debug                       | debug-oss    | No      | Yes     |   90     | NONE   | http://download.opensuse.org/debug/distribution/11.4/repo/oss/              |        
    5 | repo-debug-update                | debug-update | No      | Yes     |   90     | NONE   | http://download.opensuse.org/debug/update/11.4/                             |        
    6 | repo-non-oss                     | non-oss      | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/non-oss/                |        
    7 | repo-oss                         | oss          | Yes     | Yes     |   99     | yast2  | http://download.opensuse.org/distribution/11.4/repo/oss/                    |        
    8 | repo-source                      | source       | No      | Yes     |   99     | NONE   | http://download.opensuse.org/source/distribution/11.4/repo/oss/             |        
    linux-svsd:~ #
    Thanks

  4. #4
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Re: Απ: Bad sound quality

    I have gstreamer installed if that is what you mean by energized?
    I mean if it is enabled. Go to system settings and in phonon check if gstreamer is enabled.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  5. #5
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: Απ: Bad sound quality

    Hi,

    To make sure you have everything needed to gst the best out of your audio system, I suggest you check your multimedia settings here : MultiMedia Checker or mmcheck - Check Your openSUSE MultiMedia Setup in Just 16 Steps

  6. #6
    Join Date
    Nov 2009
    Location
    Iran
    Posts
    32

    Default Re: Re : Re: Απ: Bad sound quality

    Quote Originally Posted by stamostolias View Post
    I mean if it is enabled. Go to system settings and in phonon check if gstreamer is enabled.
    The only place I can see gstreamer is in the backend tab as the preferred one.

    http://i52.tinypic.com/1177hxz.png

    Quote Originally Posted by DaaX View Post
    Hi,

    To make sure you have everything needed to gst the best out of your audio system, I suggest you check your multimedia settings here : MultiMedia Checker or mmcheck - Check Your openSUSE MultiMedia Setup in Just 16 Steps
    Thanks, I'll go through it

  7. #7
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Re: Απ: Bad sound quality

    I thing maybe the pacman repo is responsible for that

    Code:
    2 | ftp.uni-erlangen.de-suse         | packman      | Yes     | Yes     |   98     | rpm-md | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/openSUSE_11.4/          |
    Try to modify this repo using this as URL Index of /suse/openSUSE_11.4/
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  8. #8
    Join Date
    Aug 2010
    Location
    Aveiro, Portugal
    Posts
    313

    Default Re: Απ: Re: Απ: Bad sound quality

    I'm not sure if this helps... but given that you are using KDE, are you sure that Phonon is configured to use which backend? If I remember correctly the default backend is Xine and not gstreamer, so any changes to gstreamer will most likely be futile if the configured backend is Xine.

    Try switching Phonon backend to gstreamer and see if you have the same problems (if you haven't already).

    Knowing which backend you are using is important for this situations. Note that I'm not all wise with KDE (don't use it since 1.1.1), but we might have some cool results.

  9. #9
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: Απ: Re: Απ: Bad sound quality

    Quote Originally Posted by ketheriel View Post
    I'm not sure if this helps... but given that you are using KDE, are you sure that Phonon is configured to use which backend? If I remember correctly the default backend is Xine and not gstreamer, so any changes to gstreamer will most likely be futile if the configured backend is Xine.
    On 11.4 I noted even on KDE, gstreamer precedes xine in the Phonon backend list, so gstreamer will be used first. Unless you switch the order in System Settings>Multimedia.

  10. #10
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    1,711

    Default Απ: Re: Απ: Re: Απ: Bad sound quality

    Yeahh but first thing is to see the repos. As I know this repo

    Code:
     | ftp.uni-erlangen.de-suse         | packman      | Yes     | Yes     |   98     | rpm-md | http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/openSUSE_11.4/          |
    is not so stable.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15.3||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1080 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •