Page 1 of 3 123 LastLast
Results 1 to 10 of 24

Thread: Compiz does not work in 11.4

  1. #1

    Default Compiz does not work in 11.4

    Compiz does not work completely in 11.4 even ccsm does not start with the following output:

    anixx@anixx-desktop:~> ccsm
    /usr/lib64/python2.7/site-packages/gtk-2.0/gtk/__init__.py:40: RuntimeWarning: tp_compare didn't return -1 or -2 for exception
    from gtk import _gtk
    ImportError: PyCapsule_Import could not import module "gi"
    Backend : ini
    Integration : true
    Profile : default
    Adding plugins
    Initializing core options...done
    Traceback (most recent call last):
    File "/usr/bin/ccsm", line 120, in <module>
    mainWin = ccm.MainWin(context, plugin, category)
    File "/usr/lib/python2.7/site-packages/ccm/Window.py", line 59, in __init__
    self.MainPage = MainPage(self, self.Context)
    File "/usr/lib/python2.7/site-packages/ccm/Pages.py", line 1188, in __init__
    pluginWindow = PluginWindow(self.Context)
    File "/usr/lib/python2.7/site-packages/ccm/Widgets.py", line 1608, in __init__
    self.props.hscrollbar_policy = gtk.POLICY_NEVER
    ImportError: PyCapsule_Import could not import module "gi"

    I have tried different Compiz versions. From other threads I found that people have Compiz working under 11.4. So what should I do to get it working as well?

  2. #2
    Join Date
    Jul 2008
    Location
    Planet Earth
    Posts
    195

    Default Re: Compiz does not work in 11.4

    Working fine for me with no issues from this Compiz 0.8.6 and emerald repo:

    Index of /repositories/home:/Herbster0815/openSUSE_11.4

    Many thanks to Herbster for his compilation work.

    What video drivers are you using ? I'm using the Nvidia binary blob.

  3. #3

    Default Re: Compiz does not work in 11.4

    I am also using Nvidia proprietary. Under 11.3 worked well with no issues.

  4. #4

    Default Re: Compiz does not work in 11.4

    Installed from your repository - the same result.

  5. #5
    Join Date
    Jul 2008
    Location
    Planet Earth
    Posts
    195

    Default Re: Compiz does not work in 11.4

    I take it you completely deleted all previous config files of compiz before installing and double check installed versions ?

    Ah, are you using Gnome ?

  6. #6

    Default Re: Compiz does not work in 11.4

    I tried under different DEs. Nothing helps. Even the ccsm does not start.

  7. #7

    Default Re: Compiz does not work in 11.4

    Removing config directory does not help either.

  8. #8
    Join Date
    Jul 2008
    Location
    Planet Earth
    Posts
    195

    Default Re: Compiz does not work in 11.4

    What version of python-ccm and python-compizconfig do you have installed ?

    Mine is 0.8.4-5.1 and 0.8.4-4.1 respectively.

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Compiz does not work in 11.4

    Ansus wrote:

    >
    > Removing config directory does not help either.
    >

    Of course not because that has absolutely nothing todo with compiz. Looking
    at the error you posted some python package can not be loaded.

    self.props.hscrollbar_policy = gtk.POLICY_NEVER
    ImportError: PyCapsule_Import could not import module "gi"

    I have no clue what might be screwed but on my 11.4 system with gnome and
    proprietary nvidia compiz and ccsm works.

    So we could try to figure out what might be different on yours.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.1 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | Gnome 2.32 | nVidia
    ION | 3GB Ram

  10. #10
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: Compiz does not work in 11.4

    Dragon32 wrote:

    >
    > What version of python-ccm and python-compizconfig do you have installed
    > ?
    >
    > Mine is 0.8.4-5.1 and 0.8.4-4.1 respectively.
    >

    Just to add the settings from another working 11.4 system (see below) for
    comparism:
    compizconfig-settings-manager 0.9.2.1-4.1
    libcompizconfig 0.9.2.1-5.1
    python-ccm 0.9.2.1-4.1
    python-compizconfig 0.9.2.1-5.5

    everything from standard repos, no special fancy things from other
    repositories.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.1 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | Gnome 2.32 | nVidia
    ION | 3GB Ram

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •