Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 38

Thread: Packman switch to LibAV

  1. #11
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: Packman switch to LibAV

    Quote Originally Posted by pawanyadav View Post
    yes .............Libav is gone from packman
    So it is
    Interesting.
    Good I switched back to ffmpeg from tumbleweed
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  2. #12

    Default Re: Packman switch to LibAV

    Quote Originally Posted by cjblank View Post
    Yeah and were are all the header files for

    configure: WARNING: libavutil/avutil.h: check for missing prerequisite headers?
    configure: WARNING: libavcodec/avcodec.h: check for missing prerequisite headers?
    configure: WARNING: libavformat/avformat.h: check for missing prerequisite headers?
    configure: WARNING: libswscale/swscale.h: check for missing prerequisite headers?

    ZoneMinder broke and I can't compile it. They're not in the devel package.

    There's one for ya.
    This is not good. I can't break my Zoneminder.
    Vaio F12: i7-740QM 4GB RAM Nvidia GT 330m
    OpenSuse 11.4 64 bit
    Qosmio i7-740QM 8GB RAM Nvidia GT 360m
    500 GB HD 7200 | 1 TB HD
    Opensuse 11.3 64 bit | VBox, Zoneminder & Mythtv

  3. #13

    Default Re: Packman switch to LibAV

    linclkh do you have libffmpeg-devel installed?
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  4. #14

    Default Re: Packman switch to LibAV

    ffmpeg is back in the Packman repo
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  5. #15
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,743
    Blog Entries
    20

    Default Re: Packman switch to LibAV

    Quote Originally Posted by google01103 View Post
    ffmpeg is back in the Packman repo
    Guess what
    I'm not surprised
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #16
    Join Date
    Jun 2008
    Location
    Mallow, Ireland
    Posts
    1,031
    Blog Entries
    1

    Default Re: Packman switch to LibAV

    Maybe DeVeDe might actually work this time.. haven't been able to get it working on my 11.4 installation..
    "To err is human... to really foul up requires the root password."

  7. #17
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: Packman switch to LibAV

    Quote Originally Posted by Dexter1979 View Post
    Maybe DeVeDe might actually work this time.. haven't been able to get it working on my 11.4 installation..
    My guess is it will not. I don't think anyone has brought this problem to the Packman packager's attention, and there are various possibilities which could be the cause of this. Is the gcc version the same between 11.3 and 11.4 ? I have not checked, but I did read one post about the libavcodec (which provides the ac3 encoder/decoder (I think)) where an update to the Intel compiler (?) has broken the ac3 code and hence the code for building DVDs. But I was (and still am) very rushed for time and have no time to follow this up. Someone else (who needs to create DVDs more urgently than I) will need to chase this down.

  8. #18
    Join Date
    Jun 2008
    Location
    Wales, MA
    Posts
    486

    Default Re: Packman switch to LibAV

    For approximately two weeks or so, ever since major changes to ffmpeg/libav I can not burn a DVD in Mythtv from recordings that I have made recently.

    These recordings play fine in mythtv, all my multimedia players, but when trying to make DVD's from them the audio is about 5 seconds out of sync.

    Now I can burn any recording made before all these changes started, and the audio is perfectly in sync.

    So the issue seems to be with the recordings. I rely alot on mythtv and mytharchive, and these changes recently have thrown a major monkey wrench into things, so much so that I am likely to download the older ffmpeg source code and compile it myself.

    That is a major pain in the arse as it is likely going to want a ton of dependencies, and I am going to end up having to make symlinks all over the place, then will have to lock packages in Yast so they don't scream for certain versions of ffmpeg.

    I realize it is impossible for developers to test ffmpeg for compatibilty with every app out there, but ffmpeg won't even create a DVD from a recording that it has recorded itself without the audio becoming out of sync.

    I have tried several methods of creating a DVD with these new recordings and the result is always the same, audio way out of sync.

    There have been all kinds of updates recently centered around ffmpeg and the apps that use it, I was hoping these updates would correct the stituation, unfortunaetly the problem remains.

  9. #19
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,595
    Blog Entries
    38

    Default Re: Packman switch to LibAV

    Quote Originally Posted by brucecadieux View Post
    For approximately two weeks or so, ever since major changes to ffmpeg/libav I can not burn a DVD in Mythtv from recordings that I have made recently..
    Which openSUSE version are you using ? Some users have reported this problem with openSUSE-11.4. Are you encountering this with an openSUSE version BEFORE 11.4 ?

    Has anyone reported this on the Packman Packager mailing list ?

  10. #20
    Join Date
    Jun 2008
    Location
    Wales, MA
    Posts
    486

    Default Re: Packman switch to LibAV

    I always run the latest version of openSUSE. Have been using 11.4 since the rc's came out.

    I reported problems with libav to packman, I never got a reply from them as I usually do when there is a problem, however within two days libav was pulled and ffmpeg was back, but the same problems existed.

    I just installed the ffmpeg from packman 11.3 and am going to record a show, and then test burning.

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •