Page 1 of 4 123 ... LastLast
Results 1 to 10 of 38

Thread: Packman switch to LibAV

  1. #1
    Join Date
    Feb 2010
    Location
    Los Angeles, CA, USA
    Posts
    148

    Default Packman switch to LibAV

    I checked for updates today and noticed that the Packman repository have switched to the new forked FFmpeg library: LibAV. This include gstreamer and other dependent libraries.

    VLC runs without a problem but i wonder what other applications depending on FFmpeg will not run...

    It looks like FFmpeg was removed from the repository.
    WE ARE LINUX... RESISTANCE IS FUTILE !!
    openSUSE 13.1, KDE
    2 daughters, 1 Dog, lots of passion for Linux

  2. #2

    Default Re: Packman switch to LibAV

    Quote Originally Posted by Argoson View Post

    VLC runs without a problem but i wonder what other applications depending on FFmpeg will not run...

    It looks like FFmpeg was removed from the repository.
    seems your right, but libav still includes ffmpeg so I doubt any application will notice.

  3. #3

    Default Re: Packman switch to LibAV

    this explains some of the reasoning why the change [packman] ffmpeg not in monolithic repository
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  4. #4
    Join Date
    Jun 2008
    Location
    Wales, MA
    Posts
    486

    Default Re: Packman switch to LibAV

    Quote Originally Posted by Argoson View Post
    I checked for updates today and noticed that the Packman repository have switched to the new forked FFmpeg library: LibAV. This include gstreamer and other dependent libraries.

    VLC runs without a problem but i wonder what other applications depending on FFmpeg will not run...

    It looks like FFmpeg was removed from the repository.
    I was apprehensive when I saw it was gone, and didn't let libav to update as it wanted to remove ffmpeg. Because I use and rely on mythtv backend and several front ends I didn't want to break it. So I let one of my laptops update, and tested. Mythtv played everything just fine, recordings, dvd rips, and livetv. So I updated the rest of the machines and everything works as it should.

    I was reluctant because mythtv is picky, it can be very, very picky and something as drastic as removing ffmpeg I figured would break it for sure, well it works, and I am happy.

  5. #5

    Default Re: Packman switch to LibAV

    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  6. #6

    Default Re: Packman switch to LibAV

    Yeah and were are all the header files for

    configure: WARNING: libavutil/avutil.h: check for missing prerequisite headers?
    configure: WARNING: libavcodec/avcodec.h: check for missing prerequisite headers?
    configure: WARNING: libavformat/avformat.h: check for missing prerequisite headers?
    configure: WARNING: libswscale/swscale.h: check for missing prerequisite headers?

    ZoneMinder broke and I can't compile it. They're not in the devel package.

    There's one for ya.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: Packman switch to LibAV

    It broke get_iplayer - well it doesn't convert the download from .flv to .mp4
    So I switched back to ffmpeg
    I had to use the tumbleweed packman repo for that
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: Packman switch to LibAV

    So is it wiser to keep ffmpeg? But will there be further updates of ffmpeg? If so from what repo/url can we download them?

  9. #9

    Default Re: Packman switch to LibAV

    Quote Originally Posted by fernando_a_martin View Post
    So is it wiser to keep ffmpeg? But will there be further updates of ffmpeg? If so from what repo/url can we download them?
    there's a discussion about this in the Packman mailing list The Packman April 2011 Archive by date

    as it's a fork there's 2 groups developing and both will be updating

    they can't be hosted on the obs so it's Packman, compile your own or try Google'ing

    Interesting - as of now neither is showing in the Packman repo's
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  10. #10
    Join Date
    Dec 2008
    Location
    Delhi, INdia
    Posts
    108

    Default Re: Packman switch to LibAV

    Quote Originally Posted by google01103 View Post
    there's a discussion about this in the Packman mailing list The Packman April 2011 Archive by date

    Interesting - as of now neither is showing in the Packman repo's
    yes .............Libav is gone from packman

Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •