Results 1 to 7 of 7

Thread: wifi conection problem O.SUSE 11.4 feat pro/wireless calexico2

  1. #1

    Default wifi conection problem O.SUSE 11.4 feat pro/wireless calexico2

    Hello , my problem is the following:
    I have installed Suse 11.4 recently and I'm trying to run the wireless conection and doesn't works.

    Details:
    card: pro/wireless 2200BG Calexico2
    driver instaled (as console said) kernel driver:ipw2200
    hwinfo:

    Code:
    linux-4pom:/home/victorplata # hwinfo --netcard
    25: PCI 604.0: 0282 WLAN controller                             
      [Created at pci.318]
      Unique ID: JNkJ.BmKY+aW7YM0
      Parent ID: 6NW+.pbi2aV6ikBD
      SysFS ID: /devices/pci0000:00/0000:00:1e.0/0000:06:04.0
      SysFS BusID: 0000:06:04.0
      Hardware Class: network
      Model: "Intel PRO/Wireless 2200BG [Calexico2] Network Connection"
      Vendor: pci 0x8086 "Intel Corporation"
      Device: pci 0x4220 "PRO/Wireless 2200BG [Calexico2] Network Connection"
      SubVendor: pci 0x8086 "Intel Corporation"
      SubDevice: pci 0x2701 
      Revision: 0x05
      Driver: "ipw2200"
      Driver Modules: "ipw2200"
      Device File: eth1
      Features: WLAN
      Memory Range: 0xb0101000-0xb0101fff (rw,non-prefetchable)
      IRQ: 17 (115791 events)
      HW Address: 00:16:6f:a3:36:9d
      Link detected: yes
      WLAN channels: 1 2 3 4 5 6 7 8 9 10 11
      WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462
      WLAN bitrates: 1 2 5.5 11 6 9 12 18 24 36 48 54
      WLAN encryption modes: WEP40 WEP104 TKIP CCMP
      WLAN authentication modes: open sharedkey wpa-psk wpa-eap
      Requires: ipw-firmware
      Module Alias: "pci:v00008086d00004220sv00008086sd00002701bc02sc80i00"
      Driver Info #0:
        Driver Status: ipw2200 is active
        Driver Activation Cmd: "modprobe ipw2200"
      Config Status: cfg=no, avail=yes, need=no, active=unknown
      Attached to: #20 (PCI bridge)
    iwconfig:

    Code:
    eth1      IEEE 802.11bg  ESSID:off/any 
              Mode:Managed  Channel:0  Access Point:Not-Associated  
              Bit Rate:0   Tx-Power=20 dBm   Sensitivity=8/0  
              Retry limit:7   RTS thr:off   Fragment thr:off
              Encryption key:off
              Power Management:off
              Link Quality=0  Signal level=0  Noise level=0
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    I have tried to conect by traditional method with YAST, just recognized one network call"Hotel Riga 228", but doesn`'t conect. Also I have tried to conect with Network Manager but this applecation dosen't recognize ANY w. network.

    Any idea , for where continue the work?
    thank all help.

  2. #2
    Join Date
    Oct 2008
    Location
    Madison, Wisconsin North America
    Posts
    222

    Default Re: wifi conection problem O.SUSE 11.4 feat pro/wireless calexico2

    Have you tried Getting Your Wireless to Work

    What has been your process for configuring your connection in Yast & Network manager?
    All the virtuous deeds and merit ... can be destroyed by just one moment of anger.

  3. #3

    Default Re: wifi conection problem O.SUSE 11.4 feat pro/wireless calexico2

    Did you install ipw-firmware? It says in your output that it requires it.

  4. #4

    Default Re: wifi conection problem O.SUSE 11.4 feat pro/wireless calexico2

    Quote Originally Posted by rodhuffaker View Post
    Did you install ipw-firmware? It says in your output that it requires it.
    The firmware was installed, and as I said I have tried with Network Manager and Yast...

    I actually solve the problem, was a compatibility problem with the interface eth1, It doesn't allow ipv6, I have intuitively tried to change some parameters like the "ipv6 enable" and configure the interface by console and now it's working.
    Thank you for collaborations!

  5. #5
    Join Date
    Jun 2011
    Location
    Pennsylvania
    Posts
    14

    Default Re: wifi conection problem O.SUSE 11.4 feat pro/wireless calexico2

    I am also having problems with the wifi on my HP Pavilion dv4170us laptop...it uses the Intel PRO 2200 chipset...how do I get these drivers installed on my system?? I've tried via YaST with no success. I'm using openSUSE 11.4 as of May 30, 2011.

  6. #6
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,236

    Default Re: wifi conection problem O.SUSE 11.4 feat pro/wireless calexico2

    On 06/04/2011 01:36 PM, cyberoptiq wrote:
    >
    > I am also having problems with the wifi on my HP Pavilion dv4170us
    > laptop...it uses the Intel PRO 2200 chipset...how do I get these drivers
    > installed on my system?? I've tried via YaST with no success. I'm using
    > openSUSE 11.4 as of May 30, 2011.


    The drivers are built into the kernel. No installation is necessary!

    Does the output of dmesg mention anything about firmware? You do need to install
    that using YaST.

  7. #7

    Default Re: wifi conection problem O.SUSE 11.4 feat pro/wireless calexico2

    Check openSUSE starter: Step 2. Need mobile broadband? Use the GNOME applet

    This saved me after months reading and loading packages.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •