Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: Clementine Error: Can not play mp3

  1. #1

    Default Clementine Error: Can not play mp3

    Hi, I have just installed clementine and removed amarok. But when I played mp3 they won't play and give this error window

    Clementine Error

    GStreamer could not create the element: volume. Please make sure that you have installed all necessary GStreamer plugins (e.g. OGG and MP3)
    I'm sure if gstreamer already installed because I can play the mp3 using vlc and just worked fine with amarok before. What is possible problem cause this?

  2. #2

    Default Re: Clementine Error: Can not play mp3

    vlc has it's own codecs and amarok may have been using the xine codecs so you may very well be missing gstreamer plugins required to play mp3's

    do you have gstreamer-0_10-fluendo-mp3 installed?
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Clementine Error: Can not play mp3

    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: Clementine Error: Can not play mp3

    Quote Originally Posted by google01103 View Post
    vlc has it's own codecs and amarok may have been using the xine codecs so you may very well be missing gstreamer plugins required to play mp3's

    do you have gstreamer-0_10-fluendo-mp3 installed?
    Yes, it is installed and the latest.

  5. #5

    Default Re: Clementine Error: Can not play mp3

    Actually this is the first thing I did after installation. By the way, i reran the steps. Everything checked but still get the same error.

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Clementine Error: Can not play mp3

    Quote Originally Posted by jasbutut View Post
    Actually this is the first thing I did after installation. By the way, i reran the steps. Everything checked but still get the same error.
    You did the package switch then?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Clementine Error: Can not play mp3

    found Issue 791 - clementine-player - gstreamer backend broken with 0.10.30 - A cross-platform music player based on Amarok 1.4 - Google Project Hosting "You're missing the "volume" element - check you've installed it properly, try running "gst-inspect volume". It should come from /usr/lib/gstreamer-0.10/libgstvolume.so ......... thanks for the hint, in fact i had volume element present, but debugging that lead me to that my registry was corrupted. removing it solved the problem"

    Try renaming folder ~/.config/Clementine/
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  8. #8

    Default Re: Clementine Error: Can not play mp3

    Quote Originally Posted by caf4926 View Post
    You did the package switch then?
    Switch to...? No, I followed instruction for openSUSE 11.3.
    Is that right?

  9. #9

    Default Re: Clementine Error: Can not play mp3

    Quote Originally Posted by google01103 View Post
    found Issue 791 - clementine-player - gstreamer backend broken with 0.10.30 - A cross-platform music player based on Amarok 1.4 - Google Project Hosting "You're missing the "volume" element - check you've installed it properly, try running "gst-inspect volume". It should come from /usr/lib/gstreamer-0.10/libgstvolume.so ......... thanks for the hint, in fact i had volume element present, but debugging that lead me to that my registry was corrupted. removing it solved the problem"

    Try renaming folder ~/.config/Clementine/
    at that link he removed ~/.gstreamer-0.10/registry.x86_64.bin. In my case it is ~/.gstreamer-0.10/registry.i686. I removed it but still no luck.
    I also removed ~/.config/Clementine to reset profile but still get the same error.

  10. #10
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Clementine Error: Can not play mp3

    Quote Originally Posted by jasbutut View Post
    Switch to...? No, I followed instruction for openSUSE 11.3.
    Is that right?
    If you use 11.3 - yes
    But you should still do this on Packman
    http://dl.dropbox.com/u/10573557/Swi...cs/packman.jpg
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •