Results 1 to 7 of 7

Thread: apache and php

  1. #1
    Join Date
    Nov 2010
    Location
    Damanhour-North-Egypt
    Posts
    90

    Default apache and php

    hello every one,,

    i've recently installed Apache/2.2.17 and php5 from the LAMP pattern from Yast
    it included the php5 server module loaded and enabled

    the apache server can handle HTML pages well and cgi binarys

    but it can't interpret a simple "echo statement" in a .php file
    it just sends a plain page

    i don't know if it safe to upload my .conf file but if i have please tell me and i'll do it

  2. #2
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : apache and php

    So, php is not running or the installation has failed somewhere.

  3. #3
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: apache and php

    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  4. #4
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Απ: apache and php

    stamos,

    The problem is not there. He installed the LAMP through the schemas, so maybe something went wrong.

    @mostafaxxx : do this in terminal to reinitialize everything :

    Code:
    /etc/init.d/httpd restart
    Make sure you follow this procedure to see if php works : http://en.opensuse.org/SDB:Linux_Apa...ming_PHP_works

  5. #5
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re : Απ: apache and php

    Quote Originally Posted by DaaX View Post
    stamos,

    The problem is not there. He installed the LAMP through the schemas, so maybe something went wrong.

    @mostafaxxx : do this in terminal to reinitialize everything :

    Code:
    /etc/init.d/httpd restart
    Sorry, I thing maybe the problem based on installing and configuring php and Apache. Maybe will repair it.
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  6. #6
    Join Date
    Nov 2010
    Location
    Damanhour-North-Egypt
    Posts
    90

    Default Re: Απ: apache and php

    ok once again it was my ignorance but that reference needs to be rewritten

    Novell Documentation

    any way thanks for helping

    by the way when i exit the Yast HTTP manager i get the following error

    Code:
    Switch will be removed from the Perl core distribution in the next major release. Please install it from CPAN. It is being used at /usr/share/YaST2/modules/YaPI/HTTPD.pm, line 299.
    but that isn't a problem i usually edit .conf file manual

  7. #7
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: Re: Απ: apache and php

    Quote Originally Posted by mostafaxxx View Post
    ok once again it was my ignorance but that reference needs to be rewritten

    Novell Documentation

    any way thanks for helping

    by the way when i exit the Yast HTTP manager i get the following error

    Code:
    Switch will be removed from the Perl core distribution in the next major release. Please install it from CPAN. It is being used at /usr/share/YaST2/modules/YaPI/HTTPD.pm, line 299.
    but that isn't a problem i usually edit .conf file manual
    Read this https://build.opensuse.org/package/r...penSUSE%3A11.4

    and this perl(Parse::CPAN:ackages:ackage) Downloads - Linux Packages Search
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •