Results 1 to 10 of 10

Thread: Google chrome not working on opens sue 11.3

  1. #1

    Default Google chrome not working on opens sue 11.3

    I just installed google chrome from their website and dobel klik their rmp package for OpenSuse 32 bit ...

    But when i click it , it doesn't work there is only bouncing box of chrome logo loading in my cursor ..

    When i try to run it in terminal:

    stefanus@linux-l9dj:~> google-chrome
    /usr/bin/google-chrome: error while loading shared libraries: libgcrypt.so.11: cannot open shared object file: No such file or directory

    When i try to install the lib

    sudo zypper install libgcrypt.so.11
    root's password:
    Retrieving repository 'Packman Repository' metadata [done]
    Building repository 'Packman Repository' cache [done]
    Loading repository data...
    Reading installed packages...
    'libgcrypt.so.11' not found in package names. Trying capabilities.
    'libgcrypt11' providing 'libgcrypt.so.11' is already installed.
    Resolving package dependencies...

    What is wrong i googled and installed a lot of resp but didn't fix this ..

    Maybe i have to put some line in /usr/bin/google-chrome ?

    Confused .. Please help Thanks for giving time to replying me

  2. #2

    Default Re: Google chrome not working on opens sue 11.3

    what's the result of
    Code:
    ls -l /lib/libgcrypt.so.11*
    if the result is null reinstall libgcrypt11

    also you might try installing Chromium (the opensource version of Chrome) from the contrib repo as that's what I use and works no problem
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  3. #3

    Default Re: Google chrome not working on opens sue 11.3

    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    If your system is 64-bit the you'd need to install libgcrypt11-32bit and
    not just libgcrypt11. I've been running Google Chrome on my 11.3 x86_64
    system forever without issues... currently 10.0.648.204 version.

    Good luck.





    On 04/02/2011 05:06 AM, navets wrote:
    >
    > I just installed google chrome from their website and dobel klik their
    > rmp package for OpenSuse 32 bit ...
    >
    > But when i click it , it doesn't work there is only bouncing box of
    > chrome logo loading in my cursor ..
    >
    > When i try to run it in terminal:
    >
    > stefanus@linux-l9dj:~> google-chrome
    > /usr/bin/google-chrome: error while loading shared libraries:
    > libgcrypt.so.11: cannot open shared object file: No such file or
    > directory
    >
    > When i try to install the lib
    >
    > sudo zypper install libgcrypt.so.11
    > root's password:
    > Retrieving repository 'Packman Repository' metadata [done]
    > Building repository 'Packman Repository' cache [done]
    > Loading repository data...
    > Reading installed packages...
    > 'libgcrypt.so.11' not found in package names. Trying capabilities.
    > 'libgcrypt11' providing 'libgcrypt.so.11' is already installed.
    > Resolving package dependencies...
    >
    > What is wrong i googled and installed a lot of resp but didn't fix this
    > .
    >
    > Maybe i have to put some line in /usr/bin/google-chrome ?
    >
    > Confused .. Please help Thanks for giving time to replying me
    >
    >

    -----BEGIN PGP SIGNATURE-----
    Version: GnuPG v2.0.15 (GNU/Linux)
    Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

    iQIcBAEBAgAGBQJNlws6AAoJEF+XTK08PnB53zkP/2IeoNGKAZvUA+4n0e3yqMZX
    70JJ5jDGCRr1MWrnb/fHw0tpnmHo6vMVT1d9eYNsY1326+pr2ZlmVklePNmgGOIw
    qmgZtybLTGcxKMT+Nhx5MmTUyNweYeG9t9Z6qnR1N7MH2YeA6F/7VmXPaxF2jHue
    hs7D7aNV8fKWexSa1FhBjk6klztP7VxVdyOD262mGqJDpMZXwNGsJYlgAfsVP5NG
    LjAMCn3cZ9kmdNACEPhh9jZFWSoEyOObKkv2E6GOc5vBZQksdHsrkbeQ2wWih4bK
    BiFQ+eTZIEvigDA/V4Iym8UPvRvDHhBSt1JYuK4cQYusPW5WJEOsw7yzQouT9LB+
    lMcHMjDIGJSGGnqSPh+L3kN0rT6jTZLuIngGPn93iZRtbOkqQJByxVBY2wFAbfT7
    XFkoxf6+40kqszSGJsjS9hl9TwAqH2obklpA9aWUB784C4iGc4jnq6JUqzRlScLb
    3dbUa1hkxF+/hoW0ZaZCvwTBg1SsebQLJfZurK9oc89+CPfYSB+VrkxWejWaMapj
    NSK98WriLFalyCfGWGnyzaRXZsj404FV7vHuRm9hwGFCnVdtTuqO+yWTQOE1QFeR
    Gst5F1Gl+lOe3i0VevC1fR5js+WUGBWDXcOrN7g1wjlrZ27tMAp648ydw8KKtDeY
    26/FAkGJOfCBJpmuyj7l
    =ahwy
    -----END PGP SIGNATURE-----

  4. #4

    Default Re: Google chrome not working on opens sue 11.3

    Quote Originally Posted by ab View Post
    -----BEGIN PGP SIGNED MESSAGE-----
    Hash: SHA1

    If your system is 64-bit the you'd need to install libgcrypt11-32bit and
    not just libgcrypt11. I've been running Google Chrome on my 11.3 x86_64
    system forever without issues... currently 10.0.648.204 version.

    Good luck.
    but if th op is 64bit then they should be using the 64bit Google repo http://dl.google.com/linux/rpm/stable/x86_64
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  5. #5

    Default Re: Google chrome not working on opens sue 11.3

    i tried your code is this right ?

    stefanus@linux-l9dj:~> ls -l /lib/libgcrypt.so.11
    ls: cannot access /lib/libgcrypt.so.11: No such file or directory
    stefanus@linux-l9dj:~> ls -l /lib/libgcrypt.so.11*
    ls: cannot access /lib/libgcrypt.so.11*: No such file or directory

    I tried with stars and without stars ..
    How do i reinstall it ? am i wrong ?

    My system is 32 bit ... I used chromium in my previous ubuntu .. And want to try chrome now
    Which is better for speed ?

  6. #6

    Default Re: Google chrome not working on opens sue 11.3

    reinstall libgcrypt11, it does not appear the files it provides are there

    if you run "rpm -ql libcrypt11" it will list what files it provides and it should be /lbgcrypt.so.11 and /lib/libgcrypt.so.11.6.0
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  7. #7
    Join Date
    Jul 2008
    Location
    Planet Earth
    Posts
    194

    Default Re: Google chrome not working on opens sue 11.3

    Or you could do it using Yast:

    Open Yast then software management, search for libgcrypt.so.11 with check box "RPM provides" ticked. Click the tab versions and see what you have installed and from which repo. It should be there in the OSS repo.

  8. #8

    Default Re: Google chrome not working on opens sue 11.3

    Quote Originally Posted by Dragon32 View Post
    Or you could do it using Yast:

    Open Yast then software management, search for libgcrypt.so.11 with check box "RPM provides" ticked. Click the tab versions and see what you have installed and from which repo. It should be there in the OSS repo.
    I installed it with yast .. The chrome is now open with little dialog box , to choose my search engine but i can't click it or chose anything ....

    Here is the error message now .. not sure if it's an error message ..

    stefanus@linux-l9dj:/opt/lampp/htdocs/wordpress/wp-content/themes/coffeetree> google-chrome
    /usr/bin/google-chrome: /lib/libz.so.1: no version information available (required by /usr/bin/google-chrome)
    /usr/bin/google-chrome: /lib/libz.so.1: no version information available (required by /usr/bin/google-chrome)
    /opt/google/chrome/chrome: /lib/libz.so.1: no version information available (required by /opt/google/chrome/chrome)
    /opt/google/chrome/chrome: /lib/libz.so.1: no version information available (required by /opt/google/chrome/chrome)
    [9218:9218:9981697528:ERROR:json_pref_store.cc(91)] Error reading Preferences: File doesn't exist. /home/stefanus/.config/google-chrome/Local State: No such file or directory
    [9218:9218:9981853242:ERROR:json_pref_store.cc(91)] Error reading Preferences: File doesn't exist. /home/stefanus/.config/google-chrome/Default/Preferences: No such file or directory
    /proc/self/exe: /lib/libz.so.1: no version information available (required by /proc/self/exe)
    /proc/self/exe: /lib/libz.so.1: no version information available (required by /proc/self/exe)
    ^CHandling SIGINT.
    Successfully wrote to shutdown pipe, resetting signal handler.
    Handling SIGINT.
    Check failed: g_shutdown_pipe_write_fd != -1
    ^C

    the windows cannot be closed so I press ctrl c ..

  9. #9

    Default Re: Google chrome not working on opens sue 11.3

    remove chrome and install chromium from the repos software.opensuse.org: Search Results it may matter because it was built to run in openSuse

    what is chromium http://en.wikipedia.org/wiki/Chromium_(web_browser)
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  10. #10

    Default Re: Google chrome not working on opens sue 11.3

    The chrome works , i don't know when i shutdown .. it opens .. then just works .. I don't know why but thank you

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •