Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Virtualbox permissions problem

  1. #1
    Join Date
    Apr 2011
    Location
    Nutley, NJ USA
    Posts
    354

    Default Virtualbox permissions problem

    I installed Oracle Virtualbox through the Install/Remove Software option. When I run the program, it says this:

    You are not a member of the "vboxusers" group. Please add yourself to this group before starting Virtualbox. You could do it by using: YaST / Security and Users / Users and Group Management. Don't forget to re-login to your account!

    How do I solve this problems so that Virtualbox will work?

  2. #2

    Default Re: Virtualbox permissions problem

    Open up Yast and select Security and Users | Users and Group Management. Select your user and then Edit. You should see a tab called Details click on it and off on the right you'll see Additional Groups: select vboxusers. Click OK a few times and then close Yast and log out and back in.

    You can also run this from the terminal as root
    Code:
    useradd -G vboxusers youruser

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Virtualbox permissions problem

    On 04/01/2011 05:06 PM, wellywu wrote:
    >
    > Please add yourself to
    > this group before starting Virtualbox ... by using: YaST /
    > Security and Users / Users and Group Management. Don't forget to
    > re-login to your account!
    >
    > How do I solve this problems so that Virtualbox will work?


    try adding yourself to the vboxusers group in YaST! for example:

    -open YaST
    -go Security & Users (on left)
    -then to User & Group Management (on the right)
    -click on your login/name
    -click on the Edit button
    -click on the Details button
    -in the Additional Groups window
    --scroll down and find the vboxusers line
    --left click to put a check mark in that group
    -click OK
    -look at your login/name line and check you have added yourself to the
    vboxusers group in YaST
    -click OK
    -log out of your current session
    -log into a new session

    --
    CAVEAT: http://is.gd/bpoMD
    Tried LibreOffice? Do that and help at http://is.gd/dZ9j2W
    [NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

  4. #4
    Join Date
    Apr 2011
    Location
    Nutley, NJ USA
    Posts
    354

    Default Re: Virtualbox permissions problem

    Thank you. It worked. Now, I need to install Microsoft Windows 7 Professional 32 bit and Microsoft Office 2010 Professional Plus 32 bit plus Microsoft 2010 Visual Studio Professional with MSDN.

  5. #5

    Default Re: Virtualbox permissions problem

    Bump.

    I have the same issue. Instinctively I added myself to the vboxusers group.

    Code:
    linux-20mf:/home/stefan # useradd -G vboxusers stefan
    useradd: Account `stefan' already exists.
    or




    However despite this, I still get the same error message:




    I tried running as root from the command line - one was just the name, the other had a %U on the end, as that is what the icon's shortcut did:
    Code:
    linux-20mf:/home/stefan # VirtualBox
    Qt WARNING: QGtkStyle was unable to detect the current GTK+ theme.
    g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
    /usr/bin/VirtualBox: line 4: 25941 Terminated              LD_LIBRARY_PATH="/usr/lib/virtualbox${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}" /usr/lib/virtualbox/VirtualBox $@
    
    
    linux-20mf:/home/stefan # VirtualBox %U
    Qt WARNING: QGtkStyle was unable to detect the current GTK+ theme.
    g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
    /usr/bin/VirtualBox: line 4: 25969 Terminated              LD_LIBRARY_PATH="/usr/lib/virtualbox${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}" /usr/lib/virtualbox/VirtualBox $@
    I'm running 11.4 and haven't done anything to my gtk+ theme.

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Virtualbox permissions problem

    Quote Originally Posted by steferfootballdude13 View Post
    Bump.

    I have the same issue. Instinctively I added myself to the vboxusers group.

    Code:
    linux-20mf:/home/stefan # useradd -G vboxusers stefan
    useradd: Account `stefan' already exists.
    or




    However despite this, I still get the same error message:




    I tried running as root from the command line - one was just the name, the other had a %U on the end, as that is what the icon's shortcut did:
    Code:
    linux-20mf:/home/stefan # VirtualBox
    Qt WARNING: QGtkStyle was unable to detect the current GTK+ theme.
    g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
    /usr/bin/VirtualBox: line 4: 25941 Terminated              LD_LIBRARY_PATH="/usr/lib/virtualbox${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}" /usr/lib/virtualbox/VirtualBox $@
    
    
    linux-20mf:/home/stefan # VirtualBox %U
    Qt WARNING: QGtkStyle was unable to detect the current GTK+ theme.
    g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
    /usr/bin/VirtualBox: line 4: 25969 Terminated              LD_LIBRARY_PATH="/usr/lib/virtualbox${LD_LIBRARY_PATH:+:$LD_LIBRARY_PATH}" /usr/lib/virtualbox/VirtualBox $@
    I'm running 11.4 and haven't done anything to my gtk+ theme.
    So, where have you placed the Virtual Partitions and where are the Virtual Configurations (the folder "VirtualBox VMs") located and what write permissions do you have there? I can tell you that when I installed VirtualBox in openSUSE 11.4 using the Oracle repository, the "VirtualBox VMs" folder was located in the /root folder and I do not know why. As root I moved them to my /home folder and as root I changed them to belong to me and then all worked OK. I did make sure that the Virtual Partitions went into a folder I have rights to. This was in addition to adding in myself to the vboxusers group.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7

    Default Re: Virtualbox permissions problem

    Quote Originally Posted by jdmcdaniel3 View Post
    So, where have you placed the Virtual Partitions and where are the Virtual Configurations (the folder "VirtualBox VMs") located and what write permissions do you have there? I can tell you that when I installed VirtualBox in openSUSE 11.4 using the Oracle repository, the "VirtualBox VMs" folder was located in the /root folder and I do not know why. As root I moved them to my /home folder and as root I changed them to belong to me and then all worked OK. I did make sure that the Virtual Partitions went into a folder I have rights to. This was in addition to adding in myself to the vboxusers group.

    Thank You,
    Strangest thing, a reboot fixed the problem. Thanks for the response though jdmcdaniel3.

    However don't the Virtual Partitions and where are the Virtual Configuration files get generated after you run VirtualBox? I had just installed virtualbox and it wouldn't run - I hadn't configured anything. For instance, I am creating a virtual disk right now that will be in "~/VirtualBox VMs"

    Basically: I thought it was specified at runtime.

  8. #8
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Default Re: Virtualbox permissions problem

    Quote Originally Posted by steferfootballdude13 View Post
    Strangest thing, a reboot fixed the problem. Thanks for the response though jdmcdaniel3.

    However don't the Virtual Partitions and where are the Virtual Configuration files get generated after you run VirtualBox? I had just installed virtualbox and it wouldn't run - I hadn't configured anything. For instance, I am creating a virtual disk right now that will be in "~/VirtualBox VMs"

    Basically: I thought it was specified at runtime.
    You can select where the virtual disks go, but the default may not be good, so make sure to place them where you have the correct rights. The "VirtualBox VMs" folder can be set in the program configuration , but the default in my case was in /root which is not good. It can be moved and the configuration changed, but it is one thing you would want to examine when you first install VirtualBox. So, as a new user who just installed VirtualBox, you don't really know what it is doing or where anything goes by default and so it is possible to create your first VM in such a way by default as only root can use it. After you get the hang of it, it is a really nice Virtual Manager that works very well with openSUSE including 12.1.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  9. #9

    Default Re: Virtualbox permissions problem

    To allow all users (members of vboxusers) to boot the virtual machines, set the VMs folder to a directory (preferably outside of /home). I personally use /srv/vbox. Change the user ownership of this directory to root and the group ownership to vboxusers. Example:

    Code:
    chown root:vboxusers /srv/vbox
    Then you can create and use virtual machines as any user. However, every time you boot a virtual machine as a given user, the vm configuration file (a .xml file), as well as the logs will change ownership to this user and become unreadable for the rest of the world, including the vboxusers group (0600). IIt suffices to execute a command as root to restore the vm access rights to all members of the vboxusers group. Here's the command:

    Code:
    find /srv/vbox -type d -exec chmod 775 "{}" ";" -exec chown "root:vboxusers" "{}" ";" ; find /srv/vbox -type f -exec chmod 664 "{}" ";" -exec chown "root:vboxusers" "{}" ";"'
    Don't forget to change /srv/vbox in this example to your vm folder.
    Since this command is to simple to fit in a script () and doesn't require arguments (no need to make a function either), put in in an alias in your root environment and run it any time it's needed.

    Code:
    alias vboxperm='find /srv/vbox -type d -exec chmod 775 "{}" ";" -exec chown "root:vboxusers" "{}" ";" ; find /srv/vbox -type f -exec chmod 664 "{}" ";" -exec chown "root:vboxusers" "{}" ";"'
    * Of course the same default machine folder has to be set by each user in its VirtualBox preferences (the file is saved for each user in ~/VirtualBox/VirtualBox.xml).

  10. #10
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Thumbs up Re: Virtualbox permissions problem

    Quote Originally Posted by please_try_again View Post
    To allow all users (members of vboxusers) to boot the virtual machines, set the VMs folder to a directory (preferably outside of /home). I personally use /srv/vbox. Change the user ownership of this directory to root and the group ownership to vboxusers. Example:

    Code:
    chown root:vboxusers /srv/vbox
    Then you can create and use virtual machines as any user. However, every time you boot a virtual machine as a given user, the vm configuration file (a .xml file), as well as the logs will change ownership to this user and become unreadable for the rest of the world, including the vboxusers group (0600). IIt suffices to execute a command as root to restore the vm access rights to all members of the vboxusers group. Here's the command:

    Code:
    find /srv/vbox -type d -exec chmod 775 "{}" ";" -exec chown "root:vboxusers" "{}" ";" ; find /srv/vbox -type f -exec chmod 664 "{}" ";" -exec chown "root:vboxusers" "{}" ";"'
    Don't forget to change /srv/vbox in this example to your vm folder.
    Since this command is to simple to fit in a script () and doesn't require arguments (no need to make a function either), put in in an alias in your root environment and run it any time it's needed.

    Code:
    alias vboxperm='find /srv/vbox -type d -exec chmod 775 "{}" ";" -exec chown "root:vboxusers" "{}" ";" ; find /srv/vbox -type f -exec chmod 664 "{}" ";" -exec chown "root:vboxusers" "{}" ";"'
    * Of course the same default machine folder has to be set by each user in its VirtualBox preferences (the file is saved for each user in ~/VirtualBox/VirtualBox.xml).
    Great stuff please_try_again! Thanks so much for the information.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •