Results 1 to 2 of 2

Thread: Proxy-Ausnahme funktioniert nicht unter Suse 11.4

  1. #1

    Default Proxy-Ausnahme funktioniert nicht unter Suse 11.4

    Hallo,

    wir haben das folgende Problem seit der Umstellung von 11.2 auf 11.4

    wir können aus Subversion nicht mehr auschecken. Der SVN Server reklamiert
    mit der Fehlermeldung:

    "svn: Der Server hat einen unerwarteten Rückgabewert (503 Service Unavailable) in Antwort auf die Anfrage OPTIONS für »http://svn01.albis.local:8080/svn/UG...irmware/trunk« zurückgeliefert"

    Unsere Analyse hat ergeben, dass der svn - Befehl über den Proxy läuft obwohl wir bei der
    Proxy-Konfiguration eine Ausnahme konfiguriert haben (dies hat mit Suse 11.2 funktioniert).

    Unsere Analyse hat weiter ergeben, dass wir den Proxy deaktivieren können und dann funktioniert
    das Auschecken aus Subversion einwandfrei.

    Weiter haben wir festgestellt, dass bei aktiviertem Proxy die klein geschriebene Envirement - Variable "http_proxy" gelöscht werden muss, und dann funktioniert das Auschecken aus Subversion auch.

    Wer kann uns da weiterhelfen?

    Gruss
    Martin

    =======================================================
    Proxy-Konfiguration

    x Proxy aktivieren
    HTTP-Proxy-URL
    http://proxy.albis.local:xxxx
    Proxy-Ausnahmen
    localhost, 127.0.0.1, svn01.albis.local
    =======================================================

    printenv
    =======================================================
    LESSKEY=/etc/lesskey.bin
    MANPATH=/usr/lib64/mpi/gcc/openmpi/share/man:/usr/local/man:/usr/share/man
    NNTPSERVER=news
    KDE_MULTIHEAD=false
    DM_CONTROL=/var/run/xdmctl
    HOSTNAME=linux-ucs7
    XKEYSYMDB=/usr/X11R6/lib/X11/XKeysymDB
    TERM=xterm
    SHELL=/bin/bash
    HOST=linux-ucs7
    HISTSIZE=1000
    XDG_SESSION_COOKIE=6b050dcfcaf094a4a7c7a30e000002ae-1301638524.750921-1589374161
    XDM_MANAGED=method=classic,auto
    PROFILEREAD=true
    GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/vonamar0/.gtkrc-2.0-kde4:/home/vonamar0/.gtkrc-2.0-qtengine:/home/vonamar0/.gtkrc-2.0:/home/vonamar0/.kde4/share/config/gtkrc-2.0
    KONSOLE_DBUS_SERVICE=:1.75
    TMPDIR=/tmp
    GTK_RC_FILES=/etc/gtk/gtkrc:/home/vonamar0/.gtkrc::/home/vonamar0/.kde4/share/config/gtkrc
    GS_LIB=/home/vonamar0/.fonts
    WINDOWID=92274727
    MORE=-sl
    XSESSION_IS_UP=yes
    SHELL_SESSION_ID=20183b11beca400080f8e56d40009c9b
    KDE_FULL_SESSION=true
    NO_PROXY=localhost, 127.0.0.1, svn01.albis.local
    http_proxy=http://proxy.albis.local:3128
    USER=vonamar0
    JRE_HOME=/usr/lib64/jvm/jre
    LS_COLORS=no=00:fi=00:di=01;34:ln=00;36:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=41;33;01:ex=00;32:*.cmd=00;32:*.exe=01;32:*.com=01;32:*.bat=01;32:*.btm=01;32:*.dll=01;32:*.tar=00;31:*.tbz=00;31:*.tgz=00;31:*.rpm=00;31:*.deb=00;31:*.arj=00;31:*.taz=00;31:*.lzh=00;31:*.lzma=00;31:*.zip=00;31:*.zoo=00;31:*.z=00;31:*.Z=00;31:*.gz=00;31:*.bz2=00;31:*.tb2=00;31:*.tz2=00;31:*.tbz2=00;31:*.xz=00;31:*.avi=01;35:*.bmp=01;35:*.fli=01;35:*.gif=01;35:*.jpg=01;35:*.jpeg=01;35:*.mng=01;35:*.mov=01;35:*.mpg=01;35:*.pcx=01;35:*.pbm=01;35:*.pgm=01;35:*.png=01;35:*.ppm=01;35:*.tga=01;35:*.tif=01;35:*.xbm=01;35:*.xpm=01;35:*.dl=01;35:*.gl=01;35:*.wmv=01;35:*.aiff=00;32:*.au=00;32:*.mid=00;32:*.mp3=00;32:*.ogg=00;32:*.voc=00;32:*.wav=00;32:
    LD_LIBRARY_PATH=/usr/lib64/mpi/gcc/openmpi/lib64
    XNLSPATH=/usr/share/X11/nls
    HOSTTYPE=x86_64
    FTP_PROXY=
    FROM_HEADER=
    SESSION_MANAGER=local/linux-ucs7:@/tmp/.ICE-unix/1835,unix/linux-ucs7:/tmp/.ICE-unix/1835
    PAGER=less
    CSHEDIT=emacs
    XDG_CONFIG_DIRS=/etc/xdg
    MINICOM=-c on
    DESKTOP_SESSION=default
    PATH=/usr/lib64/mpi/gcc/openmpi/bin:/home/vonamar0/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib64/jvm/jre/bin
    MAIL=/var/spool/mail/vonamar0
    CPU=x86_64
    QT_IM_MODULE=xim
    JAVA_BINDIR=/usr/lib64/jvm/jre/bin
    PWD=/home/vonamar0/workspace/trunk/trunk
    INPUTRC=/home/vonamar0/.inputrc
    XMODIFIERS=@im=local
    JAVA_HOME=/usr/lib64/jvm/jre
    LANG=de_DE.UTF-8
    KDE_SESSION_UID=1000
    PYTHONSTARTUP=/etc/pythonstart
    KONSOLE_DBUS_SESSION=/Sessions/1
    HTTPS_PROXY=
    GPG_TTY=/dev/pts/0
    QT_SYSTEM_DIR=/usr/share/desktop-data
    COLORFGBG=15;0
    SHLVL=2
    HOME=/home/vonamar0
    OSTYPE=linux
    KDE_SESSION_VERSION=4
    ALSA_CONFIG_PATH=/etc/alsa-pulse.conf
    SDL_AUDIODRIVER=pulse
    LANGUAGE=
    LESS_ADVANCED_PREPROCESSOR=no
    LS_OPTIONS=-N --color=tty -T 0
    no_proxy=localhost, 127.0.0.1, svn01.albis.local
    XCURSOR_THEME=DMZ
    HTTP_PROXY=http://proxy.albis.local:3128
    WINDOWMANAGER=/usr/bin/startkde
    LESS=-M -I -R
    G_FILENAME_ENCODING=@locale,UTF-8,ISO-8859-15,CP1252
    LOGNAME=vonamar0
    MACHTYPE=x86_64-suse-linux
    CVS_RSH=ssh
    DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-MPtBY9lKnj,guid=b4f901839776a73b241d6df90000000f
    XDG_DATA_DIRS=/usr/share
    LESSOPEN=lessopen.sh %s
    USE_FAM=
    WINDOWPATH=7
    PROFILEHOME=
    DISPLAY=:0
    QT_PLUGIN_PATH=/home/vonamar0/.kde4/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/
    GTK_IM_MODULE=cedilla
    XAUTHLOCALHOSTNAME=linux-ucs7
    LESSCLOSE=lessclose.sh %s %s
    QT_IM_SWITCHER=imsw-multi
    G_BROKEN_FILENAMES=1
    COLORTERM=1
    JAVA_ROOT=/usr/lib64/jvm/jre
    OLDPWD=/home/vonamar0/workspace/trunk
    _=/usr/bin/printenv
    ===========================================================
    Last edited by pistazienfresser; 01-Apr-2011 at 02:36. Reason: offensichtlich ungewollte Smilys

  2. #2

    Default Re: Proxy-Ausnahme funktioniert nicht unter Suse 11.4

    Hi

    I have the same problem with Subversion and proxy authentication. My set up worked correctly under OpenSuse 11.3 but since upgrading to 11.4, I am unable to successfully use the svn command line. (The Subclipse plug-in works fine from Eclipse so I know the repository is there and working.)

    I have tried turning on and off the Proxy service in Yast, setting the proxy setting in ~/.subversion/servers but nothing seems to work.
    (I can access online updates and do installation from the software repositories without any problems.)

    What is different about the svn and proxy authentication between 11.3 and 11.4 and why is it not ignoring the proxy for local servers within our network?

    aisling@sol:~> svn co http://<server-name>/svn/java/pnp-common/trunk
    svn: Server sent unexpected return value (407 Proxy Authentication Required) in response to OPTIONS request for 'http://<server-name>/svn/java/pnp-common/trunk'

    Thanks
    Aisling

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •