Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: LibreOffice - when opening a document cpu spikes and is unusable for 8 seconds

  1. #1

    Angry LibreOffice - when opening a document cpu spikes and is unusable for 8 seconds

    Running 3.3.2.... of LibreOffice under 64bit 11.3

    When I open a document (.doc) it opens right away, then the cpu spikes for about 8 seconds during which the app is not usable then all is fine.

    Renamed .libreoffice and made no difference. Tried with both .doc and .odf document types and the same

    If I open a empty doc then the spike is a second or 2

    Anyone else seeing this?

    thanks,
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,844

    Default Re: LibreOffice - when opening a document cpu spikes and is unusable for 8 seconds

    No, not here with 11.3/64bit/KDE4.6. Also not in the office (same config).

    What is the cpu-hungry process? Same issue with java disabled? Or with openGL acceleration disabled?

  3. #3

    Default Re: LibreOffice - when opening a document cpu spikes and is unusable for 8 seconds

    definitely Java, disabled it and the spike went away though when I open a doc it asks to enable Java because it's required. Did not experience this in OO, nor iirc in the earlier version of LO (alway had Java enabled). Not enabling Java is/is not problematic? note: spike shown in Top as LO, not Java

    q? openGL disabling within LO?

    thanks,
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  4. #4
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,844

    Default Re: LibreOffice - when opening a document cpu spikes and is unusable for 8 seconds

    AFAIK Java is/was required for some wizards and for base, and mostly because Sun wanted to leverage Java (IMO). It'll probably be removed from LO some time in the future. I routinely disable it.

    Re openGL: see tools>options>display>use hardware acceleration when displaying images. That is done with openGL (at least it's named so in OOo).

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: LibreOffice - when opening a document cpu spikes and is unusablefor 8 seconds

    On 04/01/2011 01:06 AM, google01103 wrote:
    >
    > definitely Java


    most java problems can be solved by using YaST/zypper to remove
    OpenJDK (icetea i think) and install the Sun java..

    should log a bug against the OpenJDK, so they can get it working
    smooth, eventually..

    --
    CAVEAT: http://is.gd/bpoMD
    Tried LibreOffice? Do that and help at http://is.gd/dZ9j2W
    [NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

  6. #6
    PeeGee NNTP User

    Default Re: LibreOffice - when opening a document cpu spikes and is unusablefor 8 seconds

    On 01/04/11 08:27, DenverD wrote:
    > On 04/01/2011 01:06 AM, google01103 wrote:
    >>
    >> definitely Java

    >
    > most java problems can be solved by using YaST/zypper to remove OpenJDK
    > (icetea i think) and install the Sun java..
    >
    > should log a bug against the OpenJDK, so they can get it working smooth,
    > eventually..
    >


    Not in this case, I think. The delay happens whether OpenJDK or SUN
    versions are used (and all three cores go above 80%) :-(

    --
    PeeGee

    MSI m/b 870-C45, AMD Athlon II X3 445, 4GB, openSUSE 11.3/11.2 x86_64
    dual boot + XP Home in VBox
    Asus m/b M2NPV-VM, AMD 64X2 3800+, 2GB, openSUSE 11.3 x86_64/XP Home
    dual boot
    Acer Aspire 1350, AMD (M)XP2400+, 768MB, openSUSE 11.4/XP Home dual boot
    Asus eeePC 4G (701), Celeron M353, 2GB, openSUSE 11.3 on SSD

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: LibreOffice - when opening a document cpu spikes and is unusablefor 8 seconds

    On 04/01/2011 10:14 AM, PeeGee wrote:

    > Not in this case, I think. The delay happens whether OpenJDK or SUN
    > versions are used (and all three cores go above 80%) :-(


    i'm sure you are right, but did you uninstall JDK?

    WAIT, i remember now--another post
    <http://forums.opensuse.org/showthread.php?t=456886> yesterday or
    before said it is necessary to (in Writer, for example) go to Tools >
    Options > Java > and

    make sure the "Use Java Runtime environment" box is X'ed

    and when "Sun Microsystems Inc. etc" appears in the "already
    installed" window, left click on the circle to put a black dot in it,
    and click OK, then Ok again and restart Writer...while watch system
    spikes and a stop watch :-)

    no more delay...

    maybe with both JDK and Sun installed, both will be listed there and
    you may choose whichever you want (with the black dot) and still have
    no delay...someone who has both should add that info to the bug, filed
    here: https://bugzilla.novell.com/show_bug.cgi?id=683054

    others should add comments confirming the bug, please..(bugs with a
    single reporter tend to not get the most priority!)

    --
    CAVEAT: http://is.gd/bpoMD
    Tried LibreOffice? Do that and help at http://is.gd/dZ9j2W
    [NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

  8. #8
    PeeGee NNTP User

    Default Re: LibreOffice - when opening a document cpu spikes and is unusablefor 8 seconds

    On 01/04/11 09:56, DenverD wrote:
    > On 04/01/2011 10:14 AM, PeeGee wrote:
    >
    >> Not in this case, I think. The delay happens whether OpenJDK or SUN
    >> versions are used (and all three cores go above 80%) :-(

    >
    > i'm sure you are right, but did you uninstall JDK?


    Yes, did that :-) I usually remove anything I'm not requiring and a
    second JRE falls into that category, for me.

    >
    > WAIT, i remember now--another post
    > <http://forums.opensuse.org/showthread.php?t=456886> yesterday or before
    > said it is necessary to (in Writer, for example) go to Tools > Options >
    > Java > and
    >
    > make sure the "Use Java Runtime environment" box is X'ed
    >
    > and when "Sun Microsystems Inc. etc" appears in the "already installed"
    > window, left click on the circle to put a black dot in it, and click OK,
    > then Ok again and restart Writer...while watch system spikes and a stop
    > watch :-)
    >
    > no more delay...


    Did that as well, no effect on the delay :-(

    I also don't seem to get the thread message that states the delay
    disappears, only that it is necessary to select the environment by
    clicking the circle (as was the case, I think, with OOo 1.x or 2.x) and
    that the "JRE is defective" message disappears.

    >
    > maybe with both JDK and Sun installed, both will be listed there and you
    > may choose whichever you want (with the black dot) and still have no
    > delay...someone who has both should add that info to the bug, filed
    > here: https://bugzilla.novell.com/show_bug.cgi?id=683054
    >
    > others should add comments confirming the bug, please..(bugs with a
    > single reporter tend to not get the most priority!)
    >


    It appears to be JAVA initialisation, as when there is an open LO/OOo
    module, there is no delay when loading another module.

    Perhaps you pre-load the core elements, as was an option in the days of
    StarOffice (which would speed things up considerably - at the expense of
    a slower logon start-up :-) ).

    --
    PeeGee

    MSI m/b 870-C45, AMD Athlon II X3 445, 4GB, openSUSE 11.3/11.2 x86_64
    dual boot + XP Home in VBox
    Asus m/b M2NPV-VM, AMD 64X2 3800+, 2GB, openSUSE 11.3 x86_64/XP Home
    dual boot
    Acer Aspire 1350, AMD (M)XP2400+, 768MB, openSUSE 11.4/XP Home dual boot
    Asus eeePC 4G (701), Celeron M353, 2GB, openSUSE 11.3 on SSD

  9. #9

    Default Re: LibreOffice - when opening a document cpu spikes and is unusablefor 8 seconds

    Googling brought up a thread that says there's an issue with the version of Java being used (11.4 updates contains 1.6.0u24) and that 1.6.0u22 or earlier is the solution User support for LibreOffice (). I tested u23 wich is what ships with 11.4 (non-oss) and that did not fix the spike.

    Sort of makes sense as this is an new issue not apparent when running 11.3

    what say you'all
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  10. #10
    Join Date
    Sep 2009
    Location
    Athens, Greece
    Posts
    70

    Default Απ: Re: LibreOffice - when opening a document cpu spikes and is unusablefor 8 seconds

    I know it's been a month after the first post, but I thought I'd mention that I have exactly the same problem with the startup lag in LibreOffice. The issue is there whether I tick the Sun or the OpenJDK in the Java options. Also, the quickstarter used to generate all sorts of error logs and I disabled it, not that it made any difference. Is there any way to disable the annoying "A JRE must be installed" message in LO? I am using OpenSUSE 11.4 with LibreOffice 3.3.2, BTW.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •