Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: 11.4/Gnome/Intel 945G - new windows open at wrong Maximized size

  1. #1

    Question 11.4/Gnome/Intel 945G - new windows open at wrong Maximized size

    Howdy y'all...

    openSUSE 11.4 / kernel 2.6.37.1-1.2-desktop / Gnome 2.32.1
    video: Intel 945G (on motherboard)
    monitor: Acer AL1716 @ 1024x768
    driver: whatever 11.4 auto-installed for the card

    Having a strange video problem after recently up-ing to 11.4. When new windows open maximized, they are opening at the wrong size (slightly too small) resulting in a distorted view including 'broken' fonts (missing pixels). If I unmaximize the new window, and then re-maximize it, it now maximizes to the correct size and everything is fine.

    Linux video has always 'just works' for me so I don't know where to start on fixing this. Help please. Thanks.

  2. #2

    Default Re: 11.4/Gnome/Intel 945G - new windows open at wrong Maximized size

    I am having exactly the same problem, so similarly, in fact, that I wouldn't even describe it the slightest bit differently. However, I am having this problem with a different Intel graphics chip (also built into the motherboard, exactly like the previous posting). I have the ASRock 775Dual-915GL motherboard, which has the Intel 915GL graphics chip built into it. According to the LSPCI command, my hardware is identified by the operating system as follows:

    00:02.0 VGA compatible controller: Intel Corporation 82915G/GV/910GL Integrated Graphics Controller (rev 0e)

    My problem is exactly the same as the the person who posted before me. Although, I wouldn't describe it at all differently, I would add some additional things that I noticed about the problem on my system:

    1) Clicking just once on the title bar of a newly opened (and improperly maximized) window instantly maximizes it properly. Even after this, newly opened windows still don't maximize fully as they should, even within the same program. For example, if I open Firefox, it will be maximized, but not fully, containing a slight gap on the top and left sides, and if I click on the title bar, that instantly fixes it, but if I choose File -> New Window and open a new window, the new window will still not be maximized properly (unless I click on the title bar). In short, any time a new window is opened in any program, even an already running program, it is always just slightly under-maximized.

    2) I also had artifacts in screens with a lot of text (such as Google News for example) just like the person before me described, but have been installing all of the automatic updates, and one of them recently seems to have fixed the text artifacts, but I installed so may security updates automatically that I do not know which one fixed it. Which ever it was, it did not fix the problem with the windows not maximizing fully, so I think they may possibly be 2 unrelated issues.

    3) I NEVER use KDE; EVER. I'm a GNOME user. But, I decided to open up KDE to see if it would maximize windows correctly, since GNOME wasn't maximizing them correctly, and to my surprise, KDE crashed immediately upon logging in, and I had to use the power button on the case to reboot since the computer was frozen, and then I had to reboot in safe mode in order to enter KDE without crashing the computer, so that I could log out of KDE and log back into GNOME, since by default, the graphics manager automatically logs you back into the desktop environment that you were most recently in instead of giving you a choice, even if it crashed last time you used it and you rarely if ever use it. Considering the other graphical issues I have experienced after the upgrade to opensuse 11.4, I think this issue may likely be related somehow, but can't be certain.

    4) Even in GNOME, stuff as non-graphics-intensive as viewing text-only web pages in Firefox will often cause the screen to freeze about halfway down the page or so as I scroll down the page, and it freezes for about 5 seconds or so, and then resumes scrolling down the page and everything works fine again with no major issues.

    These problems are all problems that were caused by my update from opensuse 11.3 to 11.4. Everything worked flawlessly, and for a very long time, before the update to 11.4. Although KDE is something that I never use, I did check it just to make sure it installed and worked properly after installing 11.3, so I know it worked correctly for a very long time before the update to 11.4. My entire system had absolutely no problems what so ever of any kind with 11.3 before upgrading to 11.4, so it has to have something to do with some kind of bug in 11.4, but I have no idea what or how to fix it. I have installed every automatic update offered to this date, and none of the updates have fixed any of these problems except for the problem of having artifacts in pages with a lot of text.

  3. #3

    Default Re: 11.4/Gnome/Intel 945G - new windows open at wrong Maximized size

    5) I forgot to mention one more symptom I found with the graphics problems. Once I had GNOME Terminal open but minimized to the task bar, and I opened a second GNOME Terminal window and it was invisible. I could tell it did in fact open because the cursor acted really oddly when I moved it over the area where new terminals always show up on the screen, as if the cursor and the invisible GNOME Terminal window were competing for the screen space or something. That only happened once though, and I have not been able to reproduce the problem.

  4. #4
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: 11.4/Gnome/Intel 945G - new windows open at wrong Maximized size

    Forget about your grafics cards, it is unrelated to it. I had for a while
    gnome on the eee pc with exactly the same problems, but since I only had it
    for testing and it annoyed me I switched back to KDE and everything is
    fine.
    The reason I tell you that is not to make you switch to KDE, but just to
    confirm that the problem also exists with nvidia, so it has nothing to do
    with intel graphic cards.

    Sorry that I cannot tell you a solution, using metacity without compiz made
    the problem disappear in my case.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.1 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  5. #5

    Default Re: 11.4/Gnome/Intel 945G - new windows open at wrong Maximized size

    Martin,

    Thank you very much for your suggestions and information. Your information about Compiz being part of the problem allowed me to solve the problem on my system. It appears to be a problem with the desktop effects feature. After reading what you posted, I went to the Control Center in GNOME to see if I could get to a screen that would allow me to change the graphics settings, and in the Control Center, I found a button titled "Desktop Effects" under the "Look and Feel" heading. When I clicked on that, it brought up a small window with a check box at the top left, allowing me to unclick the "Enable desktop effects" feature. I unclicked it, and instantly everything started working correctly. The windows now automatically maximize to the correct size, and the freezing scrolling seems to have gone away, too. Interestingly, the window allowing me to uncheck the desktop effects said "Simple CompizConfig Settings Manager" in the title bar, so this must be a bug with Compiz. I haven't tried KDE yet, so I don't know if it fixed the KDE problem or not quite yet, but I will check later on and let the forum know. For now, this seems to have fixed all of the other problems, though. I think you are right that it cannot be a graphics card or driver issue; it has to be something with Compiz. Thanks very much for your help and suggestions! Everything is working much more nicely now.

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: 11.4/Gnome/Intel 945G - new windows open at wrong Maximized size

    Glad you solved it.
    Just to comment on something I wrote and which can be misinterpreted. I
    wrote "it" annoyed me, with this "it" I meant compiz not gnome itself, since
    I think gnome is a really good desktop environment.
    The reason I switched at the end back to KDE is simply I am more a KDE
    person :-)

    I do not know if this gives you a visible improvement:
    There is a setting in gnome which enables compositing in metacity itself (it
    looks a bit better) you may want to try it (has nothing to do with desktop
    effects it just makes the appearance of rounded borders for example better).

    Press ALT-F2 and type gconf-editor. Navigate to apps -> metacity -> general
    At the right side there is a checkbox "compositing_manager", just tick it
    and see if it is an improvement. If not just disable it again.

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.1 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  7. #7

    Default Re: 11.4/Gnome/Intel 945G - new windows open at wrong Maximized size

    I tried the "compositing_manager" option that you mentioned, and it works very nicely. Thanks for letting me know about it!

    I have now had the chance to try out KDE since disabling Compiz, to see if the KDE bug is the same bug or something completely different. It turned out that having Compiz disabled did not solve the KDE problem. It was still exactly as before, with the screen freezing up and turning black and saying "Message from syslogd@linux" over and over and over again in white lettering, and the "Caps" and "Scroll" lights started flashing on the keyboard. It was impossible for me to copy and save the text that it showed on the black screen since the screen was frozen, but I did see something that said "Preempt SMP" after one of the "Message from syslogd@linux" lines. As before, I had to reboot in safe mode to enter KDE without crashing so that I could log out of it and log back into GNOME. For whatever reason, KDE works perfectly fine if I boot up in safe mode. So, since disabling Compiz didn't fix the KDE problem, it is probably safe to assume that it is a separate, unrelated issue.

    Now that we have identified the source of the window maximizing problem, though, I think that solves the topic of this particular forum thread. To summarize what we have figured out in case anyone with a similar problem comes across this later:

    1) Windows not maximizing correctly is caused by Compiz. Disabling Compiz by unclicking "Enable desktop effects" solves the problem temporarily until the bug in Compiz gets fixed. If you do that, enabling "compositing_manager" causes your system to still have a very nice appearance in the meantime until there is a fix for Compiz.

    2) The text artifacts are an unrelated issue, already solved by downloading and installing all of the available automatic updates (not sure which one specifically solved it though).

    3) The KDE problem is an unrelated issue.

    4) The screen freezing while scrolling is caused by the same Compiz bug as the window maximizing problem, and can be temporarily resolved in the same way, by disabling the "Enable desktop effects" feature until a more permanent Compiz fix becomes available.

    5) The invisible window problem only happened once on my system, and I have not been able to reproduce the problem, so I assume it was likely fixed by an automatic update, but cannot be certain.

    Thanks very much for your help, Martin. Figuring these things out has at least gotten GNOME working very nicely on my system, and I'm sure these tips we have figured out will probably help other people, too, until the problem in Compiz is discovered and fixed. Although, I don't personally use KDE, it would be nice to find a fix for that problem, since I'm sure there are a lot of people who do prefer to use KDE. I actually really like KDE, but I just seem to like GNOME better, so I always use GNOME. Although I'm a GNOME user, there are some KDE programs that I use in GNOME that I really like a lot, such as K3B for example. Luckily, those programs do not seem to be affected by the KDE bug. KDE programs seem to work just fine for me in GNOME. It is just KDE itself that doesn't work on my system. I think to get into that should be a different thread though, because we should probably keep things organized, and we now know that to be separate, unrelated bug. Thanks again for your help, Martin!

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,654

    Default Re: 11.4/Gnome/Intel 945G - new windows open at wrong Maximized size

    lub997 wrote:

    >
    > I tried the "compositing_manager" option that you mentioned, and it
    > works very nicely. Thanks for letting me know about it!
    >
    > I have now had the chance to try out KDE since disabling Compiz, to see
    > if the KDE bug is the same bug or something completely different. It
    > turned out that having Compiz disabled did not solve the KDE problem. It
    > was still exactly as before, with the screen freezing up and turning
    > black and saying "Message from syslogd@linux" over and over and over
    > again in white lettering, and the "Caps" and "Scroll" lights started
    > flashing on the keyboard. It was impossible for me to copy and save the
    > text that it showed on the black screen since the screen was frozen, but
    > I did see something that said "Preempt SMP" after one of the "Message
    > from syslogd@linux" lines. As before, I had to reboot in safe mode to
    > enter KDE without crashing so that I could log out of it and log back
    > into GNOME. For whatever reason, KDE works perfectly fine if I boot up
    > in safe mode. So, since disabling Compiz didn't fix the KDE problem, it
    > is probably safe to assume that it is a separate, unrelated issue.
    >
    > Now that we have identified the source of the window maximizing
    > problem, though, I think that solves the topic of this particular forum
    > thread. To summarize what we have figured out in case anyone with a
    > similar problem comes across this later:
    >
    > 1) Windows not maximizing correctly is caused by Compiz. Disabling
    > Compiz by unclicking "Enable desktop effects" solves the problem
    > temporarily until the bug in Compiz gets fixed. If you do that, enabling
    > "compositing_manager" causes your system to still have a very nice
    > appearance in the meantime until there is a fix for Compiz.
    >
    > 2) The text artifacts are an unrelated issue, already solved by
    > downloading and installing all of the available automatic updates (not
    > sure which one specifically solved it though).
    >
    > 3) The KDE problem is an unrelated issue.
    >
    > 4) The screen freezing while scrolling is caused by the same Compiz bug
    > as the window maximizing problem, and can be temporarily resolved in the
    > same way, by disabling the "Enable desktop effects" feature until a more
    > permanent Compiz fix becomes available.
    >
    > 5) The invisible window problem only happened once on my system, and I
    > have not been able to reproduce the problem, so I assume it was likely
    > fixed by an automatic update, but cannot be certain.
    >
    > Thanks very much for your help, Martin. Figuring these things out has
    > at least gotten GNOME working very nicely on my system, and I'm sure
    > these tips we have figured out will probably help other people, too,
    > until the problem in Compiz is discovered and fixed. Although, I don't
    > personally use KDE, it would be nice to find a fix for that problem,
    > since I'm sure there are a lot of people who do prefer to use KDE. I
    > actually really like KDE, but I just seem to like GNOME better, so I
    > always use GNOME. Although I'm a GNOME user, there are some KDE programs
    > that I use in GNOME that I really like a lot, such as K3B for example.
    > Luckily, those programs do not seem to be affected by the KDE bug. KDE
    > programs seem to work just fine for me in GNOME. It is just KDE itself
    > that doesn't work on my system. I think to get into that should be a
    > different thread though, because we should probably keep things
    > organized, and we now know that to be separate, unrelated bug. Thanks
    > again for your help, Martin!
    >

    Pleasse note that KDE does not use compiz, KDE has all desktop effects built
    into its own window manager kwin.
    You can disable the KDE desktop effects in system settings (hope it is
    called so in an english system, I see it in german).

    --
    PC: oS 11.3 64 bit | Intel Core2 Quad Q8300@2.50GHz | KDE 4.6.1 | GeForce
    9600 GT | 4GB Ram
    Eee PC 1201n: oS 11.4 64 bit | Intel Atom 330@1.60GHz | KDE 4.6.0 | nVidia
    ION | 3GB Ram

  9. #9

    Default Re: 11.4/Gnome/Intel 945G - new windows open at wrong Maximized size

    I went ahead and officially reported both bugs at bugzilla.novell.com so that hopefully they can be permanently fixed at some point. I reported the Compiz bug and the KDE bug separately, since we determined that they are completely unrelated and KDE uses kwin instead.

    It looks as though the Compiz bug had already been reported on March 15, so I simply added what we figured out here to the bug report that already existed.

    https://bugzilla.novell.com/show_bug.cgi?id=679900

    I did not find an existing bug report for the KDE bug, so I went ahead and created a new report for it.

    https://bugzilla.novell.com/show_bug.cgi?id=687996

    I am glad to see that they have such a nice system set up for reporting bugs. Hopefully reporting the bugs will help them get noticed and fixed in the future. Despite these bugs, I am still very happy with openSUSE. I switched from Windows to Linux way back when Red Hat 7.1 was still new, and continued to use Red Hat until 7.3, and then I decided to try SUSE around the time of SUSE 8.1 to try out the reiserfs support, and I was so happy with SUSE that it has always been my favorite operating system ever since. I still like to use reiserfs today because I love its fast performance and ease of use, but one of the other things I also ended up liking a lot about SUSE is how it has so much different optional software included. It seems to have a program for just about every task, and even if it doesn't, One-Click and zypper have made it so easy and convenient to install other software. They have made Linux easy to use, but not sacrificed any of its amazing power; that's really a neat accomplishment. In all the time I have used SUSE, this is the only time I've ever come across any bug that was even troublesome enough to be worth mentioning, so I think that is really impressive. It is usually so stable that I have actually run my desktop computer for close to a year without rebooting before, and even then, it was a power outage, not a software issue. Everyone I have showed opensuse to have always ended up really enjoying it, too.

  10. #10

    Default Re: 11.4/Gnome/Intel 945G - new windows open at wrong Maximized size

    Hey there. Remember i told you about corrupted text in window boxes? That's exactly the same prob i got, i just forgot to tell you (cause i didn't notice myself at first) that window doesn't get maximized completely until i click on it. Oh well, it's all fine, but the problem still hasn't been fixed. That, and a couple of more issues stops me from using openSUSE, unfortunatelly. I need compiz for some things, not much for eyecandy though.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •