Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: openSUSE_11.4_(i586) GoogleEarth install failures

  1. #1
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,490

    Default openSUSE_11.4_(i586) GoogleEarth install failures

    Hi,

    I'm running openSUSE 11.4 (i586) and have problems installing GoogleEarth

    Any help / advice appreciated.

    1. Version 5.2 will not install, output as follows
    Code:
    jens@linux-m6e5:~/Updates/googleearth> sh GoogleEarthLinux-5.2.bin 
    Verifying archive integrity... All good.
    Uncompressing Google Earth for GNU/Linux 5.2.1.1588..........................
    I/O error : No such file or directory
    setup.data/setup.xml:1: parser error : Document is empty
    
    ^
    setup.data/setup.xml:1: parser error : Start tag expected, '<' not found
    
    ^
    ./setup.sh: line 158:  2540 Segmentation fault      "$setup" "$@"
    jens@linux-m6e5:~/Updates/googleearth>
    2. Version 6 installs ok but will not run, the 'Googleearth' and 'startup tip' windows open
    but then nothing else happens until program is terminated

    output from cmd ldd shows

    Code:
    jens@linux-m6e5:/opt/google/earth/free> ldd googleearth-bin 
    .
    .
    .
    libgoogleearth_free.so => not found
    .
    .
    .
    Note:
    lsb version 4.0-12.1 is installed
    Mesa version 7.10-3.3 is installed

    Regards
    Michael

  2. #2
    Join Date
    Nov 2010
    Location
    Ελλάδα(Αθήνα)-Россия (г. Красноярск)
    Posts
    2,919

    Default Απ: openSUSE_11.4_(i586) GoogleEarth install failures

    you must install this library libgoogleearth_free.so
    You have missed it.

    Code:
    jens@linux-m6e5:/opt/google/earth/free> ldd googleearth-bin 
    .
    .
    .
    libgoogleearth_free.so => not found
    .
    .



    Open your terminal
    Code:
    su
    Code:
    # zypper install libgoogleearth_free.so
    Πάντα Φιλικά, Στάμος.
    Desktop: openSUSE Leap 15||x86_64||Gnome 3.14 & KDE 5||AMD Ryzen 7 8 core||Nvidia GTX 1070 Ti Gaming Edition
    Γλώσσες Προγραμματισμού: C++, Qt developing.
    http://bit.ly/fT8Hfi

  3. #3

    Default Re: openSUSE_11.4_(i586) GoogleEarth install failures

    if you go to the directory where googleearth is installed is libgoogleearth_free.so there?

    are you starting it with googleearth-bin or with googleearth ?
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  4. #4
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,490

    Default Re: openSUSE_11.4_(i586) GoogleEarth install failures

    Quote Originally Posted by google01103 View Post
    if you go to the directory where googleearth is installed is libgoogleearth_free.so there?

    are you starting it with googleearth-bin or with googleearth ?
    yes the file is in /opt/google/earth/free/

    I normally start googleearth from the icon which uses the cmd, /opt/google/earth/free/google-earth %f
    but the result is the same if it is started with sh /opt/google/earth/free/googleearth
    or sh /opt/google/earth/free/google-earth

    Thanks for responding

    Michael

  5. #5

    Default Re: openSUSE_11.4_(i586) GoogleEarth install failures

    this thread might help googleearth-bin not found error - Google Earth Help

    one of the suggestions is to install lsb:
    Code:
     zypper install lsb
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  6. #6
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,490

    Default Re: openSUSE_11.4_(i586) GoogleEarth install failures

    Hi,

    thanks stamostolias and google01103 for your suggestions but I'm still stuck,
    after trying everything

    the only other anomally I've noticed on this machine is with glxgears,
    the response is a black screen in the terminal window
    Code:
    jens@linux-m6e5:/lib> glxgears
    
    *** NOTE: Don't use glxgears as a benchmark.
        OpenGL implementations are not optimized for frame rates >> 60fps,
        thus these numbers are meaningless when compared between vendors.
    
    XIO:  fatal IO error 11 (Resource temporarily unavailable) on X server ":0"
          after 34 requests (34 known processed) with 0 events remaining.
    jens@linux-m6e5:/lib>
    this I've seen on many distributions and sooner or later its resolve by an update

    regrds
    michael

  7. #7

    Default Re: openSUSE_11.4_(i586) GoogleEarth install failures

    if glxgears doesn't work maybe that's why googleearth doesn't, what's your graphics card and which drivers?
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  8. #8
    Join Date
    Jun 2009
    Location
    Mangfall, Germany
    Posts
    1,490

    Default Re: openSUSE_11.4_(i586) GoogleEarth install failures

    Hi google01103,

    to the best of my knowledge the PC setup is as follows

    I suspect 'Size & Orientation-System Settings' info is kept elsewhere, as the
    Primary output is set to DVI-0, but is not visible below.

    set-up details,
    Code:
    OS Information
    OS:  Linux 2.6.38-18-desktop i686
      Current user:  jens@linux-m6e5
      System:  openSUSE 11.4 (i586)
      KDE:  4.6.1 (4.6.1) "release 390"
      Display Info
    Vendor:  ATI Technologies Inc
      Model:  Radeon X1650
      2D driver:  radeon
      3D driver:  R300 Gallium (7.10)
    NO_KMS_IN_INITRD=default (have had it set 'yes' but makes no difference)

    No 'nomodeset' in boot cmd line (if introduced, can only boot terminal mode)

    /etc/X11/xorg.conf.d/50-device.conf
    Code:
    Section "ServerLayout"
    	Identifier     "aticonfig Layout"
    	Screen      0  "aticonfig-Screen[1]-0" 0 0
    EndSection
    Section "Device"    Identifier  "aticonfig-Device[1]-0"
    	Driver      "radeon"
    	Option	    "Monitor-VGA-0" "VGA-0"
    	Option	    "Monitor-DVI-0" "DVI-0"
    # lspci: 02:00.0 VGA compatible controller: ATI Technologies Inc RV530LE [Radeon X1600/X1650 PRO]
    #        02:00.1 Display controller: ATI Technologies Inc RV530LE [Radeon X1650 PRO] (Secondary)
    	BusID       "PCI:2:0:0"
    EndSection
    /etc/X11/xorg.conf.d/50-monitor.conf
    Code:
    Section "Monitor"
    # xrandr -q:        VGA-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 338mm x 270mm
    	Identifier  "VGA-0"
    	Option	    "VendorName" "ATI Open source Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    	Option	    "PreferredMode" "1280x1024"
    	Option	    "TargetRefresh" "60"
    	Option	    "Position" "0 0"
    	Option	    "Rotate" "normal"
    	Option	    "Disable" "false"
    EndSection
    Section "Monitor"
    # xrandr -q:        DVI-0 connected 1280x1024+1280+0 (normal left inverted right x axis y axis) 338mm x 270mm
    	Identifier  "DVI-0"
    	Option	    "VendorName" "ATI Open Source Driver"
    	Option	    "ModelName" "Generic Autodetecting Monitor"
    	Option	    "DPMS" "true"
    	Option	    "PreferredMode" "1280x1024"
    	Option	    "TargetRefresh" "60"
    	Option	    "Position" "1280 0"
    	Option	    "Rotate" "normal"
    	Option	    "Disable" "false"
    EndSection
    /etc/X11/xorg.conf.d/50-screen.conf
    Code:
    Section "Screen"
    # xrandr -q: Screen 0: minimum 320 x 200, current 2560 x 1024, maximum 3840 x 1920
    	Identifier "aticonfig-Screen[1]-0"
    	Device     "aticonfig-Device[1]-0"
    	DefaultDepth     24
    	SubSection "Display"
    		Viewport   0 0
    		Virtual   2560 1024
    		Depth     24
    	EndSubSection
    EndSection
    regards
    michael

  9. #9

    Default Re: openSUSE_11.4_(i586) GoogleEarth install failures

    I'm pretty clueless, thought maybe your graphics were borked

    2 thing to try:
    - are you running compiz or kwin for desktop effects? try disabling
    - create and login as a new user, does the problem still exist?

    final question when you upgraded to 11.4 (assuming you upgraded) did you also upgrade you graphics driver?
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

  10. #10

    Default Re: openSUSE_11.4_(i586) GoogleEarth install failures

    thinking that maybe you have a graphics problem and not a googleearth problem, if that's the case you'd be better off starting a new graphics titled thread

    if you upgraded to 11.4 did you also upgrade your graphics driver? do effects work in either compiz or kwin?

    if you dl ksudoku can you play the 3d version called "Roxdoku 9"?
    openSUSE Leap 42.1 x64, Plasma 5 & KDE 4.14.x, pretty current proprietary Nvidia drivers (self-compiled)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •