Page 1 of 6 123 ... LastLast
Results 1 to 10 of 52

Thread: В сотый раз ati radeon и openSUSE 11.4

  1. #1
    Join Date
    Mar 2011
    Location
    Балаково
    Posts
    137

    Default В сотый раз ati radeon и openSUSE 11.4

    Нужен драйвер на карточку radeon9600 series. Драйвер "radeonhd" как я понял только для карт hd-серии, а на оф сайте предлагают только catalyst 9.3 с которым у меня следующая проблема:
    Code:
    hasculdr@linux-nw0a:~/Downloads> bash /home/hasculdr/Downloads/ati-driver-installer-9-3-x86.x86_64.run
    Created directory fglrx-install.sxFk5l
    Verifying archive integrity... All good.
    Uncompressing ATI Proprietary Linux Driver-8.593......................................................................
    ==================================================
     ATI Technologies Linux Driver Installer/Packager 
    ==================================================
    which: no XFree86 in (/home/hasculdr/bin:/usr/local/bin:/usr/bin:/bin:/usr/bin/X11:/usr/X11R6/bin:/usr/games:/usr/lib/jvm/jre/bin)
    
    Error: ./default_policy.sh does not support version
    default:v2:i686:lib::none:2.6.37.1-1.2-default; make sure that the version is being
    correctly set by --iscurrentdistro
    
    Removing temporary directory: fglrx-install.sxFk5l
    hasculdr@linux-nw0a:~/Downloads>
    Читал, что теперь не будет дров для старых карт, работающих с openSUSE 11.2+, но вот сегодня наткнулся на информацию что старые дрова можно поставить на пропатченное ядро (увы вовремя не сохранил статью, снова найти не могу) или пропатчив сами дрова. Подскажите пожалуйста, что мне сейчас нужно попробовать? Только подробнее, т.к. "Начинающий пользователь" для меня очень лестный комплимент.

  2. #2

    Default Re: В сотый раз ati radeon и openSUSE 11.4

    Сразу после установки 11.4 тоже столкнулся с проблемой отсутствия драйверов. Поставил из репозитория Index of /mirror/ati/openSUSE_11.4, судя по информации должен поддерживать и 9600
    Code:
    Сведения — пакет fglrx_xpic_SUSE114:
    
    Репозиторий: @System
    Имя: fglrx_xpic_SUSE114
    Версия: 8.821-1
    Архитектура: i586
    Производитель: 
    Установлен: Да
    Состояние: актуален
    Размер после установки: 91,8 MiB
    Сводка: X Window display driver for the ATI graphics accelerators
    Описание: 
    Display driver files for the ATI RADEON (9500 and later), MOBILITY RADEON (M10 and later), RADEON XPRESS IGP and FireGL (Z1 and later) series of graphics accelerators.  This package provides 2D display drivers, precompiled kernel modules, kernel module build environment, control panel source coude and hardware accelerated OpenGL.
    Вчера на сайте АМД выложили драйвер версии 11.3, сейчас качаю, а там посмотрим как будет работать

  3. #3
    Join Date
    Mar 2011
    Location
    Балаково
    Posts
    137

    Default Re: В сотый раз ati radeon и openSUSE 11.4

    Вот откуда я узнал о том, что они прекратили поддержку своих старых карточек, еще там написано что бесполезно ставить старые дрова на 11,2+, т.к. в них Xorg 7.4 (не знаю что это такое), с которым старые карточки не работают.

  4. #4
    Join Date
    Mar 2011
    Location
    Балаково
    Posts
    137

    Default Re: В сотый раз ati radeon и openSUSE 11.4

    Поставил этот драйвер, но каталист запустить не могу: пишет "инициализация не удалась, возможно графический драйвер ати не установлен или функционирует неправильно. Настройте его с помощью утиллиты aticonfig". Пишу в консоли aticonfig --install, отвечает "No supported adapters detected". Что дальше пробовать?

  5. #5

    Default Re: В сотый раз ati radeon и openSUSE 11.4

    Quote Originally Posted by Hasculdr View Post
    Поставил этот драйвер, но каталист запустить не могу: пишет "инициализация не удалась, возможно графический драйвер ати не установлен или функционирует неправильно. Настройте его с помощью утиллиты aticonfig". Пишу в консоли aticonfig --install, отвечает "No supported adapters detected". Что дальше пробовать?
    Драйвер radeon,проприетарный не поддерживает вашу карту,о чем и написал.

  6. #6
    Join Date
    Mar 2011
    Location
    Балаково
    Posts
    137

    Default Re: В сотый раз ati radeon и openSUSE 11.4

    Quote Originally Posted by ayakunin View Post
    Драйвер radeon,проприетарный не поддерживает вашу карту,о чем и написал.
    Непонятно - в описании сказано
    Display driver files for the ATI RADEON (9500 and later)

  7. #7

    Default Re: В сотый раз ati radeon и openSUSE 11.4

    Quote Originally Posted by Hasculdr View Post
    Непонятно - в описании сказано
    Используйте radeon,проприетарный поддерживает карты начиная с HD 2000.

    ЗЫ Поддержка openSUSE 11.4 заявлена только в драйвере 11.3.

  8. #8
    Join Date
    Mar 2011
    Location
    Балаково
    Posts
    137

    Default Re: В сотый раз ati radeon и openSUSE 11.4

    Но у меня же 9600 Series, куда мне проприетарный?(

  9. #9
    Join Date
    Mar 2011
    Location
    Балаково
    Posts
    137

    Default Re: В сотый раз ati radeon и openSUSE 11.4

    Хочу установить XFree86, может тогда дело продвинется. Мне нужно узнать версию своей GNU C библиотеки. Подскажите как это сделать.

  10. #10

    Default Re: В сотый раз ati radeon и openSUSE 11.4

    Quote Originally Posted by Hasculdr View Post
    Но у меня же 9600 Series, куда мне проприетарный?(

    Я вам и советовал использовать свободный,т.е. radeon,который свободный и входит уже в xorg.

Page 1 of 6 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •