Page 1 of 8 123 ... LastLast
Results 1 to 10 of 78

Thread: openSUSE 11.4, KMix too few channels (probably due to PulseAudio)

  1. #1

    Default openSUSE 11.4, KMix too few channels (probably due to PulseAudio)

    Hi,

    today I installed openSUSE 11.4 (32bit) on my machine. So far, nice work. But I have some problems with KMix. When I open it, there are is only one Playback and one Capture device.
    When I open "alsamixer" and click F5 to show all bars, it shows only two: "Master" and "Capture".

    But I need something more. Something like the Microphone boost. Without it, trying to use the microphone is useless.. :/

    Any ideas how I can activate it?


    My sound chip:
    24: PCI 07.0: 0403 Audio device
    [Created at pci.318]
    Unique ID: M71A.14Q3JWBTiv4
    SysFS ID: /devices/pci0000:00/0000:00:07.0
    SysFS BusID: 0000:00:07.0
    Hardware Class: sound
    Model: "nVidia MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio"
    Vendor: pci 0x10de "nVidia Corporation"
    Device: pci 0x0774 "MCP72XE/MCP72P/MCP78U/MCP78S High Definition Audio"
    SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
    SubDevice: pci 0x8346
    Revision: 0xa1
    Driver: "HDA Intel"
    Driver Modules: "snd_hda_intel"
    Memory Range: 0xf7e78000-0xf7e7bfff (rw,non-prefetchable)
    IRQ: 21 (8166 events)
    Module Alias: "pci:v000010DEd00000774sv00001043sd00008346bc04sc03i00"
    Driver Info #0:
    Driver Status: snd_hda_intel is active
    Driver Activation Cmd: "modprobe snd_hda_intel"
    Config Status: cfg=yes, avail=yes, need=no, active=unknown

  2. #2
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: openSUSE 11.4, KMix too few channels (probably due to PulseAudio)

    Did you try a recording with the single capture channel (master volume/level) at max level in KMix? What application are you using to make the recording? When you activate it, you should get an application (volume) channel appear on KMix's Capture Streams tab where you can adjust the level.

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: openSUSE 11.4, KMix too few channels (probably due to PulseAudio)

    On 03/29/2011 10:06 PM, Ctwx wrote:
    >
    > Any ideas how I can activate it?
    >


    -close running copies of KMix
    -left click on the KMix icon
    -left click on the button "Mixer"
    -mine has a menu: File, Settings, Help
    -click Settings then click Configure Channels..
    -available channels on the left, visible channels on the right
    --move those on the left which you want to see, to the right
    --move those you don't want to see to the left
    -click ok

    other settings are available via Settings > Configure KMix

    --
    CAVEAT: http://is.gd/bpoMD
    Tried LibreOffice? Do that and help at http://is.gd/dZ9j2W
    [NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

  4. #4

    Default Re: openSUSE 11.4, KMix too few channels (probably due to PulseAudio)

    I am trying to use Mumble. (Installing Mumble - Mumble)
    When Mumble is open, I have an extra channel in KMix's Playback tab, but not in Capture ->

    Uploaded with ImageShack.us

  5. #5

    Default Re: openSUSE 11.4, KMix too few channels (probably due to PulseAudio)

    Quote Originally Posted by DenverD View Post
    On 03/29/2011 10:06 PM, Ctwx wrote:
    >
    > Any ideas how I can activate it?
    >


    -close running copies of KMix
    -left click on the KMix icon
    -left click on the button "Mixer"
    -mine has a menu: File, Settings, Help
    -click Settings then click Configure Channels..
    -available channels on the left, visible channels on the right
    --move those on the left which you want to see, to the right
    --move those you don't want to see to the left
    -click ok

    other settings are available via Settings > Configure KMix
    There are none except for the "Internal Audio Analog Stereo".

    Uploaded with ImageShack.us

    In Settings -> Configure KMix I can't do anything that has to do with the channels. :/

  6. #6
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: openSUSE 11.4, KMix too few channels (probably due to PulseAudio)

    On 03/30/2011 09:36 AM, Ctwx wrote:
    > In Settings -> Configure KMix I can't do anything that has to do with
    > the channels. :/


    then i'm pretty sure you have found a bug, please begin here:
    http://en.opensuse.org/Submitting_Bug_Reports

    after the report please return here and put the bug report number/URL
    here so others that google into your thread can find the bug and add
    their info to it (bugs on only ONE system don't get looked at as
    quickly as a bug on 1000 computers!)

    --
    CAVEAT: http://is.gd/bpoMD
    Tried LibreOffice? Do that and help at http://is.gd/dZ9j2W
    [NNTP via openSUSE 11.3 + KDE4.5.5 + Thunderbird3.1.8]

  7. #7
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: openSUSE 11.4, KMix too few channels (probably due to PulseAudio)

    Quote Originally Posted by Ctwx View Post
    There are none except for the "Internal Audio Analog Stereo".

    In Settings -> Configure KMix I can't do anything that has to do with the channels. :/
    There are comments elsewhere on the forum about the initially empty Configure KMix panels so that appears to be normal, as it is on mine. Although I noticed for example, an entry appears in the right hand panel when an application's capture channel appears on the Capture Streams (eg using Audacity). BTW that Capture Stream channel's level for Audacity is at 50% on slider initially. I was able to increase it to get a good recorded volume level with my notebooks built-in mic, whereas on 11.3 I used Mic Boost.

    However I can't recommend Audacity for recording, as it doesn't yet have native support for PulseAudio. It relies on the alsa plug-in for P/A, and I read that it isn't very reliable according to Audacity. I eventually get latency problems and error messages. At least it proves the connectivity with P/A and recording level. Before testing I checked my mic using this at the command line (normal user):
    Code:
    arecord -d 10 myrecording.wav
    For 10 seconds recording to wav file with any chosen name.

    It seems that Mumble is not packaged by openSUSE and not in the standard repos or packman. I guess you sourced it from an OBS user's home repo, so that makes it difficult to get support for it. I am not familiar with it. Does it have native support for PulseAudio?

  8. #8
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: openSUSE 11.4, KMix too few channels (probably due to PulseAudio)

    BTW, you can install the package "pavucontrol". It appears (to me at least) to offer similar features to KMix and Phonon (KMix>Settings>Audio Setup). There are slight differences when it comes to reporting status of streams.

  9. #9
    Join Date
    Mar 2010
    Location
    Europe
    Posts
    657

    Default Re: openSUSE 11.4, KMix too few channels (probably due to PulseAudio)

    If you can live without it, you could aslo disable Pulse Audio.

  10. #10
    Join Date
    Jun 2008
    Location
    UK
    Posts
    5,500

    Default Re: openSUSE 11.4, KMix too few channels (probably due to PulseAudio)

    Quote Originally Posted by Lord_Emsworth View Post
    If you can live without it, you could aslo disable Pulse Audio.
    That is an option, but it's one that stifles progress in terms of learning and contributing to further resolution of problems.

Page 1 of 8 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •