Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 11.4 zypper cannot resolve repositores

  1. #1

    Default 11.4 zypper cannot resolve repositores

    I installed 11.4 from a verified and checked CD. Had and worked through the DSL and ipv6 problems discussed elsewhere in this forum. So browsers now work on the internet, but neither zypper nor yast will resolve the 11.4 repositories, so no refresh, no updates. Browsers bring up the repositories fine, so I can download and install an rpm that way, but it's not a life. Haven't been able to find this issue elsewhere, asis usually the case.

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: 11.4 zypper cannot resolve repositores

    Can you open up a terminal session and run the following command:

    Code:
    zypper repos
    Copy and paste the result of this terminal command into a forum message here wrapped in the code tags # while in the advanced forum message editor. The results could be helpful in determining what is going on.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jul 2009
    Location
    Montreal, Québec
    Posts
    833

    Default Re : Re: 11.4 zypper cannot resolve repositores

    Hi,

    And with IPV6 disabled, does it work ?

  4. #4

    Default Re: Re : Re: 11.4 zypper cannot resolve repositores

    With ipv6 disbled, the browsers work. Zypper and Yast do not resolve repositories ever. Zypper lr lists them, zypper ref looks for them and can't find them. Yast2 lists them exactly as specified in the list of 11.4 repos but can't reach them for refresh. Firefox accepts and finds the URLs as specified.

  5. #5

    Default Re: 11.4 zypper cannot resolve repositores

    zypper lr produces
    # | Alias | Name | Enabled | Refresh
    --+----------------------+----------------------------+---------+--------
    1 | openSUSE-11.4-11.4-0 | openSUSE-11.4-11.4-0 | Yes | No
    2 | repo-debug | openSUSE-11.4-Debug | Yes | Yes
    3 | repo-debug-update | openSUSE-11.4-Update-Debug | Yes | Yes
    4 | repo-non-oss | openSUSE-11.4-Non-Oss | Yes | Yes
    5 | repo-oss | openSUSE-11.4-Oss | Yes | Yes
    6 | repo-source | openSUSE-11.4-Source | Yes | Yes
    7 | repo-update | openSUSE-11.4-Update | Yes | Yes

    zypper ref tells me it can't resolve them. The URLs listed via Yast are correct, but not refreshable 9or resolvable.

  6. #6
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: 11.4 zypper cannot resolve repositores

    Here are the items I see that are different in my setup:

    Code:
    # | Alias                | Name                       | Enabled | Refresh
    --+----------------------+----------------------------+---------+--------
    1 | openSUSE-11.4-11.4-0 | openSUSE-11.4-11.4-0       | Yes     | No
    2 | repo-debug           | openSUSE-11.4-Debug        | No      | Yes
    3 | repo-debug-update    | openSUSE-11.4-Update-Debug | No      | Yes
    4 | repo-non-oss         | openSUSE-11.4-Non-Oss      | Yes     | Yes
    5 | repo-oss             | openSUSE-11.4-Oss          | Yes     | Yes
    6 | repo-source          | openSUSE-11.4-Source       | No      | Yes
    7 | repo-update          | openSUSE-11.4-Update       | Yes     | Yes
    Three of the default repos are not enabled on mine, but they are enable on yours. That is all I could see different and I have added in the Packman repository. When you post such information, switch to the advanced message editor. Select all of the text you posted and then press the code tag button #. This prevents the information from being formatted.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: 11.4 zypper cannot resolve repositores

    On 2011-03-29 00:06, raykings wrote:
    >
    > I installed 11.4 from a verified and checked CD. Had and worked through
    > the DSL and ipv6 problems discussed elsewhere in this forum. So
    > browsers now work on the internet, but neither zypper nor yast will
    > resolve the 11.4 repositories, so no refresh, no updates. Browsers
    > bring up the repositories fine, so I can download and install an rpm
    > that way, but it's not a life. Haven't been able to find this issue
    > elsewhere, asis usually the case.


    proxy, corporate or university network? YaST has to be told about that.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  8. #8

    Default Re: 11.4 zypper cannot resolve repositores

    Just a plain straightforward home system. The question is really "in what sense do zypper and yast access a URL differently from the way my browser does?"

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,857
    Blog Entries
    20

    Default Re: 11.4 zypper cannot resolve repositores

    Quote Originally Posted by raykings View Post
    zypper lr produces
    # | Alias | Name | Enabled | Refresh
    --+----------------------+----------------------------+---------+--------
    1 | openSUSE-11.4-11.4-0 | openSUSE-11.4-11.4-0 | No | No
    2 | repo-debug | openSUSE-11.4-Debug | No | No
    3 | repo-debug-update | openSUSE-11.4-Update-Debug | No | No
    4 | repo-non-oss | openSUSE-11.4-Non-Oss | Yes | Yes
    5 | repo-oss | openSUSE-11.4-Oss | Yes | Yes
    6 | repo-source | openSUSE-11.4-Source | Yes | Yes
    7 | repo-update | openSUSE-11.4-Update | Yes | Yes

    zypper ref tells me it can't resolve them. The URLs listed via Yast are correct, but not refreshable 9or resolvable.
    Change as above
    try again
    Tumbleweed_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    1,970

    Default Re: 11.4 zypper cannot resolve repositores

    Could You install wireshark and give us a trace of packets while issuing the zypper ref command ?

    Best regards,
    Greg
    Best regards,
    Greg

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •