Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: 11-4/64 has to be started with "nomodesetx11"

  1. #1
    Join Date
    Dec 2010
    Location
    UAE
    Posts
    25

    Default 11-4/64 has to be started with "nomodesetx11"

    Have worked on this for some time now. I cannot start my SuSE 11-4/64 without using "nomodesetx11" in boot.
    Apparently something is missing in my setup.
    Have a ATI Radeon card on a HP Pavillion dv6 laptop. 11-3/64 was working . . .
    Have tried to un- and re-install SuSe provided AMD-driver and also tried the driver downloaded from ATI (for 11-3).
    Nothing seems to work.
    Any suggestions?

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: 11-4/64 has to be started with "nomodesetx11"

    Have worked on this for some time now. I cannot start my SuSE 11-4/64 without using "nomodesetx11" in boot.
    Apparently something is missing in my setup.
    Have a ATI Radeon card on a HP Pavillion dv6 laptop. 11-3/64 was working . . .
    Have tried to un- and re-install SuSe provided AMD-driver and also tried the driver downloaded from ATI (for 11-3).
    Nothing seems to work.
    I guess I have only heard of using nomodeset, without the x11 on the end and I am not sure what that does, if anything. You can start by looking here:

    SDB:ATI drivers - openSUSE

    and you can search the forums for ATI using this:

    Search - openSUSE.org

    This is a our newest search engine option for openSUSE.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,190

    Default Re: 11-4/64 has to be started with "nomodesetx11"

    I had those same problems with nvidia here's what I did, it might work for you.
    1) at startup type in: nomodset (that's just nomodset no x11 or anything else)
    Once you're running
    2)go here: Additional package repositories - openSUSE
    3) install ATI 11.4 repo into yast
    4)after installation click Software Management ( for nvidia yast opened to Installation Summary there was a lot of nvidia stuff there to be installed ATI may do the same) click Accept
    5) after that I had the nvidia set up I'd known from 11.3
    I hope this'll help you.
    I'm just a curious cat
    My 64 bit: CPU AMD RYZEN 9 3900X 12 Core GPU MSI Radeon RX5600 XT
    MOTHERBOARD GIGABYTE B550 AORUS PRO AC
    Opensuse Tumbleweed Plasma 5

  4. #4
    Join Date
    Dec 2010
    Location
    UAE
    Posts
    25

    Default Re: 11-4/64 has to be started with "nomodesetx11"

    Quote Originally Posted by jdmcdaniel3 View Post
    I guess I have only heard of using nomodeset, without the x11 on the end and I am not sure what that does, if anything. You can start by looking here:

    SDB:ATI drivers - openSUSE

    and you can search the forums for ATI using this:

    Search - openSUSE.org

    This is a our newest search engine option for openSUSE.

    Thank You,
    Had a good look and have tried some of it. No doubt the driver installs but regardless of the method used, I end up with X not starting.
    To boot into desktop I have to select 'nomodeset' = no active driver or 'x11safemode' = no active driver
    Do you have any other suggestions?

  5. #5
    Join Date
    Dec 2010
    Location
    UAE
    Posts
    25

    Default Re: 11-4/64 has to be started with "nomodesetx11"

    Quote Originally Posted by Sagemta View Post
    I had those same problems with nvidia here's what I did, it might work for you.
    1) at startup type in: nomodset (that's just nomodset no x11 or anything else)
    Once you're running
    2)go here: Additional package repositories - openSUSE
    3) install ATI 11.4 repo into yast
    4)after installation click Software Management ( for nvidia yast opened to Installation Summary there was a lot of nvidia stuff there to be installed ATI may do the same) click Accept
    5) after that I had the nvidia set up I'd known from 11.3
    I hope this'll help you.
    NVIDIA works as you mention. Unfortunately only the links for ATI are there. NO FILES!

  6. #6

    Default Re: 11-4/64 has to be started with "nomodesetx11"

    Quote Originally Posted by jdmcdaniel3 View Post
    I guess I have only heard of using nomodeset, without the x11 on the end and I am not sure what that does, if anything. You can start by looking here:
    actually i have used 'nomodesetx11' but on a 11.3 machine - 64bit

  7. #7
    Join Date
    Dec 2010
    Location
    UAE
    Posts
    25

    Default Re: 11-4/64 has to be started with "nomodesetx11"

    Hi.
    Depending on the driver install method and/or driver used, boot phase stops in different places when computer booting.
    The computer is an HP Pavillion dv6 with an Intel video chip build in and an AMD/ATI videocard added for better performance. In Win, the laptop will switch between the two, based on computer connected to external power or not (to preserve power).
    As far as I can see from attached logs, the problem is with these two video cards fighting over resourses, X not being able to select AMD/ATI or at least select one of them, thereby creating a conflict.
    I would like to get AMD/ATI working. Do not have any on/off selection of motherboard video chip in BIOS.
    Any suggestions . . anyone . . .?

    [ 25.415]
    X.Org X Server 1.9.3
    Release Date: 2010-12-13
    [ 25.415] X Protocol Version 11, Revision 0
    [ 25.415] Build Operating System: openSUSE SUSE LINUX
    [ 25.415] Current Operating System: Linux linux-n6ba.site 2.6.37.1-1.2-desktop #1 SMP PREEMPT 2011-02-21 10:34:10 +0100 x86_64
    [ 25.415] Kernel command line: root=/dev/disk/by-id/ata-WDC_WD5000BEKT-60KA9T0_WD-WXJ1AB067425-part2 resume=/dev/disk/by-id/ata-WDC_WD5000BEKT-60KA9T0_WD-WXJ1AB067425-part1 splash=silent quiet vga=0x361
    [ 25.415] Build Date: 22 February 2011 10:08:09PM
    [ 25.415]
    [ 25.415] Current version of pixman: 0.20.0
    [ 25.415] Before reporting problems, check X.Org Wiki - Home
    to make sure that you have the latest version.
    [ 25.415] Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [ 25.415] (==) Log file: "/var/log/Xorg.4.log", Time: Mon Apr 4 06:24:43 2011
    [ 25.415] (==) Using config file: "/etc/X11/xorg.conf"
    [ 25.416] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [ 25.416] (==) ServerLayout "aticonfig Layout"
    [ 25.416] (**) |-->Screen "aticonfig-Screen[0]-0" (0)
    [ 25.416] (**) | |-->Monitor "aticonfig-Monitor[0]-0"
    [ 25.417] (**) | |-->Device "aticonfig-Device[0]-0"
    [ 25.417] (==) Automatically adding devices
    [ 25.417] (==) Automatically enabling devices
    [ 25.417] (WW) The directory "/usr/share/fonts/TTF/" does not exist.
    [ 25.417] Entry deleted from font path.
    [ 25.417] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
    [ 25.417] Entry deleted from font path.
    [ 25.417] (WW) The directory "/usr/share/fonts/misc/sgi" does not exist.
    [ 25.417] Entry deleted from font path.
    [ 25.417] (==) FontPath set to:
    /usr/share/fonts/misc:unscaled,
    /usr/share/fonts/Type1/,
    /usr/share/fonts/100dpi:unscaled,
    /usr/share/fonts/75dpi:unscaled,
    /usr/share/fonts/URW/,
    /usr/share/fonts/cyrillic:unscaled,
    /usr/share/fonts/truetype/
    [ 25.417] (==) ModulePath set to "/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules"
    [ 25.417] (II) The server relies on udev to provide the list of input devices.
    If no devices become available, reconfigure udev or disable AutoAddDevices.
    [ 25.417] (II) Loader magic: 0x7dc040
    [ 25.417] (II) Module ABI versions:
    [ 25.417] X.Org ANSI C Emulation: 0.4
    [ 25.417] X.Org Video Driver: 8.0
    [ 25.417] X.Org XInput driver : 11.0
    [ 25.417] X.Org Server Extension : 4.0
    [ 25.419] (--) PCI:*(0:0:2:0) 8086:0046:103c:144a rev 2, Mem @ 0xc0000000/4194304, 0xb0000000/268435456, I/O @ 0x00005050/8
    [ 25.419] (--) PCI: (0:1:0:0) 1002:68c1:103c:144a rev 0, Mem @ 0xa0000000/268435456, 0xc4400000/131072, I/O @ 0x00004000/256, BIOS @ 0x????????/131072
    [ 25.419] (II) Open ACPI successful (/var/run/acpid.socket)
    [ 25.419] (II) "extmod" will be loaded by default.
    [ 25.419] (II) "dbe" will be loaded by default.
    [ 25.419] (II) "glx" will be loaded by default.
    [ 25.419] (II) "record" will be loaded by default.
    [ 25.419] (II) "dri" will be loaded by default.
    [ 25.419] (II) "dri2" will be loaded by default.
    [ 25.419] (II) LoadModule: "extmod"
    [ 25.421] (II) Loading /usr/lib64/xorg/modules/extensions/libextmod.so
    [ 25.421] (II) Module extmod: vendor="X.Org Foundation"
    [ 25.421] compiled for 1.9.3, module version = 1.0.0
    [ 25.421] Module class: X.Org Server Extension
    [ 25.421] ABI class: X.Org Server Extension, version 4.0
    [ 25.421] (II) Loading extension MIT-SCREEN-SAVER
    [ 25.421] (II) Loading extension XFree86-VidModeExtension
    [ 25.421] (II) Loading extension XFree86-DGA
    [ 25.421] (II) Loading extension DPMS
    [ 25.421] (II) Loading extension XVideo
    [ 25.421] (II) Loading extension XVideo-MotionCompensation
    [ 25.421] (II) Loading extension X-Resource
    [ 25.421] (II) LoadModule: "dbe"
    [ 25.423] (II) Loading /usr/lib64/xorg/modules/extensions/libdbe.so
    [ 25.423] (II) Module dbe: vendor="X.Org Foundation"
    [ 25.423] compiled for 1.9.3, module version = 1.0.0
    [ 25.423] Module class: X.Org Server Extension
    [ 25.423] ABI class: X.Org Server Extension, version 4.0
    [ 25.423] (II) Loading extension DOUBLE-BUFFER
    [ 25.423] (II) LoadModule: "glx"
    [ 25.423] (II) Loading /usr/lib64/xorg/modules/updates/extensions/libglx.so
    [ 25.423] (II) Module glx: vendor="FireGL - ATI Technologies Inc."
    [ 25.423] compiled for 6.9.0, module version = 1.0.0
    [ 25.424] (II) Loading extension GLX
    [ 25.424] (II) LoadModule: "record"
    [ 25.425] (II) Loading /usr/lib64/xorg/modules/extensions/librecord.so
    [ 25.425] (II) Module record: vendor="X.Org Foundation"
    [ 25.425] compiled for 1.9.3, module version = 1.13.0
    [ 25.425] Module class: X.Org Server Extension
    [ 25.425] ABI class: X.Org Server Extension, version 4.0
    [ 25.425] (II) Loading extension RECORD
    [ 25.425] (II) LoadModule: "dri"
    [ 25.426] (II) Loading /usr/lib64/xorg/modules/extensions/libdri.so
    [ 25.426] (II) Module dri: vendor="X.Org Foundation"
    [ 25.426] compiled for 1.9.3, module version = 1.0.0
    [ 25.426] ABI class: X.Org Server Extension, version 4.0
    [ 25.426] (II) Loading extension XFree86-DRI
    [ 25.426] (II) LoadModule: "dri2"
    [ 25.427] (II) Loading /usr/lib64/xorg/modules/extensions/libdri2.so
    [ 25.427] (II) Module dri2: vendor="X.Org Foundation"
    [ 25.427] compiled for 1.9.3, module version = 1.2.0
    [ 25.427] ABI class: X.Org Server Extension, version 4.0
    [ 25.427] (II) Loading extension DRI2
    [ 25.427] (II) LoadModule: "fglrx"
    [ 25.428] (II) Loading /usr/lib64/xorg/modules/drivers/fglrx_drv.so
    [ 25.436] (II) Module fglrx: vendor="FireGL - ATI Technologies Inc."
    [ 25.436] compiled for 1.4.99.906, module version = 8.83.6
    [ 25.436] Module class: X.Org Video Driver
    [ 25.436] (II) Loading sub module "fglrxdrm"
    [ 25.436] (II) LoadModule: "fglrxdrm"
    [ 25.437] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
    [ 25.437] (II) Module fglrxdrm: vendor="FireGL - ATI Technologies Inc."
    [ 25.437] compiled for 1.4.99.906, module version = 8.83.6
    [ 25.437] (II) ATI Proprietary Linux Driver Version Identifier:8.83.6
    [ 25.437] (II) ATI Proprietary Linux Driver Release Identifier: 8.831.2
    [ 25.437] (II) ATI Proprietary Linux Driver Build Date: Mar 8 2011 22:53:31
    [ 25.437] (++) using VT number 7

    [ 25.588] (WW) Falling back to old probe method for fglrx
    [ 25.596] (II) Loading PCS database from /etc/ati/amdpcsdb
    [ 25.597] (--) Chipset Supported AMD Graphics Processor (0x68C1) found
    [ 25.598] (WW) fglrx: No matching Device section for instance (BusID PCI:0@1:0:1) found
    [ 25.598] (II) fglrx: intel VGA device detected, load intel driver.
    [ 25.598] (II) LoadModule: "intel"
    [ 25.601] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
    [ 25.602] (II) Module intel: vendor="X.Org Foundation"
    [ 25.602] compiled for 1.9.3, module version = 2.14.0
    [ 25.602] Module class: X.Org Video Driver
    [ 25.602] ABI class: X.Org Video Driver, version 8.0
    [ 25.603] (II) AMD Video driver is running on a device belonging to a group targeted for this release
    [ 25.603] (II) AMD Video driver is signed
    [ 25.604] (II) fglrx(0): pEnt->device->identifier=0x80aa70
    [ 25.609] (II) intel(1): pEnt->device->identifier=(nil)
    [ 25.609] (EE) Screen 1 deleted because of no matching config section.
    [ 25.609] (II) UnloadModule: "intel"
    [ 25.609] (II) fglrx(0): === [xdl_x760_atiddxPreInit] === begin
    [ 25.609] (II) fglrx(0): PowerXpress: Discrete GPU is selected.
    [ 25.609] libGL symbol link files sanity check failed
    [ 25.609] (EE) fglrx(0): PowerXpress: Fail to switch libGL link files.
    [ 25.609] (WW) fglrx(0): PreInit PowerXpress failed!
    Backtrace:
    [ 25.609] 0: /usr/bin/Xorg (xorg_backtrace+0x28) [0x463678]
    [ 25.609] 1: /usr/bin/Xorg (0x400000+0x6ae89) [0x46ae89]
    [ 25.609] 2: /lib64/libc.so.6 (0x7ffad38a0000+0x32b30) [0x7ffad38d2b30]
    [ 25.609] 3: /usr/lib64/xorg/modules/drivers/fglrx_drv.so (xdl_x760_atiddxFreeScreen+0x72) [0x7ffad15618d2]
    [ 25.609] 4: /usr/bin/Xorg (xf86DeleteScreen+0x7c) [0x47aa0c]
    [ 25.609] 5: /usr/bin/Xorg (InitOutput+0x87a) [0x47240a]
    [ 25.609] 6: /usr/bin/Xorg (0x400000+0x2591d) [0x42591d]
    [ 25.609] 7: /lib64/libc.so.6 (__libc_start_main+0xfd) [0x7ffad38bebfd]
    [ 25.609] 8: /usr/bin/Xorg (0x400000+0x25679) [0x425679]
    [ 25.609] Segmentation fault at address 0x31
    [ 25.609]
    Fatal server error:
    [ 25.609] Caught signal 11 (Segmentation fault). Server aborting
    [ 25.609]
    [ 25.609]
    Please consult the The X.Org Foundation support
    at X.Org Wiki - Home
    for help.
    [ 25.609] Please also check the log file at "/var/log/Xorg.4.log" for additional information.
    [ 25.609]

  8. #8

    Default Re: 11-4/64 has to be started with "nomodesetx11"

    lak27, maybe just disable the built in vga in bios?

  9. #9
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: 11-4/64 has to be started with "nomodesetx11"

    There is a bug in 11.4 which impacts selected ATI hardware requiring 'nomodeset' upon boot, but unless one knows EXACTLY what AMD hardware one has, any suggestion would be PURE speculation. Just stating an HP DV6 is not enough information.

    Can you run in a terminal:
    Code:
    /sbin/lspci -nnk
    and look for the line with VGA in it, and then copy the line and then next 3 lines, and paste them here in this forum thread so we can see EXACTLY what graphic hardware your HP laptop has?

    Based on the line:
    Code:
    [ 25.419] (--) PCI: (0:1:0:0) 1002:68c1:103c:144a rev 0, Mem @ 0xa0000000/268435456, 0xc4400000/131072, I/O @ 0x00004000/256, BIOS @ 0x????????/131072
    I am guessing an AMD Radeon HD5600 series, but to force someone who is trying to help to surf on that just to find out the graphic card is not so efficient. So please run the lspci command as requested to help us have more information so we can help you.

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: 11-4/64 has to be started with "nomodesetx11"

    Quote Originally Posted by lak_726 View Post
    The computer is an HP Pavillion dv6 with an Intel video chip build in and an AMD/ATI videocard added for better performance. In Win, the laptop will switch between the two, based on computer connected to external power or not (to preserve power).
    Re-reading your post I noted the above quote.

    Typically Linux default X auto configuration struggles when there is more than one graphic card (I do NOT have these posts bookmarked as I do not have the hardware) ... I've seen one or two posts of Linux users who claim they managed to get this working with multiple graphic cards, and over a dozen posts of users who could not get it to work.

    I have not seen one how-to guide on how to configure in such a case (which does not mean there is no such guide - it just means I a quick surf I could find no such guide).

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •