Results 1 to 7 of 7

Thread: Problems setting up a Samba server, SuSE 11.3

  1. #1
    Join Date
    Jun 2008
    Location
    Pacific Northwest
    Posts
    374

    Thumbs up Problems setting up a Samba server, SuSE 11.3

    The YaST samba server utility created the following samba.conf file. The lines

    workgroup = WORKGROUP
    netbios name = linux-gep3

    were added manually in an attempt to get things working. Linux-gep3 has "samba server" and "samba client" as allowed service in the firewall. The folder /home/username/xyz has all file sharing options enabled. The client computers do not see WORKGROUP when clicking into "samba shares" with Dolphin.

    Any help would be appreciated. Samba.conf follows:


    [global]
    workgroup = WORKGROUP
    netbios name = linux-gep3
    name resolve order = bcast host lmhosts wins
    server string = ""
    printcap name = cups
    cups options = raw
    use client driver = yes
    map to guest = Bad user
    preferred master = yes
    os level = 65
    usershare allow guests = Yes
    usershare max shares = 100
    passdb backend = smbpasswd

    [printers]
    comment = All Printers
    path = /var/tmp
    printable = Yes
    create mask = 0600
    browseable = No

    [print$]
    comment = Printer Driver
    path = /var/lib/samba/drivers
    write list = @ntadmin root
    force group = ntadmin
    create mask = 0664
    directory mask = 0775

    [Records]
    comment = Records
    path = /home/username/xyz/
    read only = No
    guest ok = Yes
    force user = username
    The greatest obstacle to discovery is not ignorance, it is the illusion of knowledge.
    Daniel J. Boorstin US Patent Office

  2. #2
    Join Date
    Aug 2009
    Location
    Buenos Aires, Argentina
    Posts
    103

    Default Re: Problems setting up a Samba server, SuSE 11.3

    Quote Originally Posted by Parthenolide View Post
    The YaST samba server utility created the following samba.conf file. The lines

    ...
    [Records]
    comment = Records
    path = /home/username/xyz/
    read only = No
    guest ok = Yes
    force user = username
    Hi, do you have a user called "username"?
    I would suggest adding

    browseable = Yes
    force user = root (or any other user with full rights over the directory)

    And set the /home/username/xyz/ directory rights so everyone can see and work with it.
    Maybe for testing:

    # chmod 777 /home/username/xyz/

    Then adjust as needed.

    Hope that helps,

    Pancho
    openSUSE | Think correctly

  3. #3
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Problems setting up a Samba server, SuSE 11.3

    You did not say the nature of your Samba problem, but just insinuated it did not work. Further, just how it works can be different when on the openSUSE computer, looking for others and when on the other computer, looking for openSUSE. You should add the additional allowed Firewall service of Netbios Server. I normally add in the Global options of security = SHARE & local master = Yes.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  4. #4
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Problems setting up a Samba server, SuSE 11.3

    On Sun March 27 2011 08:36 pm, jdmcdaniel3 wrote:

    >
    > You did not say the nature of your Samba problem, but just insinuated it
    > did not work. Further, just how it works can be different when on the
    > openSUSE computer, looking for others and when on the other computer,
    > looking for openSUSE. You should add the additional allowed Firewall
    > service of *Netbios Server. *I normally add in the Global options of
    > *security = SHARE* & *local master = Yes*.
    >
    > Thank You,
    >

    jdmcdaniel3;

    Security = Share is rather obsolete and often creates more problems than it's
    worth. Just add users with smbpasswd -a.

    Parthenolide;



    You might want to take a look at this Howto it is very well written and
    complete.
    http://opensuse.swerdna.org/suselanprimer.html

    Make sure you have done the following.

    Set "Samba Server", "Netbios Server" and "Samba Client" as allowed services.
    (YaST > Security and Users > Firewall > Allowed services)

    Make sure that smbd and nmbd are set to start on boot. (YaST > System > System
    Services (Runlevel)).

    You need nmbd for name resolution.

    Created Samba Users with:
    Code:
    smbpasswd -a <username>

    --
    P. V.
    "We're all in this together, I'm pulling for you." Red Green

  5. #5
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,731
    Blog Entries
    2

    Default Re: Problems setting up a Samba server, SuSE 11.3

    Please post the smb.conf file for one of the client computers.
    Also, on all computers, as venzkep said: Set "Samba Server", "Netbios Server" and "Samba Client" as allowed services.
    And as venzkep implied: "security = share" is a bad option

    Regarding the [Records] share
    Code:
    [Records]
    comment = Records
    path = /home/chauncey/xyz/
    read only = No
    guest ok = Yes
    force user = chauncey
    The permissions on xyz should be ideally drwxr-x--- (chmod 750) but drwxr-xr-x (chmod 755) is OK too.
    "browseable = yes" is automatically on, you don't have to include it.
    Leap 42.3 & 15.1 &KDE
    FYIs from the days of yore

  6. #6
    Join Date
    Jun 2008
    Location
    Pacific Northwest
    Posts
    374

    Default Re: Problems setting up a Samba server, SuSE 11.3

    Thanks to everyone for their help. Per jdmcdaniel13 and venzkep suggestions I set the firewall to allow the netbios server, and now it works like a champ. Resolved.
    The greatest obstacle to discovery is not ignorance, it is the illusion of knowledge.
    Daniel J. Boorstin US Patent Office

  7. #7
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: Problems setting up a Samba server, SuSE 11.3

    Thanks to everyone for their help. Per jdmcdaniel13 and venzkep suggestions I set the firewall to allow the netbios server, and now it works like a champ. Resolved.
    Happy to hear you found your issue Parthenolide. You can not believe how often I had this trip me up at first, causing me to just give up and turn off the Firewall. And this was just because it did not have the word Samba in it. For some reason I just did not place Netbios Server as a function of Samba at first. So I guess I am not the only one that missed this. Please let us know if you need any other assistance and Good Luck!

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •