Results 1 to 10 of 10

Thread: Compiz (Gnome) not properly working on OpenSuse 11.4

  1. #1
    Join Date
    Jan 2010
    Location
    Colombia
    Posts
    17

    Default Compiz (Gnome) not properly working on OpenSuse 11.4

    Hi there,

    Last week I did update OpenSuse 11.3 (previously updated from 11.2) to 11.4.
    Everything works fine except for the compiz desktop effects. On every login they don't seem to be enabled. I have to enable them through simple-ccsm (On full ccsm they appear as enabled )

    Trying to get this working I've updated compiz version to 0.9.4-115.1, but still not working. Later I uninstall whole compiz software, and then reinstall it once again. Nothing seem to change.

    The current status is that when I login no desktop effects are enabled. When I enable them my desktop behavior is too unstable, sometimes the gnome-menu looks like invisible.

    Note: When I login and go to "Windows" on system menu I get an error telling me that window manager is 'Unkown'.

    Infor:
    Opensuse 11.4
    Gnome 2.32
    Laptop Dell Studio 15

    Thanks in advance for your help.

  2. #2
    Join Date
    Sep 2009
    Location
    Argentina, Buenos Aires
    Posts
    100

    Default Re: Compiz (Gnome) not properly working on OpenSuse 11.4

    Hello,

    I also used to have that problem with the main menu, when I click it first time it shows okay, then when I clicked it the second time it became trasnparent (just showing a little shadow border)

    The same happend with the right click on desktop (that should show the options) and one last thing... if you open a window, then you left click on it (to give it focus), and then right click on desktop... and if you repeat this quickly some times your Compiz and desktop effects turns off.

    So each time you enable desktop effects then the its turns off when you bother a little with the interface (i think its what you are taking about)

    What I do to solve it is, reinstall my Opensuse :-( and stick to official repositories, this way everything work fine!

    I think its a repo problem you have, and I have it too... but couldnt find out exactly what was the repo breaking my Compyz (I think maybe a phyton library...)

    You can also try this, so a guru may help you better. Turn off desktop effects, open a terminal window and from there start your compiz manager with
    simple-ccsm
    then start to play with you desktop til it turns off with aparently no reason... you will get some errors in the terminal window where you run simple-ccsm, but cant remember them now... segmentation fauls I think)

    This is my repo list now (with priorities)
    Code:
    [Factory_Contrib_11.4]
    name=Factory_Contrib_11.4
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/repositories/openSUSE:/Factory:/Contrib/openSUSE_11.4/
    path=/
    type=rpm-md
    priority=120
    keeppackages=0
    
    [Updates-for-openSUSE-11.4-11.4-0]
    name=Updates for openSUSE 11.4 11.4-0
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/update/11.4/
    path=/
    type=rpm-md
    keeppackages=0
    
    [VirtualBox_repo_11.4]
    name=VirtualBox_repo_11.4
    enabled=1
    autorefresh=1
    baseurl=http://download.virtualbox.org/virtualbox/rpm/opensuse/11.4/
    path=/
    type=rpm-md
    priority=80
    keeppackages=0
    
    [download.opensuse.org-Wine]
    name=openSUSE BuildService - Wine CVS Builds
    enabled=0
    autorefresh=0
    baseurl=http://download.opensuse.org/repositories/Emulators:/Wine/openSUSE_11.4/
    path=/
    type=rpm-md
    priority=80
    keeppackages=0
    
    [download.opensuse.org-mozilla]
    name=openSUSE BuildService - Mozilla
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/repositories/mozilla/openSUSE_11.4/
    path=/
    type=rpm-md
    priority=80
    keeppackages=0
    
    [download.opensuse.org-standard]
    name=Main Repository 11.4 (Contrib)
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/repositories/openSUSE:/11.4:/Contrib/standard/
    path=/
    type=rpm-md
    priority=110
    keeppackages=0
    
    [ftp.uni-erlangen.de-suse]
    name=Packman Repository
    enabled=1
    autorefresh=1
    baseurl=http://ftp.uni-erlangen.de/pub/mirrors/packman/suse/openSUSE_11.4/
    path=/
    type=rpm-md
    priority=110
    keeppackages=0
    
    [j.eng_11.4]
    name=j.eng_11.4
    enabled=1
    autorefresh=1
    baseurl=http://jftp.medozas.de/openSUSE_11.4/
    path=/
    type=rpm-md
    priority=130
    keeppackages=0
    
    [openSUSE-11.4-11.4-0]
    name=openSUSE-11.4-11.4-0
    enabled=0
    autorefresh=0
    baseurl=cd:///?devices=/dev/disk/by-id/ata-hp_BD-ROM_BC-5501H_06E3187E11,/dev/sr0
    path=/
    type=yast2
    keeppackages=0
    
    [opensuse-guide.org-repo]
    name=libdvdcss repository
    enabled=1
    autorefresh=1
    baseurl=http://opensuse-guide.org/repo/11.4/
    path=/
    type=rpm-md
    priority=80
    keeppackages=0
    
    [repo-debug]
    name=openSUSE-11.4-Debug
    enabled=0
    autorefresh=1
    baseurl=http://download.opensuse.org/debug/distribution/11.4/repo/oss/
    path=/
    type=NONE
    keeppackages=0
    
    [repo-debug-update]
    name=openSUSE-11.4-Update-Debug
    enabled=0
    autorefresh=1
    baseurl=http://download.opensuse.org/debug/update/11.4/
    path=/
    type=NONE
    keeppackages=0
    
    [repo-non-oss]
    name=openSUSE-11.4-Non-Oss
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/distribution/11.4/repo/non-oss/
    path=/
    type=yast2
    keeppackages=0
    
    [repo-oss]
    name=openSUSE-11.4-Oss
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/distribution/11.4/repo/oss/
    path=/
    type=yast2
    keeppackages=0
    
    [repo-source]
    name=openSUSE-11.4-Source
    enabled=1
    autorefresh=1
    baseurl=http://download.opensuse.org/source/distribution/11.4/repo/oss/
    path=/
    type=yast2
    keeppackages=0
    
    [www2.ati.com-suse]
    name=ATI Repository
    enabled=1
    autorefresh=1
    baseurl=http://www2.ati.com/suse/11.4
    path=/
    type=rpm-md
    keeppackages=0
    Hope to help...

  3. #3
    Join Date
    Jan 2010
    Location
    Colombia
    Posts
    17

    Default Re: Compiz (Gnome) not properly working on OpenSuse 11.4

    Thanls a lot for your help,

    Following your advice I use console to start simple-ccsm, these are the results:

    Code:
    Backend     : ini
    Integration : true
    Profile     : Por defecto
    Adding plugins
    Initializing core options...done
    Initializing animation options...done
    Initializing animationaddon options...done
    Initializing ezoom options...done
    Initializing mag options...done
    Initializing cube options...done
    Initializing cubeaddon options...done
    Initializing switcher options...done
    Initializing shift options...done
    Initializing ring options...done
    Initializing staticswitcher options...done
    Initializing compiztoolbox options...done
    Initializing gnomecompat options...done
    Initializing crashhandler options...done
    Initializing regex options...done
    Initializing wobbly options...done
    Initializing opengl options...done
    Initializing fade options...done
    Initializing td options...done
    Initializing composite options...done
    Initializing rotate options...done
    Initializing gears options...done
    Initializing blur options...done
    Checking for Xgl: not present. 
    xset q doesn't reveal the location of the log file. Using fallback /var/log/Xorg.0.log 
    Detected PCI ID for VGA: 00:02.0 0300: 8086:2a42 (rev 07) (prog-if 00 [VGA controller])
    Checking for software rasterizer: not present. 
    Checking for texture_from_pixmap: present. 
    Checking for non power of two support: present. 
    Checking for Composite extension: present. 
    Comparing resolution (1366x768) to maximum 3D texture size (4096): Passed.
    Checking for nVidia: not present. 
    Checking for FBConfig: present. 
    Checking for Xgl: not present. 
    Starting gtk-window-decorator
    /usr/bin/compiz (core) - Warn: Unknown option '--ignore-desktop-hints'                                                                                                                          
                                                                                                                                                                                                    
    /usr/bin/compiz (core) - Error: Plugin 'core' has ABI version '20110224', expected ABI version '20110131'.                                                                                      
                                                                                                                                                                                                    
    /usr/bin/compiz (core) - Error: InitPlugin 'ccp' failed                                                                                                                                         
    /usr/bin/compiz (core) - Error: Couldn't activate plugin 'ccp'                                                                                                                                  
    /usr/bin/compiz (core) - Error: Plugin 'core' has ABI version '20110224', expected ABI version '20110131'.                                                                                      
                                                                                                                                                                                                    
    /usr/bin/compiz (core) - Error: InitPlugin 'ccp' failed                                                                                                                                         
    /usr/bin/compiz (core) - Error: Couldn't activate plugin 'ccp'
    /usr/bin/compiz (core) - Warn: Value type is not yet set
    I really don't wanna re-install my SO right now, so if this is useful to make it work, i'll appreciate any help.

  4. #4
    Join Date
    Sep 2009
    Location
    Argentina, Buenos Aires
    Posts
    100

    Lightbulb Re: Compiz (Gnome) not properly working on OpenSuse 11.4

    It maybe useful if you post the outputs of:
    zypper repos
    uname -a
    hwinfo
    (you can paste the outputs in a pastebin and it would be wise to post everything in the Application Forums since its a Compiz problem more than a laptop one)

    And the video driver you are using (I am using the opensuse 11.4 ATI repository and its working fine for me, but I used to install the propietary drivers downloaded from ati.com)

  5. #5
    Join Date
    Jan 2010
    Location
    Colombia
    Posts
    17

    Default Re: Compiz (Gnome) not properly working on OpenSuse 11.4

    Thanks for your help,

    Theses are the outputs from:
    zypper repos
    uname -a
    hwinfo --gfxcard

    compiz problem - Pastebin.com

    Greetings.

  6. #6
    Join Date
    Sep 2009
    Location
    Argentina, Buenos Aires
    Posts
    100

    Default Re: Compiz (Gnome) not properly working on OpenSuse 11.4

    OK... your uname says "desktop" kernel... if I am not mistaken I think it should be "default" kernel type for a laptop. I had a lot of problems when I add repositories and one of them changen my kernel from default to desktop (I think desktop its more friendly to desktop computers not for laptops... but I am just guessing)

    At your own risk :-), you can try to go back to default kernel instead of desktop if my first guessing is true.

    Or you can try to remove the X11:Compiz repository (firstly uninstall the stuff installed from this repository) and revert to the official repositories openSUSE-11.4-Update, openSUSE-11.4-........ (there is an option to zypper dup repositoryname or from Yast if you select filter by repository, then select and revert)

    Sorry for not being more useful...

  7. #7
    Join Date
    Jan 2010
    Location
    Colombia
    Posts
    17

    Default Re: Compiz (Gnome) not properly working on OpenSuse 11.4

    Well I've uninstalled compiz, disabled X11:Compiz repository and installed Compiz 0.9.2-1.5.5.

    Then I've installed kernel-default, restart, select the new kernel and login once again...

    Nothing happens. The problem's still there.

    Thanks sebadamus. I really appreciate your help, at least you give me some options.

    I hope anyone else give me some ideas.

    BTW: I'm starting thinking that my problem could be my video/graphic driver. But so far, I really don't know what's the next step to prove this hipotesis.

    Greetings.

  8. #8
    Join Date
    Aug 2010
    Location
    Aveiro, Portugal
    Posts
    313

    Default Re: Compiz (Gnome) not properly working on OpenSuse 11.4

    Hi,

    I don't believe that users who aren't familiar with compiz should jump into 0.9.4. It does work perfectly for me, but needs some manual tweaks.

    Regarding the 0.9.2.1 provided as default with openSUSE, it's also working properly. The first thing you should actually do is to look for .xsession-errors and check out the logs for anything that might be looking suspicious, or eventually post the log from that file. From there we can for sure look into something that help you

    Compiz is enabled is the following file exists: ~/.config/compiz/enable-compiz
    If the previous file doesn't exist you can try to create it with: 'touch ~/.config/compiz/enable-compiz' and relog.

    If it's there, compiz is launched by compiz-manager... If its not there, compiz doesn't load. Now, it might be there, and compiz not being launched, if that's the case, that's most likely because something is going wrong... In this case we need the log that I pointed before which should be in: ~/.xsession-errors.

  9. #9

    Default Re: Compiz (Gnome) not properly working on OpenSuse 11.4

    (Assuming the compiz packages are installed already...)

    Make sure "compiz-manager" is run when GNOME starts. In other words, if you're using openSUSE's "slab" menu, click on "Control Center" (on the right under "System"), then (in the "Personal" group) "Startup Applications". (Or just run "gnome-control-center" from a terminal.) Make sure there's an entry for '/usr/bin/compiz-manager' . Add it and enable it if it doesn't exist (it didn't after I upgraded from 11.3 to 11.4).

    Then make sure ~/.config/compiz/enable-compiz exists. Log out, log in and hopefully all should be well.

  10. #10
    Join Date
    Jan 2010
    Location
    Colombia
    Posts
    17

    Default Re: Compiz (Gnome) not properly working on OpenSuse 11.4

    Well eco2geek you were right (Thanks ). There was no entry for '/usr/bin/compiz-manager', I added it and it works fine now. There's just a little issue with the desktop selector (It only show 1 desktop, so I got to press Ctrl + alt + Left/right, and it shows me the others 3 desktops).

    Also thanks to ketheriel and sebadamus for your help.

    Greetings.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •