Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: NFS umount only works with root

  1. #1

    Default NFS umount only works with root

    Hello. I mount my NFS shares with fstab entries like

    xxxx.xxxx.xx:/srv/vdr /media/vdr_video nfs noauto,user,bg,soft,intr,retry=5 0 0
    With openSUSE 11.2 works this fine. With openSUSE 11.4 installation (no upgrade) only NFS mount works fine. The umount command works only with root.

    Regards

    Thilo

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default re: NFS umount only works with root

    I thought all fstab mounts were controlled with root privileges (as far as mounting/unmounting). Anyway, this is likely a udisks policy

    With KDE, you can adjust graphically via

    System Settings > Actions Policy > org.freedesktop > The udisks Project > Unmount a device mounted by a another user

    Gnome has a similar graphical interface.

  3. #3

    Default re: NFS umount only works with root

    I change the "Active console" parameter at "Unmount a device mounted by a another user" from Administrator Auhentication to Yes. umount doesen't work anymore. umount also doesen't work in terminal.

    I see you are an global moderator. Can you please change the thread title to "NFS umount only work with root". I made ​​a mistake. Thanks.

    Regards

    Thilo

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Re: NFS umount only works with root

    I've just noticed is that you've used /media/vdr_video as a mount-point. I think you should be using a mount-point within your ~/ directory (for user mounting/unmounting). The /media tree is root-owned, reserved for removable device mounting.

    Here's a nice NFS troubleshooting guide.
    Last edited by deano_ferrari; 27-Mar-2011 at 11:31.

  5. #5

    Default Re: NFS umount only works with root

    sorry, however this I do not understand. The fstab entry

    <FQDN>:/srv/vdr /media/vdr_video nfs noauto,user,bg,soft,intr,retry=5 0 0
    meanwhile i use so several years in such a way. Mount with normal user are ok. Only umout doesen't work. OpenSUSE 11.2 on my Notebook mount and umount with the fstab entry and normal user works fine. Never i mount something in my userhome.

    I suppose this is a bug.

    Regards

    Thilo

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,711
    Blog Entries
    1

    Default Re: NFS umount only works with root

    I'm guessing its a security improvement. Try creating a mount-point within your home directory (eg /home/thilo/vdr_video), then adjust fstab accordingly. See if that works ok.

  7. #7

    Default Re: NFS umount only works with root

    thilo b wrote:
    > sorry, however this I do not understand. The fstab entry
    >
    >> <FQDN>:/srv/vdr /media/vdr_video nfs noauto,user,bg,soft,intr,retry=5 0
    >> 0

    >
    > meanwhile i use so several years in such a way. Mount with normal user
    > are ok. Only umout doesen't work. OpenSUSE 11.2 on my Notebook mount and
    > umount with the fstab entry and *normal* user works fine. Never i mount
    > something in my userhome.
    >
    > I suppose this is a bug.


    try umount -v to see if it tells you anything more. Or perhaps look in
    /var/log/messages

    I too don't see why umount should behave differently to mount?!!

  8. #8

    Default Re: NFS umount only works with root

    umount -v /media/vdr_video
    umount.nfs: You are not permitted to unmount /media/vdr_video
    umount.nfs: You are not permitted to unmount /media/vdr_video
    @ my home:
    umount -v vdr_video/
    umount: Nur root kann vdr.local.tb:/srv/vdr von /home/thilo/vdr_video unmounten
    In the file /var/log/messages nothing recorded.

    Regards

    Thilo

  9. #9
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: NFS umount only works with root

    On 2011-03-29 18:36, thilo b wrote:
    >
    >> umount -v /media/vdr_video
    >> umount.nfs: You are not permitted to unmount /media/vdr_video
    >> umount.nfs: You are not permitted to unmount /media/vdr_video

    >
    > @ my home:
    >> umount -v vdr_video/
    >> umount: Nur root kann vdr.local.tb:/srv/vdr von /home/thilo/vdr_video
    >> unmounten


    Hum.

    Create this script - /usr/local/bin/english:

    Code:
    -----------------
    > #!/bin/sh
    > LANG=en_US.UTF-8 LC_ALL=en_US.UTF-8 DICTIONARY=english KDE_LANG=en_US.UTF-8 $*

    -----------------


    Now, repeat the commands above as "english mount etcetera", so that we can
    read it :-)

    And post between code tags - advanced editor, "#".

    Include the output of the command "mount" alone, while the nfs export is
    mounted.

    Don't create mount points in /home, that doesn't make sense. However, you
    should not use /media for manual mounts, the traditional place is /mnt.

    One detail more: the user umounting has to be the same one as mounted the
    device - else, you need the option "users" (plural) in the options.

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  10. #10

    Default Re: NFS umount only works with root

    thilo b wrote:
    >> umount -v /media/vdr_video
    >> umount.nfs: You are not permitted to unmount /media/vdr_video
    >> umount.nfs: You are not permitted to unmount /media/vdr_video

    >
    > @ my home:
    >> umount -v vdr_video/
    >> umount: Nur root kann vdr.local.tb:/srv/vdr von /home/thilo/vdr_video
    >> unmounten

    >
    > In the file /var/log/messages nothing recorded.


    Hmm, What permissions do /media/vdr_video and /home/thilo/vdr_video have?

    As Carlos says, you must use the same user, which I guess you are, but
    perhaps you can show the output from the preceding

    mount -v <whatever args>

    as well. Also

    cat /proc/mounts

    might just show something useful.

    (BTW, I'm not running 11.4. Can somebody who IS running 11.4 confirm
    whether or not fstab-based NFS mounts and unmounts by a non-root user
    works for you?)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •