Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: smb Protocol in firefox

  1. #1
    Join Date
    Apr 2009
    Posts
    27

    Question smb Protocol in firefox

    What do I need to do to get the smb protocol to work in SUSE 11.4? When I type in smb://ipaddress on my local network, I get an error saying Firefox does not know how to handle it. Yet I have another Linux work station which is Ubuntu 10.04 and it works fine so I am assuming it is something to do with SUSE.

  2. #2
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default Re: smb Protocol in firefox

    Check your firewall settings. I think you should add samba-client and netbios to the allowed services, iirc.

  3. #3
    Join Date
    Jun 2008
    Location
    Finland, European Union
    Posts
    1,879

    Default Re: smb Protocol in firefox

    Firefox has nothing to do with smb as its a browser, open a file manager and then type smb:// into it.

    For example Dolphin on KDE.

  4. #4
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default Re: smb Protocol in firefox

    Firefox can handle smb, at least to a certain degree. Just tried it after I read the OP.

  5. #5
    Join Date
    Apr 2009
    Posts
    27

    Default Re: smb Protocol in firefox

    Quote Originally Posted by Chrysantine View Post
    Firefox has nothing to do with smb as its a browser, open a file manager and then type smb:// into it.

    For example Dolphin on KDE.
    That may be so and yes it does work in nautilus, but smb does work in firefox on my Ubuntu box so there must be a way to get Suse to work as well.

  6. #6
    Join Date
    Apr 2009
    Posts
    27

    Default Re: smb Protocol in firefox

    Quote Originally Posted by supertimorplusfort View Post
    Firefox can handle smb, at least to a certain degree. Just tried it after I read the OP.

    How did you get it to work?

  7. #7
    Join Date
    Apr 2009
    Posts
    27

    Default Re: smb Protocol in firefox

    Quote Originally Posted by supertimorplusfort View Post
    Check your firewall settings. I think you should add samba-client and netbios to the allowed services, iirc.

    I added netbios to the allowed services as smbclient was already allowed, but still no luck.

  8. #8
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default Re: smb Protocol in firefox

    Actually, after I read your post, I just tried smb://ip... in Firefox and it just worked. I've done nothing to get it to work. Maybe there's a setting in Firefox's about:config. Somewhere around "network.protocol-handler" I would guess. Oh, I use Firefox 3.6 btw.
    Whatsoever, I think every file browser is way more convenient for smb than firefox is.

  9. #9
    Join Date
    Jun 2008
    Location
    Berlin, Germany
    Posts
    369

    Default Re: smb Protocol in firefox

    Ok, tried it again with openSUSE 11.4 and Firefox 4.0b12. Didn't work...

  10. #10

    Default Re: smb Protocol in firefox

    Hi,

    Am 27.03.2011 01:36, schrieb Z K:
    >
    > What do I need to do to get the smb protocol to work in SUSE 11.4? When
    > I type in smb://ipaddress on my local network, I get an error saying
    > Firefox does not know how to handle it. Yet I have another Linux work
    > station which is Ubuntu 10.04 and it works fine so I am assuming it is
    > something to do with SUSE.


    This feature is unfortunately missing with openSUSE 11.4.
    Firefox used gnome-vfs before to provide it and the Firefox on 11.4 uses
    gio to replace _almost_ all gnome-vfs functions.
    Providing the smb protocol is one of the missing ones. However I'm
    wondering if people really used it since it was quite basic.

    Wolfgang

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •