Results 1 to 6 of 6

Thread: Accounting Program Error. Hoping you know about Pastel Accounting 2011

  1. #1
    Join Date
    Mar 2010
    Location
    South Africa
    Posts
    6

    Angry Accounting Program Error. Hoping you know about Pastel Accounting 2011

    Having an Error with a commercial Account program Called Pastel Accounting
    [www.pastel.co.za]. When I invoke multiuser Access to opening one account set
    of books with multiple users for opening one account, it produces an error. I'm
    able to open the one set of books with a password. But when trying open the same
    set of books from another computer, it produces an error. The attached file
    shows the error. The Database engine is Pervasive Corporate Site > Home.


    This is the version I'm running and my script below.

    Samba version 3.5.8-30.1-2516-SUSE-SL11.3-i386

    # Samba config file created using SWAT
    # from UNKNOWN (0.0.0.0)
    # Date: 2011/02/22 15:56:54

    [global]
    netbios name = SERVER
    server string = Samba file and print server
    bind interfaces only = Yes
    update encrypted = Yes
    client schannel = No
    server schannel = No
    obey pam restrictions = Yes
    passwd program = /usr/bin/passwd '%u'
    passwd chat = *New*password* %n\n *ReType*new*password* %n\n
    *passwd*changed*\n
    passwd chat timeout = 120
    username map = /etc/samba/smbusers
    password level = 6
    username level = 6
    unix password sync = Yes
    client NTLMv2 auth = Yes
    log file = /var/log/samba/samba.log
    max log size = 1000
    name resolve order = wins lmhosts bcast
    client signing = No
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    printcap name = cups
    machine password timeout = 120
    add user script = /usr/sbin/useradd -d /dev/null -c 'Samba User Account' -s
    /dev/null '%u'
    delete user script = /usr/sbin/userdel '%u'
    add group script = /usr/sbin/groupadd '%g'
    delete group script = /usr/sbin/groupdel '%g'
    add user to group script = /usr/sbin/useradd -d /dev/null -c 'Samba User
    Account' -s /dev/null -g '%g' '%u'
    delete user from group script = /usr/sbin/userdel '%u' '%g'
    add machine script = /usr/sbin/useradd -d /dev/null -g sambamachines -c 'Samba
    Machine Account' -s /dev/null -M '%u'
    logon script = %G.bat
    logon path = \\%L\profiles\%u
    logon drive = m:
    logon home = \\%L\homes\%u
    os level = 33
    local master = No
    dns proxy = No
    ## usershare allow guests = Yes
    idmap uid = 16777216-33554431
    idmap gid = 16777216-33554431
    template shell = /dev/null
    winbind separator = @
    winbind cache time = 360
    winbind nss info = no
    cups options = raw

    [homes]
    comment = Home Directories
    valid users = %S, %D%w%S
    read only = No
    inherit acls = Yes
    browseable = No

    [netlogon]
    comment = Network Logon Service
    path = /home/netlogon
    locking = No
    strict locking = No

    [profiles]
    comment = Network Profiles Service
    path = %H
    read only = No
    create mask = 0600
    directory mask = 0700
    store dos attributes = Yes

    [printers]
    comment = All Printers
    path = /var/spool/samba
    printable = Yes
    browseable = No
    locking = No
    strict locking = No

    [pdf-documents]
    comment = Converted PDF Documents
    path = /home/pdf-documents
    read only = No
    locking = No
    strict locking = No

    [pdf-printer]
    comment = PDF Printer Service
    path = /tmp
    printable = Yes
    printing = bsd
    print command = /usr/bin/gadmin-samba-pdf %s %u
    lpq command =
    lprm command = lprm -P'%p' %j
    use client driver = Yes

    [jobfiles]
    writeable = yes
    locking = No
    path = /home/tugela/Jobfiles
    force user = tugela
    create mask = 0664
    directory mask = 0775
    public = yes
    inherit acls = Yes

    [VIP]
    path = /home/tugela/VIP_PAYROLL
    valid users = vip, charles
    write list = vip, charles
    force user = tugela
    read only = No
    create mask = 0644
    inherit acls = Yes
    locking = No

    [pastel]
    writeable = yes
    locking = No
    path = /home/tugela/pastel
    write list = vip,charles,pastel,"TP Admin & Debtors"
    force user = tugela
    create mask = 0644
    valid users = charles,vip,pastel,"TP Admin & Debtors"
    inherit acls = Yes

    [tugord]
    writeable = yes
    locking = no
    path = /home/tugela/tugord
    write list = charles,tug,"TP Admin & Debtors"
    force user = tugela
    valid users = charles,tug, "TP Admin & Debtors"
    create mode = 0644
    inherit acls = Yes

    [backup]
    path = /media/Tugela Backups
    writeable = yes
    write list = vip,charles,pastel,"TP Admin & Debtors"
    valid users = charles,vip,pastel,"TP Admin & Debtors"
    inherit acls = Yes


  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    24,872

    Default Re: Accounting Program Error. Hoping you know about Pastel Accounting 2011

    You forgot to mention which version of openSUSE you use.
    Henk van Velden

  3. #3
    Join Date
    Nov 2009
    Location
    ND, USA
    Posts
    1,131

    Default Re: Accounting Program Error. Hoping you know about Pastel Accounting 2011

    On Sat March 26 2011 09:06 am, tommyrich wrote:

    >
    > Having an Error with a commercial Account program Called Pastel
    > Accounting
    > [www.pastel.co.za]. When I invoke multiuser Access to opening one
    > account set
    > of books with multiple users for opening one account, it produces an
    > error. I'm
    > able to open the one set of books with a password. But when trying open
    > the same
    > set of books from another computer, it produces an error. The attached
    > file
    > shows the error. The Database engine is 'Pervasive Corporate Site >
    > Home' (http://www.pervasive.com/).
    >
    >
    > This is the version I'm running and my script below.
    >
    > Samba version 3.5.8-30.1-2516-SUSE-SL11.3-i386

    <snip>
    >
    > [global]
    > netbios name = SERVER
    > server string = Samba file and print server
    > bind interfaces only = Yes
    > update encrypted = Yes
    > client schannel = No
    > server schannel = No
    > obey pam restrictions = Yes
    > passwd program = /usr/bin/passwd '%u'
    > passwd chat = *New*password* %n\n *ReType*new*password* %n\n
    > *passwd*changed*\n
    > passwd chat timeout = 120
    > username map = /etc/samba/smbusers
    > password level = 6
    > username level = 6
    > unix password sync = Yes
    > client NTLMv2 auth = Yes
    > log file = /var/log/samba/samba.log
    > max log size = 1000
    > name resolve order = wins lmhosts bcast
    > client signing = No
    > socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    > printcap name = cups
    > machine password timeout = 120
    > add user script = /usr/sbin/useradd -d /dev/null -c 'Samba User
    > Account' -s
    > /dev/null '%u'
    > delete user script = /usr/sbin/userdel '%u'
    > add group script = /usr/sbin/groupadd '%g'
    > delete group script = /usr/sbin/groupdel '%g'
    > add user to group script = /usr/sbin/useradd -d /dev/null -c 'Samba
    > User
    > Account' -s /dev/null -g '%g' '%u'
    > delete user from group script = /usr/sbin/userdel '%u' '%g'
    > add machine script = /usr/sbin/useradd -d /dev/null -g sambamachines
    > -c 'Samba
    > Machine Account' -s /dev/null -M '%u'
    > logon script = %G.bat
    > logon path = \\%L\profiles\%u
    > logon drive = m:
    > logon home = \\%L\homes\%u
    > os level = 33
    > local master = No
    > dns proxy = No
    > ## usershare allow guests = Yes
    > idmap uid = 16777216-33554431
    > idmap gid = 16777216-33554431
    > template shell = /dev/null
    > winbind separator = @
    > winbind cache time = 360
    > winbind nss info = no
    > cups options = raw
    >

    <snip>
    > [image: http://home.intekom.com/trustservice/pastelerror.jpg]
    >

    tommyrich;

    I'm not familiar with that Accounting program, but I'll venture to guess that
    since your problem is with later connections that you are having a problem
    with oplocks. Try adding the following parameter to the appropriate shares:
    Code:
    oplocks = no
    See the following writeup on the use of oplocks:

    http://www.samba.org/samba/docs/man/...n/locking.html

    Although not directly related to your problem, your smb.conf is a disaster,
    full of unneeded and perhaps harmful parameters. For example "socket
    options" are obsolete for modern kernels and this parameter generally
    degrades performance. You have "name resolve order" to first try to use
    wins, yet there is no indication that any wins server is configured. I
    think you would be well advised to review the following HowTO.

    http://opensuse.swerdna.org/suselanprimer.html


    --
    P. V.
    "We're all in this together, I'm pulling for you." Red Green

  4. #4
    Join Date
    Mar 2010
    Location
    South Africa
    Posts
    6

    Default Re: Accounting Program Error. Hoping you know about Pastel Accounting 2011

    Quote Originally Posted by hcvv View Post
    You forgot to mention which version of openSUSE you use.
    Using Opensuse 11.3

  5. #5
    Join Date
    Mar 2010
    Location
    South Africa
    Posts
    6

    Default Re: Accounting Program Error. Hoping you know about Pastel Accounting 2011

    Thank you for the replys

    I've done the oplocks because the pervasive database engine throws a 116 error with Pastel, which is to do with a locking error with its [ .loc ] file.

  6. #6
    Join Date
    Mar 2010
    Location
    South Africa
    Posts
    6

    Default Re: Accounting Program Error. Hoping you know about Pastel Accounting 2011

    All is working. Do not use [ locking = on ] on Read-write Sharing of folders. Should of stuck with the default settings.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •