Results 1 to 2 of 2

Thread: Installed SCIM, but not needing it often

  1. #1
    Join Date
    Nov 2010
    Location
    どこでも
    Posts
    53

    Default Installed SCIM, but not needing it often

    I recently installed SCIM because I needed the japanese input method, but problem is I don't need it so often, and apparently installing it made my keyboard ignore shift+ctrl selection of words on text fields (which is very frustrating because I use it a lot).

    I tried to close SCIM (then I would open it when I need it), but if I choose "exit" on it's tray icon, it just reloads. I'm about to try "kill scim" but I suppose there must be a way to stop it from auto loading at startup.

    Either that or making my shift+ctrl working again for text selection would make me happy. Also, does SCIM completely overrides the keyboard input of KDE? I had english international and latinamerican before, but changing them didn't had any effect after SCIM came...

    Thank you very much in advance!

  2. #2
    Taki NNTP User

    Default Re: Installed SCIM, but not needing it often

    On 03/25/2011 09:36 PM, kirbyiwakitsukino wrote:
    >
    > I recently installed SCIM because I needed the japanese input method,
    > but problem is I don't need it so often, and apparently installing it
    > made my keyboard ignore shift+ctrl selection of words on text fields
    > (which is very frustrating because I use it a lot).
    >
    > I tried to close SCIM (then I would open it when I need it), but if I
    > choose "exit" on it's tray icon, it just reloads. I'm about to try "kill
    > scim" but I suppose there must be a way to stop it from auto loading at
    > startup.
    >
    > Either that or making my shift+ctrl working again for text selection
    > would make me happy. Also, does SCIM completely overrides the keyboard
    > input of KDE? I had english international and latinamerican before, but
    > changing them didn't had any effect after SCIM came...
    >
    > Thank you very much in advance!
    >
    >


    The SCIM input frame-work is now being replaced by iBus. It is not
    actively developed, it seems. Apparently, many users having a trouble
    using SCIM in KDE, too.

    For simple Japanese input, use "ibus-anthy"; it works fine for me.

    SCIM or iBus, a key combination for toggling to turn on/off the input
    framework is user-selectable. The default is usually Control+Space or
    Shift+Space. How you've got Shift+Control is a mystery to me.

    In KDE, there's a menu item to configure iBus. Or from a terminal or
    console, enter the command "ibus-set-up", as a normal user.

    You may want to subscribe to the "M17N" repo:

    http://download.opensuse.org/reposit...openSUSE_11.4/

    some packages to install:
    ibus
    anthy
    ibus-anthy
    ibus-table
    ibus-gtk (there's ibus-qt, too, if you want)
    libibus2 (this gets pulled in, when you pick ibus)
    some Japanese fonts

    gjiten - a simplistic Japanese-English/English-Japanese dictionary
    (this pulls in "edict". There's "kiten" as well,
    though I see no need for it)
    efont-unicode

    In ~/.xim, I have:

    export GTK_IM_MODULE=ibus
    export XMODIFIERS=@im=ibus
    export QT_IM_MODULE=ibus
    (I think "iBus" tells you at an early stage to add the above 3 lines
    in ~/.bashrc. That works, too. I'm following a tradition.)
    Additionally, I have two more lines:
    export QT_IM_SWITCHER=imsw-multi
    ibus-daemon -x -d
    (I'm following the pattern in ~/.xim.template.)




Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •