Results 1 to 10 of 10

Thread: display fails in opensuse 11.4

  1. #1

    Unhappy display fails in opensuse 11.4

    I have been with opensuse from 10, and I currently run 11.3 on my desktops. My attempt to install 11.4 failed. It produced a display with many tiny rectangles instead of a gui. I guess there is a discrepancy between the times produced by the x and the y display drivers and the times expected by the display hardware. I can't blame it on the display hardware, though, because I switched to another monitor and got the same error. I did the usual tests from the install screen, and there are no errors. If I run the program in fail-safe mode, the display is text only. In this case there is no x-server. I have not observed that in 11.3 fail-safe. Can anyone offer suggestions?

    Richard

  2. #2
    Join Date
    Mar 2010
    Location
    Austin - Texas
    Posts
    10,140
    Blog Entries
    48

    Smile Re: display fails in opensuse 11.4

    I have been with opensuse from 10, and I currently run 11.3 on my desktops. My attempt to install 11.4 failed. It produced a display with many tiny rectangles instead of a gui. I guess there is a discrepancy between the times produced by the x and the y display drivers and the times expected by the display hardware. I can't blame it on the display hardware, though, because I switched to another monitor and got the same error. I did the usual tests from the install screen, and there are no errors. If I run the program in fail-safe mode, the display is text only. In this case there is no x-server. I have not observed that in 11.3 fail-safe. Can anyone offer suggestions?

    Richard
    Tell us more about your video hardware and more about your computer if you can. It is odd that openSUSE 11.3 works OK and 11.4 does not. I normally suggest that you addin the kernel load option nomodeset. You can type this command in as an option before pressing enter to select your openSUSE startup. If this works, it can be added as a standard option to your /boot/grub/menu.lst file if you want.

    Thank You,
    My Blog: https://forums.opensuse.org/blogs/jdmcdaniel3/

    Software efficiency halves every 18 months, thus compensating for Moore's Law

    Its James again from Austin, Texas

  3. #3
    Join Date
    Mar 2011
    Location
    East Midlands, UK
    Posts
    3

    Default Re: display fails in opensuse 11.4

    Hi
    I have had the same problem with the upgrade and or complete new install. I to use suse from v 10.1 and mainly business use. I have three machines that run suse 1 Compaq laptop (32bit) and 2 desktops 1(32bit) and 1 (64bit). The laptop is duel boot with win 7 and installed right out the box, but neither desktops machines work though they have been running suse 11.3 since it came out with no problems. Would like to know how to resolve the problem, as it seems odd that the display is fine all the way through the install and only occures after reboot? CPU AMD 7750 Dual Core RAM 3.6 GiB Display nVidia Corp C61 Geforce 7025/ nforce 630a driver nouveau/Gallium (7.8.2)

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: display fails in opensuse 11.4

    Quote Originally Posted by tanglin View Post
    Hi
    I have had the same problem with the upgrade and or complete new install. I to use suse from v 10.1 and mainly business use. I have three machines that run suse 1 Compaq laptop (32bit) and 2 desktops 1(32bit) and 1 (64bit). The laptop is duel boot with win 7 and installed right out the box, but neither desktops machines work though they have been running suse 11.3 since it came out with no problems. Would like to know how to resolve the problem, as it seems odd that the display is fine all the way through the install and only occures after reboot? CPU AMD 7750 Dual Core RAM 3.6 GiB Display nVidia Corp C61 Geforce 7025/ nforce 630a driver nouveau/Gallium (7.8.2)
    Did you try the boot code 'nomodeset' ?

    Did you try a 'safe settings' install or a 'fail safe boot ?

    If you succeed with either of those it provides information on which one can make assessments as to the problem and possibly come up with work around solutions. Without that knowledge passed on its difficult to provide any advice.

  5. #5
    Join Date
    Mar 2011
    Location
    East Midlands, UK
    Posts
    3

    Default Re: display fails in opensuse 11.4

    Yes tried both so am at a loss, I reinstalled 11.3 on both machines so there is no problem as they work just fine. But it is always nice to have the latest version if pos. I will keep my eye open for any further posts on this problem in the mean time will stick with 11.3
    Thank you.

  6. #6

    Thumbs down Re: display fails in opensuse 11.4

    I had this problem with the (32-bit) Live CD version. I have NVidia displays on both desktop and laptop and both failed with the small rectangles. The full DVD, when installed, has a working display -- BUT CALLS ITSELF 11.2 IN THE INITIAL SCREEN AND THE MULTIBOOT!!!! It also does a poor job of setting up the multiboot -- I had to modify the menu.lst file by hand to get other linux boots to work.

    Also I cannot install iscan firmware because it says it is already installed -- but the scanner setup says iscan is not present. Perhaps this should be a separate subject?

  7. #7
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: display fails in opensuse 11.4

    Quote Originally Posted by tanglin View Post
    Yes tried both so am at a loss,
    Thats a bit strange. When you nominally boot, the nouveau video driver is attempted. When you use 'nomodeset' the nv video driver is attempted. When you use the fail safe the fbdev driver is used. Given you succeeded in the installation (with the fbdev driver) it surprised me that the fbdev driver did not work in failsafe.

    When you installed 11.4, did you keep your previous /home and in that /home have special desktop effects enabled? Its ALWAYS best NOT to have special desktop effects enabled in one's old /home if one is going to keep that in a new install (IMHO).

  8. #8
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: display fails in opensuse 11.4

    Quote Originally Posted by wdhart View Post
    Perhaps this should be a separate subject?
    ...... YES .......

  9. #9

    Default Re: display fails in opensuse 11.4

    No, it was a full install. I don't remember seeing a 'nomodeset' startup option in the Live CD menu. And I will start a new thread for the other stuff! Thanks

  10. #10
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    27,109
    Blog Entries
    40

    Default Re: display fails in opensuse 11.4

    Quote Originally Posted by wdhart View Post
    No, it was a full install. I don't remember seeing a 'nomodeset' startup option in the Live CD menu. And I will start a new thread for the other stuff! Thanks
    nomodeset is not a start menu selectable option. It is something you type in the options line. Its use is described in the 11.4 release notes.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •