Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: No Sax2 or xorg.conf - 11.4 x64

  1. #1

    Default No Sax2 or xorg.conf - 11.4 x64

    After installation, xorg.conf is missing. I am unable to create it with Sax2, as the /usr/X11R6/bin/ (and lib and lib64) directories are empty. This happens with both KDE and LXDE installs on 11.4 x64.

    I see that Sax2 is deprecated, however auto-detection is not working. Under 11.3 I created dummy devices in order to get VNC working as a guest within Citrix XenServer.

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: No Sax2 or xorg.conf - 11.4 x64

    Right. Though you can have an xorg.conf file in theory you don't need one.

    sax2 is old code was broken and no one wanted to support it. Besides in theory you should not need it

    Things have changed in the video stack.

    The propritary ATI and NVIDIA have utilities that will generate a xorg.conf file.

    Also setting are supposed to go into a set of files in etc/X11/xorg.conf.d directory

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: No Sax2 or xorg.conf - 11.4 x64

    On 03/25/2011 04:13 PM, Rick DeBay wrote:
    >
    > xorg.conf is missing. I am unable to create it with Sax2


    xorg.conf was been depreciated Linux wide, in favor of 'automatic'
    configuration

    Sax2 was dropped as openSUSE 11.2 (or maybe .1) was released, because
    it was hopelessly broken (or something like that) and when the
    community asked hackers to step up and fix/support it no one did..

    lots said about that which google can find..

    so, the question is: what is not working that you wanted to fix the
    old (pre 11.2/.1) way?

    i suspect graphics, if so something here should get you going:
    http://en.opensuse.org/SDB:Configuring_graphics_cards

    or post again..

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  4. #4

    Default Re: No Sax2 or xorg.conf - 11.4 x64

    On Friday 25 Mar 2011 15:36, gogalthorp scribbled:

    > sax2 is old code was broken and no one wanted to support it. Besides in
    > theory you should not need it


    But maybe there'll be Sax3?
    http://michal.hrusecky.net/2011/02/g...1-ideas-sax-3/

    --
    Graham Davis, Bracknell, UK.

  5. #5
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: No Sax2 or xorg.conf - 11.4 x64

    On 03/25/2011 05:06 PM, Cloddy wrote:

    > But maybe there'll be Sax3?


    GREAT!!
    i especially liked this part: "One feature that is also a little bit
    important is to make it distribution independent to make it easy for
    other distributions to use it, improve it and contribute back, so we
    will make a world better place for all of us."

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  6. #6

    Default Re: No Sax2 or xorg.conf - 11.4 x64

    I am installing as a guest under Citrix XenServer. Auto detection does not work, as there is no graphic console. With 11.3 I created a dummy device within xorg.conf, and that allowed VNC to work.

  7. #7
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: No Sax2 or xorg.conf - 11.4 x64

    On 03/25/2011 05:36 PM, Rick DeBay wrote:
    >
    > I am installing as a guest under Citrix XenServer. Auto detection does
    > not work, as there is no graphic console. With 11.3 I created a dummy
    > device within xorg.conf, and that allowed VNC to work.


    if you happen to have a nice backup that old xorg.conf, i _think_ if
    you put it in 11.4 (where it was in your previous version) it will
    "just work" (on the same hardware)...

    hmmmm....you might want to delete everything except that dummy device..

    NOTE: there is a good chance i do NOT know what i'm talking about
    <read my caveat below please>...there are however several post in
    these fora about how to force the system to build a xorg.conf, which
    (i understand) _will_ be read if found by the system and override the
    'automatic' configuration magic...

    but, i don't know how to do that..

    oh! maybe google knows:

    http://tinyurl.com/5vk558z
    http://tinyurl.com/67d69c7

    if those don't help maybe a real guru will happen along who can point
    you to the right place...or you might try some other version of this
    search string http://tinyurl.com/624e2vy

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,708
    Blog Entries
    1

    Default Re: No Sax2 or xorg.conf - 11.4 x64

    Here is a Citrix thread which may help you get a working X-server. It contains the required /etc/X11/xorg.conf entries:

    Now edit Xorg.conf. Change the device to use a dummy driver.

    Section "Device"
    BoardName "Graphics"
    Driver "dummy"
    Identifier "Device[0]"
    VendorName "Unclassified"
    EndSection

    Make sure there are settings for 8, 15, 16, or 24 bit depths.

    Section "Screen"
    SubSection "Display"
    Depth 24
    Modes "default"
    EndSubSection
    Device "Device[0]"
    Identifier "Screen[0]"
    Monitor "Monitor[0]"
    EndSection

    Edit the modes section. These are the settings for 1024x768 resolution.

    Modeline "1024x768" 53.08 1024 1056 1256 1288 768 784 791 807

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,708
    Blog Entries
    1

    Default Re: No Sax2 or xorg.conf - 11.4 x64

    This Citrix How To is for SLES 11, but should still be relevant as far as configuring the Xorg server is concerned.

  10. #10

    Default Re: No Sax2 or xorg.conf - 11.4 x64

    Quote Originally Posted by deano_ferrari View Post
    Here is a Citrix thread which may help you get a working X-server. It contains the required /etc/X11/xorg.conf entries:
    Yes, that was my post when I was trying to get 11.3 working. The beginning of my post states
    You need to run "Sax2 -a" to build the Xorg.conf file
    Since Sax2 is gone, I came here to find out what the developers planned as a fallback if auto-detect didn't work.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •