Results 1 to 8 of 8

Thread: Some kde apps won't work after downgrading 11.4->11.3

  1. #1

    Default Some kde apps won't work after downgrading 11.4->11.3

    Hi,

    after being not so satisfied with opensuse 11.4 (worked really slow at times), i decided to downgrade to 11.3. But now, some applications won't start.

    When starting personal kontact, i only got a notification that akonadi server is starting but it doesn't progress. Only thing I can do is to kill the app.Same for Clementine (amarok-like player), but here it doesn't even try to start.

    So, I was thinking to delete all the settings folders concerning these apps in my home folder, but it doesn't change anything. I did so by searching for *kmail* *kontact* and *clementine* and erased those folders. Could it be that I forgot some? Some folders under some different names? I'm not really experienced into this subject.

    Maybe there could also be a different cause of the problems with these specific programs?

    thanx in advance

  2. #2
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Some kde apps won't work after downgrading 11.4->11.3

    On 03/25/2011 11:06 AM, sonicboy wrote:
    >
    > i decided to downgrade to 11.3.


    how did you downgrade?

    i'm not aware of a way to downgrade from 11.4 to 11.3 and NOT have
    problems..


    > Maybe there could also be a different cause of the problems with these
    > specific programs?


    my guess would be a hosed system..

    unless you a better way to "downgrade" here is how i would do it on my
    machine:

    -backup all data to off machine medium
    -fresh format install the version desired
    -fully update it
    -install/update all applications desired
    -copy saved data to new system (note: this is NOT the same as copying
    in all configurations from your old home....do NOT do that...instead,
    copy in the data [music, movies, letters, emails, spreadsheets, etc
    etc etc]

    an even easier way would be to just restore from the full back up you
    made before you 'upgraded'..

    on the other hand, there are probably others here with different
    opinions...and, mine absolutely is an opinion (which differs from both
    fact and advice)

    --
    DenverD
    CAVEAT: http://is.gd/bpoMD
    [NNTP posted w/openSUSE 11.3, KDE4.5.5, Thunderbird3.1.8, nVidia
    173.14.28 3D, Athlon 64 3000+]
    "It is far easier to read, understand and follow the instructions than
    to undo the problems caused by not." DD 23 Jan 11

  3. #3

    Default Re: Some kde apps won't work after downgrading 11.4->11.3

    Although DenverD gives you actually proper way to "downgrade", i can imagine you wouldn't want to go through all that. In that case i would suggest to uninstall and then reinstall apps that you know that are not working.

  4. #4
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Some kde apps won't work after downgrading 11.4->11.3

    You could try running apps from konsole, e.g.: clementine,
    and see what comes out.
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

  5. #5
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Some kde apps won't work after downgrading 11.4->11.3

    On 2011-03-25 11:06, sonicboy wrote:
    >
    > Hi,
    >
    > after being not so satisfied with opensuse 11.4 (worked really slow at
    > times), i decided to downgrade to 11.3. But now, some applications won't
    > start.


    You should have restored the backup of 11.3 that you should have done prior
    to the upgrade. Doing a zypper dup to downgrade is not reliable.

    > So, I was thinking to delete all the settings folders concerning these
    > apps in my home folder, but it doesn't change anything. I did so by
    > searching for *kmail* *kontact* and *clementine* and erased those
    > folders. Could it be that I forgot some? Some folders under some
    > different names? I'm not really experienced into this subject.


    Try with a new user.

    > Maybe there could also be a different cause of the problems with these
    > specific programs?


    You would have to verify the entire list of packages, looking for packages
    coming from the wrong version, perhaps ssby judiciously using rpm -qa
    --queryformat ...

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  6. #6

    Default Re: Some kde apps won't work after downgrading 11.4->11.3

    This is output when starting clementine:

    Code:
    clementine: symbol lookup error: clementine: undefined symbol: _ZN9QListData11detach_growEPii
    and this for kontact:

    Code:
    Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)                                                                              
    Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)                                                                              
    [akonadiserver] search paths:  ("/usr/local/bin", "/usr/bin", "/bin", "/usr/bin/X11", "/usr/X11R6/bin", "/usr/games", "/usr/lib64/jvm/jre/bin", "/opt/real/RealPlayer", "/usr/sbin", "/usr/local/sbin", "/usr/local/libexec", "/usr/libexec", "/opt/mysql/libexec", "/opt/local/lib/mysql5/bin")                                                                        
    [akonadiserver] Found mysql_install_db:  "/usr/bin/mysql_install_db"                                                                                                                
    [akonadiserver] Found mysqlcheck:  "/usr/bin/mysqlcheck"                                                                                                                            
    Calling appendChild() on a null node does nothing.                                                                                                                                  
    Calling appendChild() on a null node does nothing.                                                                                                                                  
    Calling appendChild() on a null node does nothing.                                                                                                                                  
    Calling appendChild() on a null node does nothing.                                                                                                                                  
    Calling appendChild() on a null node does nothing.                                                                                                                                  
    Calling appendChild() on a null node does nothing.                                                                                                                                  
    Calling appendChild() on a null node does nothing.                                                                                                                                  
    Calling appendChild() on a null node does nothing.                                                                                                                                  
    Calling appendChild() on a null node does nothing.                                                                                                                                  
    Calling appendChild() on a null node does nothing.                                                                                                                                  
    "/usr/bin/kontact(5325)" Error in thread 140515016894304 : "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"                                                                                                                                                                        
    "/usr/bin/kontact(5325)" Error in thread 140515016894304 : "QLocalSocket::connectToServer: Invalid name"                                                                            
    "/usr/bin/kontact(5325)" Error in thread 140515016894304 : "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
    "/usr/bin/kontact(5325)" Error in thread 140515016894304 : "QLocalSocket::connectToServer: Invalid name"
    "/usr/bin/kontact(5325)" Error in thread 140515016894304 : "org.freedesktop.DBus.Error.ServiceUnknown - The name org.kde.nepomuk.services.nepomukstorage was not provided by any .service files"
    "/usr/bin/kontact(5325)" Error in thread 140515016894304 : "QLocalSocket::connectToServer: Invalid name"
    kontact(5325) KMKernel::recoverDeadLetters: Autosave directory "/home/wouter/.kde4/share/apps/kmail/autosave/cur" not found! 
    kontact(5325)/kdeui (kdelibs): No such XML file "/home/wouter/.kde4/share/apps/kontact/local-kmail.rc" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::init: Akonadi Client Session: connection config file ' akonadi/akonadiconnectionrc can not be found in ' "/home/wouter/.config" ' nor in any of  ("/etc/xdg", "/etc") 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/kio (KIOJob) KIO::TransferJob::slotData: mimetype() not emitted when sending first data!; job URL = KUrl("imaps://wjveenoo@mail.ugent.be:993/INBOX/;UID=243;SECTION=BODY.PEEK[]") data size = 960 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/kio (KIOJob) KIO::TransferJob::slotData: mimetype() not emitted when sending first data!; job URL = KUrl("imaps://wjveenoo@mail.ugent.be:993/INBOX/;UID=244;SECTION=BODY.PEEK[]") data size = 960 
    kontact(5325)/kio (KIOJob) KIO::TransferJob::slotData: mimetype() not emitted when sending first data!; job URL = KUrl("imaps://wjveenoo@mail.ugent.be:993/INBOX/;UID=245;SECTION=BODY.PEEK[]") data size = 955 
    kontact(5325)/kio (KIOJob) KIO::TransferJob::slotData: mimetype() not emitted when sending first data!; job URL = KUrl("imaps://wjveenoo@mail.ugent.be:993/INBOX/;UID=246;SECTION=BODY.PEEK[]") data size = 955 
    kontact(5325)/kio (KIOJob) KIO::TransferJob::slotData: mimetype() not emitted when sending first data!; job URL = KUrl("imaps://wjveenoo@mail.ugent.be:993/INBOX/;UID=247;SECTION=BODY.PEEK[]") data size = 955 
    kontact(5325)/kio (KIOJob) KIO::TransferJob::slotData: mimetype() not emitted when sending first data!; job URL = KUrl("imaps://wjveenoo@mail.ugent.be:993/INBOX/;UID=248;SECTION=BODY.PEEK[]") data size = 955 
    kontact(5325)/kio (KIOJob) KIO::TransferJob::slotData: mimetype() not emitted when sending first data!; job URL = KUrl("imaps://wjveenoo@mail.ugent.be:993/INBOX/;UID=249;SECTION=BODY.PEEK[]") data size = 953 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    <unknown program name>(5324)/: Communication problem with  "kontact" , it probably crashed. 
    Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken." " 
    
    wouter@linux-t8wp:~$ kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    kontact(5325)/libakonadi Akonadi::SessionPrivate::socketError: Socket error occurred: "QLocalSocket::connectToServer: Connection refused" 
    (This line repeats itself continuously)
    thanx for help

  7. #7
    Join Date
    Feb 2009
    Location
    Spain
    Posts
    25,547

    Default Re: Some kde apps won't work after downgrading 11.4->11.3

    On 2011-03-27 11:06, sonicboy wrote:

    > thanx for help


    You probably still have parts from 11.4

    --
    Cheers / Saludos,

    Carlos E. R.
    (from 11.2 x86_64 "Emerald" at Telcontar)

  8. #8
    Join Date
    Jun 2008
    Location
    Sogndal, Noreg
    Posts
    1,103

    Default Re: Some kde apps won't work after downgrading 11.4->11.3

    Create a new user and see what happens then. You could also try and delete the content of /tmp directory, but be cautious you should know what you are doing.
    OpenSuSE 13.1, KDE 4.11.5, 64bit
    Gigabyte 990FXA-UD3, AMD FX8350, MSI GeForce GTX 760, RME HDSP9632, 16GB HyperX Kingston DDR3, Samsung 840-Pro SSD 128GB, WD Desktop Black 1TB, Hitachi Deskstar 7K1000 750GB

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •