Results 1 to 3 of 3

Thread: Fix for Firefox acting slow on page look ups.

  1. #1
    Join Date
    Mar 2011
    Location
    Cleveland, TN
    Posts
    6

    Default Fix for Firefox acting slow on page look ups.

    Hello Everyone,

    On my system Firefox 4 seemed to be taking its sweet time "looking up" addresses, but when it found the page it blazed on the render.

    I poked around on the net and found a few suggestions to speed up the "look up". So I thought I would share... I aimed for the fewest changes, so not to break too many things or make a big mess...

    (Warning moving and changing things that you don't know about, in the about:config can goof up Firefox so double check your settings)

    place about:config in the address bar and hit enter

    You should get a really long list of things

    In the search bar put
    ‘network.dns.disableIPv6’

    My default value was set to false, go ahead and set it to true. Right click and Toggle.

    Clear out the search bar where ‘network.dns.disableIPv6’ was, and put in ‘network.http.pipelining’

    You should have three listings

    Right click on ‘network.http.pipelining’ and Toggle so "true" shows for the value.

    Next, right click on ‘network.http.pipelining.maxrequests’ and Modify, a box will pop up, replace the default 4 with 8.

    Close the about:config



    Now test your Forefox performance.

    These three small changes, made a world of difference for me. Its now comparably fast as chromium.

    If you disagree with what I did, or want to let me know of any other "safe" speedups let me know.


    PS. If you don't see any improvements performance-wise or your from the future and do use IPv6, it would be best to go and take these settings back to the default Firefox settings.

  2. #2
    PeeGee NNTP User

    Default Re: Fix for Firefox acting slow on page look ups.

    On 25/03/11 06:36, karlk79 wrote:
    >
    > Hello Everyone,
    >
    > On my system Firefox 4 seemed to be taking its sweet time "looking up"
    > addresses, but when it found the page it blazed on the render.
    >
    > I poked around on the net and found a few suggestions to speed up the
    > "look up". So I thought I would share... I aimed for the fewest changes,
    > so not to break too many things or make a big mess...
    >
    > (Warning moving and changing things that you don't know about, in the
    > about:config can goof up Firefox so double check your settings)
    >
    > place about:config in the address bar and hit enter
    >
    > You should get a really long list of things
    >
    > In the search bar put
    > ‘network.dns.disableIPv6’
    >
    > My default value was set to false, go ahead and set it to true. Right
    > click and Toggle.
    >
    > Clear out the search bar where ‘network.dns.disableIPv6’ was, and put
    > in ‘network.http.pipelining’
    >
    > You should have three listings
    >
    > Right click on ‘network.http.pipelining’ and Toggle so "true" shows for
    > the value.
    >
    > Next, right click on ‘network.http.pipelining.maxrequests’ and Modify,
    > a box will pop up, replace the default 4 with 8.
    >
    > Close the about:config
    >
    >
    >
    > Now test your Forefox performance.
    >
    > These three small changes, made a world of difference for me. Its now
    > comparably fast as chromium.
    >
    > If you disagree with what I did, or want to let me know of any other
    > "safe" speedups let me know.
    >
    >
    > PS. If you don't see any improvements performance-wise or your from the
    > future and do use IPv6, it would be best to go and take these settings
    > back to the default Firefox settings.
    >
    >


    I found that using ‘network.http.pipelining’ set to 'true' for one
    (banking) web site I visit regularly caused random rendering failures
    with FF3.x (refresh often cleared the problem), so I now use two
    profiles - one with, one without :-) Haven't put FF4 on this system as I
    don't consider it 'fit for purpose' yet :-(

    --
    PeeGee

    MSI m/b 870-C45, AMD Athlon II X3 445, 4GB, openSUSE 11.3/11.2 x86_64
    dual boot + XP Home in VBox
    Asus m/b M2NPV-VM, AMD 64X2 3800+, 2GB, openSUSE 11.3 x86_64/XP Home
    dual boot
    Acer Aspire 1350, AMD (M)XP2400+, 768MB, openSUSE 11.2/XP Home dual boot
    Asus eeePC 4G (701), Celeron M353, 2GB, openSUSE 11.3 on SSD

  3. #3
    Join Date
    Jun 2008
    Location
    Earth - Denmark
    Posts
    10,730

    Default Re: Fix for Firefox acting slow on page look ups.

    good job!! works great...thanks for finding and posting for others to use!!
    DD
    Caveat: http://is.gd/bpoMD
    Posted via http.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •